summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2010-11-21 13:23:46 +0000
committerDaniel Pielmeier <billie@gentoo.org>2010-11-21 13:23:46 +0000
commit91786586d313a74ed174861397081ef8d3d7ed52 (patch)
tree29b03d1ac581d093d60bfdea925d2b01792b41a3 /app-portage
parentreplaced by vmware-modules-235 (in overlay) (diff)
downloadgentoo-2-91786586d313a74ed174861397081ef8d3d7ed52.tar.gz
gentoo-2-91786586d313a74ed174861397081ef8d3d7ed52.tar.bz2
gentoo-2-91786586d313a74ed174861397081ef8d3d7ed52.zip
Version bump.
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/ChangeLog9
-rw-r--r--app-portage/pfl/pfl-2.1.ebuild72
2 files changed, 80 insertions, 1 deletions
diff --git a/app-portage/pfl/ChangeLog b/app-portage/pfl/ChangeLog
index 6f84aa26fa79..aa86725bc2ba 100644
--- a/app-portage/pfl/ChangeLog
+++ b/app-portage/pfl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/pfl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.16 2010/11/20 10:36:03 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.17 2010/11/21 13:23:46 billie Exp $
+
+*pfl-2.1 (21 Nov 2010)
+
+ 21 Nov 2010; Daniel Pielmeier <billie@gentoo.org> +pfl-2.1.ebuild:
+ Version bump. Only information from the offical Gentoo repository is
+ submitted, overlays are excluded from now on. Works with portage-2.2.*, Fixes
+ bug #346165, thanks Dan Johansson for reporting.
20 Nov 2010; Michael Weber <xmw@gentoo.org> pfl-2.0.ebuild:
Added ~sparc keyword
diff --git a/app-portage/pfl/pfl-2.1.ebuild b/app-portage/pfl/pfl-2.1.ebuild
new file mode 100644
index 000000000000..cd383ca71a5b
--- /dev/null
+++ b/app-portage/pfl/pfl-2.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-2.1.ebuild,v 1.1 2010/11/21 13:23:46 billie Exp $
+
+EAPI=3
+
+PYTHON_DEPEND=2
+
+inherit python
+
+MY_PV=20081230
+
+DESCRIPTION="PFL is an online searchable file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de/index.php/Special:PFLQuery2"
+SRC_URI="http://files.portagefilelist.de/${P}
+ http://files.portagefilelist.de/e-file-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE="network-cron"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/pyxml
+ net-misc/curl
+ sys-apps/portage"
+
+RESTRICT="mirror"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_unpack() {
+ cp "${DISTDIR}/${P}" "${WORKDIR}/${PN}.py"
+ cp "${DISTDIR}/e-file-${MY_PV}" "${WORKDIR}/e-file"
+}
+
+src_install() {
+ if use network-cron ; then
+ cat >> "${T}/${PN}" <<- EOF
+ #!/bin/sh
+ exec nice $(PYTHON) -O $(python_get_sitedir)/${PN}/${PN}.py >/dev/null
+ EOF
+
+ exeinto /etc/cron.weekly
+ doexe "${T}/${PN}" || die
+ fi
+
+ exeinto $(python_get_sitedir)/${PN}
+ doexe ${PN}.py || die
+
+ dobin e-file || die
+
+ dodir /var/lib/${PN} || die
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+
+ if [[ ! -e "${ROOT%/}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${ROOT%/}/var/lib/${PN}/pfl.info"
+ chown -R 0:portage "${ROOT%/}/var/lib/${PN}"
+ chmod 775 "${ROOT%/}/var/lib/${PN}"
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}