summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-15 13:06:12 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-15 13:06:12 +0000
commit94faa556df9159b71829b5393023543517a059f2 (patch)
tree84acf6f63e8283437e35bd3a8bacb515df175d0b /app-portage
parentx86 stable wrt bug #351323 (diff)
downloadgentoo-2-94faa556df9159b71829b5393023543517a059f2.tar.gz
gentoo-2-94faa556df9159b71829b5393023543517a059f2.tar.bz2
gentoo-2-94faa556df9159b71829b5393023543517a059f2.zip
Version bump. The new version introduces preliminary support for global (make.conf) actions.
(Portage version: 2.2.0_alpha15_p1/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/flaggie/ChangeLog9
-rw-r--r--app-portage/flaggie/flaggie-0.1.ebuild (renamed from app-portage/flaggie/flaggie-0.0.3.ebuild)19
2 files changed, 22 insertions, 6 deletions
diff --git a/app-portage/flaggie/ChangeLog b/app-portage/flaggie/ChangeLog
index 13e36e33913c..99da001a32d5 100644
--- a/app-portage/flaggie/ChangeLog
+++ b/app-portage/flaggie/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/flaggie
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/ChangeLog,v 1.14 2011/01/08 10:22:02 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/ChangeLog,v 1.15 2011/01/15 13:06:12 mgorny Exp $
+
+*flaggie-0.1 (15 Jan 2011)
+
+ 15 Jan 2011; Michał Górny <mgorny@gentoo.org> -flaggie-0.0.3.ebuild,
+ +flaggie-0.1.ebuild:
+ Version bump. The new version introduces preliminary support for global
+ (make.conf) actions.
08 Jan 2011; Michał Górny <mgorny@gentoo.org> flaggie-0.0.4.ebuild:
Use bash-completion.eclass.
diff --git a/app-portage/flaggie/flaggie-0.0.3.ebuild b/app-portage/flaggie/flaggie-0.1.ebuild
index 59ed0301bbb2..2614fc7a06c1 100644
--- a/app-portage/flaggie/flaggie-0.0.3.ebuild
+++ b/app-portage/flaggie/flaggie-0.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/flaggie-0.0.3.ebuild,v 1.5 2011/01/06 15:51:12 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/flaggie-0.1.ebuild,v 1.1 2011/01/15 13:06:12 mgorny Exp $
EAPI=3
PYTHON_DEPEND="*:2.6"
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="2.4 2.5"
-inherit base distutils
+inherit base bash-completion distutils
DESCRIPTION="A smart CLI mangler for package.* files"
HOMEPAGE="https://github.com/mgorny/flaggie/"
@@ -25,10 +25,19 @@ src_prepare() {
distutils_src_prepare
}
+src_install() {
+ distutils_src_install
+
+ dobashcompletion contrib/bash-completion/${PN}.bash-completion || die
+}
+
pkg_postinst() {
distutils_pkg_postinst
- ewarn "Please notice that flaggie is a fairly young project, and can definitely"
- ewarn "be buggy. It is suggested that you backup your package.* files before"
- ewarn "using it for the first time to prevent potential data loss."
+ ewarn "Please denote that flaggie creates backups of your package.* files"
+ ewarn "before performing each change through appending a single '~'."
+ ewarn "If you'd like to keep your own backup of them, please use another"
+ ewarn "naming scheme (or even better some VCS)."
+
+ bash-completion_pkg_postinst
}