summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-06-26 12:50:00 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-06-26 12:50:00 +0000
commit959c12375ce5b0b6a0da3c845b5d808a0ec7f7ec (patch)
tree05ea9d7ea52996812f07b9539f0d1e5d5fa3f4cf /app-portage
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-959c12375ce5b0b6a0da3c845b5d808a0ec7f7ec.tar.gz
gentoo-2-959c12375ce5b0b6a0da3c845b5d808a0ec7f7ec.tar.bz2
gentoo-2-959c12375ce5b0b6a0da3c845b5d808a0ec7f7ec.zip
Minor version bump, default to SAVE_WORLD=true and build system changes
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog8
-rw-r--r--app-portage/eix/eix-0.16.2.ebuild (renamed from app-portage/eix/eix-0.15.7.ebuild)18
2 files changed, 22 insertions, 4 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index cb7ab6ed7476..8c62940cee60 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.290 2009/06/19 22:06:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.291 2009/06/26 12:50:00 darkside Exp $
+
+*eix-0.16.2 (26 Jun 2009)
+
+ 26 Jun 2009; Jeremy Olexa <darkside@gentoo.org> -eix-0.15.7.ebuild,
+ +eix-0.16.2.ebuild:
+ Minor version bump, default to SAVE_WORLD=true and build system changes
19 Jun 2009; Brent Baude <ranger@gentoo.org> eix-0.16.0.ebuild:
stable ppc64, bug 273555
diff --git a/app-portage/eix/eix-0.15.7.ebuild b/app-portage/eix/eix-0.16.2.ebuild
index 13ece035cbab..9d97bbc45caf 100644
--- a/app-portage/eix/eix-0.15.7.ebuild
+++ b/app-portage/eix/eix-0.16.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.15.7.ebuild,v 1.1 2009/04/20 14:34:54 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.16.2.ebuild,v 1.1 2009/06/26 12:50:00 darkside Exp $
inherit multilib
@@ -12,16 +12,19 @@ SRC_URI="mirror://sourceforge/eix/${P}.tar.lzma"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="doc sqlite"
+IUSE="doc nls sqlite tools"
RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
app-arch/bzip2"
DEPEND="${RDEPEND}
app-arch/lzma-utils
- doc? ( dev-python/docutils )"
+ doc? ( dev-python/docutils )
+ nls? ( sys-devel/gettext )"
src_compile() {
econf --with-bzip2 $(use_with sqlite) $(use_with doc rst) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
--with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
--with-portage-rootpath="${ROOTPATH}"
emake || die "emake failed"
@@ -35,10 +38,19 @@ src_install() {
}
pkg_postinst() {
+ elog "Ask your overlay maintainers to provide metadata or consider to run"
+ elog " egencache --repo=foo --update"
+ elog "after updates (e.g. in /etc/eix-sync)."
+ elog "This will speed up portage and update-eix (when the new default cache method"
+ elog "\"...#metadata-flat\" is used and file dates are correct) for those overlays."
+ elog "If metadata is provided but file dates are mangled during overlay updates,"
+ elog "you may switch to cache method \"metadata-flat\" instead for that overlay:"
+ elog "This is even faster, but works only if metadata is actually up-to-date."
ewarn
ewarn "Security Warning:"
ewarn
ewarn "Since >=eix-0.12.0, eix uses by default OVERLAY_CACHE_METHOD=\"parse|ebuild*\""
+ ewarn "(since >=eix-0.16.1 with automagic \"#metadata-flat\")."
ewarn "This is rather reliable, but ebuilds may be executed by user \"portage\". Set"
ewarn "OVERLAY_CACHE_METHOD=parse in /etc/eixrc if you do not trust the ebuilds."
if test -d /var/log && ! test -x /var/log || test -e /var/log/eix-sync.log