summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2012-03-10 23:34:58 +0000
committerBrian Dolbec <dolsen@gentoo.org>2012-03-10 23:34:58 +0000
commit988b1f458313ab586fb623204cd6118279bcf710 (patch)
treeee1b481c878001653acba8bc49f388392dc0155c /app-portage
parentmarked x86 per bug 407673 (diff)
downloadgentoo-2-988b1f458313ab586fb623204cd6118279bcf710.tar.gz
gentoo-2-988b1f458313ab586fb623204cd6118279bcf710.tar.bz2
gentoo-2-988b1f458313ab586fb623204cd6118279bcf710.zip
update 1.4* python dependency, remove old rc's
(Portage version: 2.2.0_alpha84_p31/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/layman/ChangeLog9
-rw-r--r--app-portage/layman/files/layman-2.0.0_rc1-fix-mistracking-success.patch69
-rw-r--r--app-portage/layman/layman-1.4.1.ebuild7
-rw-r--r--app-portage/layman/layman-1.4.2-r2.ebuild7
-rw-r--r--app-portage/layman/layman-2.0.0_rc1-r1.ebuild92
-rw-r--r--app-portage/layman/layman-2.0.0_rc2.ebuild89
6 files changed, 16 insertions, 257 deletions
diff --git a/app-portage/layman/ChangeLog b/app-portage/layman/ChangeLog
index b397ca2f3219..d6a7503eb823 100644
--- a/app-portage/layman/ChangeLog
+++ b/app-portage/layman/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/layman
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.149 2012/01/04 01:27:17 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.150 2012/03/10 23:34:58 dolsen Exp $
+
+ 10 Mar 2012; Brian Dolbec <dolsen@gentoo.org> layman-1.4.1.ebuild,
+ layman-1.4.2-r2.ebuild, -layman-2.0.0_rc1-r1.ebuild,
+ -layman-2.0.0_rc2.ebuild,
+ -files/layman-2.0.0_rc1-fix-mistracking-success.patch:
+ Update the python dependency for the 1.4* versions, fixes bug 399167.
+ Remove old rc candidates.
04 Jan 2012; Christian Ruppert <idl0r@gentoo.org> metadata.xml:
Brian Dolbec is the new primary maintainer of layman
diff --git a/app-portage/layman/files/layman-2.0.0_rc1-fix-mistracking-success.patch b/app-portage/layman/files/layman-2.0.0_rc1-fix-mistracking-success.patch
deleted file mode 100644
index 7645b56525df..000000000000
--- a/app-portage/layman/files/layman-2.0.0_rc1-fix-mistracking-success.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From c5c3121331d8f2f2b39b8f41b91d705d197be250 Mon Sep 17 00:00:00 2001
-From: dol-sen <brian.dolbec@gmail.com>
-Date: Tue, 12 Jul 2011 12:01:43 -0700
-Subject: [PATCH] fix mistracking success adding an overlay.
-
----
- layman/api.py | 17 +++++++++--------
- layman/db.py | 4 +++-
- 2 files changed, 12 insertions(+), 9 deletions(-)
-
-diff --git a/layman/api.py b/layman/api.py
-index 8e54d7d..a924ead 100644
---- a/layman/api.py
-+++ b/layman/api.py
-@@ -114,14 +114,14 @@ class LaymanAPI(object):
- self._error("Repository '"+ovl+"' was not installed")
- results.append(False)
- continue
-+ success = False
- try:
-- self._get_installed_db().delete(
-+ success = self._get_installed_db().delete(
- self._get_installed_db().select(ovl))
-- results.append(True)
- except Exception as e:
- self._error(
-- "Failed to disable repository '"+ovl+"':\n"+str(e))
-- results.append(False)
-+ "Exception caught disabling repository '"+ovl+"':\n"+str(e))
-+ results.append(success)
- self.get_installed(dbreload=True)
- if False in results:
- return False
-@@ -147,12 +147,13 @@ class LaymanAPI(object):
- self._error(UnknownOverlayMessage(ovl))
- results.append(False)
- continue
-+ success = False
- try:
-- self._get_installed_db().add(self._get_remote_db().select(ovl), quiet=True)
-- results.append(True)
-+ success = self._get_installed_db().add(
-+ self._get_remote_db().select(ovl), quiet=True)
- except Exception as e:
-- self._error("Failed to enable repository '"+ovl+"' : "+str(e))
-- results.append(False)
-+ self._error("Exception caught enabling repository '"+ovl+"' : "+str(e))
-+ results.append(success)
- self.get_installed(dbreload=True)
- if False in results:
- return False
-diff --git a/layman/db.py b/layman/db.py
-index 3ed5cc6..b1df906 100644
---- a/layman/db.py
-+++ b/layman/db.py
-@@ -206,7 +206,9 @@ class DB(DbBase):
- self.write(self.path)
- make_conf.delete(overlay)
- else:
-- raise Exception('No local overlay named "' + overlay.name + '"!')
-+ self.output.error('No local overlay named "' + overlay.name + '"!')
-+ return False
-+ return True
-
- def sync(self, overlay_name, quiet = False):
- '''Synchronize the given overlay.'''
---
-1.7.6
-
diff --git a/app-portage/layman/layman-1.4.1.ebuild b/app-portage/layman/layman-1.4.1.ebuild
index d79feb61d572..ea4bd15f57a3 100644
--- a/app-portage/layman/layman-1.4.1.ebuild
+++ b/app-portage/layman/layman-1.4.1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-1.4.1.ebuild,v 1.10 2011/07/09 11:23:47 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-1.4.1.ebuild,v 1.11 2012/03/10 23:34:58 dolsen Exp $
EAPI="2"
PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="xml"
inherit eutils distutils
@@ -17,7 +18,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="bazaar cvs darcs git mercurial subversion test"
-COMMON_DEPS="dev-lang/python[xml]"
+COMMON_DEPS="dev-lang/python"
DEPEND="${COMMON_DEPS}
test? ( dev-vcs/subversion )"
RDEPEND="${COMMON_DEPS}
diff --git a/app-portage/layman/layman-1.4.2-r2.ebuild b/app-portage/layman/layman-1.4.2-r2.ebuild
index 454743cc330b..e5fde374c0de 100644
--- a/app-portage/layman/layman-1.4.2-r2.ebuild
+++ b/app-portage/layman/layman-1.4.2-r2.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-1.4.2-r2.ebuild,v 1.1 2011/04/28 03:25:03 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-1.4.2-r2.ebuild,v 1.2 2012/03/10 23:34:58 dolsen Exp $
EAPI="2"
PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="xml"
inherit eutils distutils
@@ -17,7 +18,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="bazaar cvs darcs git mercurial subversion test"
-COMMON_DEPS="dev-lang/python[xml]"
+COMMON_DEPS="dev-lang/python"
DEPEND="${COMMON_DEPS}
test? ( dev-vcs/subversion )"
RDEPEND="${COMMON_DEPS}
diff --git a/app-portage/layman/layman-2.0.0_rc1-r1.ebuild b/app-portage/layman/layman-2.0.0_rc1-r1.ebuild
deleted file mode 100644
index fd2ca660d2a7..000000000000
--- a/app-portage/layman/layman-2.0.0_rc1-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-2.0.0_rc1-r1.ebuild,v 1.6 2011/08/08 16:28:35 darkside Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.6"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
-
-inherit eutils distutils prefix
-
-DESCRIPTION="Tool to manage Gentoo overlays"
-HOMEPAGE="http://layman.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="bazaar cvs darcs git mercurial subversion test"
-
-COMMON_DEPS="dev-lang/python[xml]"
-DEPEND="${COMMON_DEPS}
- test? ( dev-vcs/subversion )"
-RDEPEND="${COMMON_DEPS}
- bazaar? ( dev-vcs/bzr )
- cvs? ( dev-vcs/cvs )
- darcs? ( dev-vcs/darcs )
- git? ( dev-vcs/git )
- mercurial? ( dev-vcs/mercurial )
- subversion? (
- || (
- >=dev-vcs/subversion-1.5.4[webdav-neon]
- >=dev-vcs/subversion-1.5.4[webdav-serf]
- )
- )"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-fix-mistracking-success.patch"
- sed -i -e 's#/var/lib/layman#@GENTOO_PORTAGE_EPREFIX@/var/lib/layman#' etc/layman.cfg || die
- eprefixify etc/layman.cfg
-}
-
-src_test() {
- testing() {
- for suite in layman/tests/{dtest,external}.py ; do
- PYTHONPATH="." "$(PYTHON)" ${suite} \
- || die "test suite '${suite}' failed"
- done
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- insinto /etc/layman
- doins etc/layman.cfg || die
-
- doman doc/layman.8
- dohtml doc/layman.8.html
-
- keepdir /var/lib/layman
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- einfo "You are now ready to add overlays into your system."
- einfo
- einfo " layman -L"
- einfo
- einfo "will display a list of available overlays."
- einfo
- elog "Select an overlay and add it using"
- elog
- elog " layman -a overlay-name"
- elog
- elog "If this is the very first overlay you add with layman,"
- elog "you need to append the following statement to your"
- elog "/etc/make.conf file:"
- elog
- elog " source /var/lib/layman/make.conf"
- elog
- elog "If you modify the 'storage' parameter in the layman"
- elog "configuration file (/etc/layman/layman.cfg) you will"
- elog "need to adapt the path given above to the new storage"
- elog "directory."
- elog
- ewarn "Please add the 'source' statement to make.conf only AFTER "
- ewarn "you added your first overlay. Otherwise portage will fail."
-}
diff --git a/app-portage/layman/layman-2.0.0_rc2.ebuild b/app-portage/layman/layman-2.0.0_rc2.ebuild
deleted file mode 100644
index 683bbb67a7e1..000000000000
--- a/app-portage/layman/layman-2.0.0_rc2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-2.0.0_rc2.ebuild,v 1.1 2011/08/11 20:06:16 fuzzyray Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.6"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit eutils distutils prefix
-
-DESCRIPTION="Tool to manage Gentoo overlays"
-HOMEPAGE="http://layman.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="bazaar cvs darcs git mercurial subversion test"
-
-COMMON_DEPS="dev-lang/python[xml]"
-DEPEND="${COMMON_DEPS}
- test? ( dev-vcs/subversion )"
-RDEPEND="${COMMON_DEPS}
- bazaar? ( dev-vcs/bzr )
- cvs? ( dev-vcs/cvs )
- darcs? ( dev-vcs/darcs )
- git? ( dev-vcs/git )
- mercurial? ( dev-vcs/mercurial )
- subversion? (
- || (
- >=dev-vcs/subversion-1.5.4[webdav-neon]
- >=dev-vcs/subversion-1.5.4[webdav-serf]
- )
- )"
-
-src_prepare() {
- eprefixify etc/layman.cfg layman/config.py
-}
-
-src_test() {
- testing() {
- for suite in layman/tests/{dtest,external}.py ; do
- PYTHONPATH="." "$(PYTHON)" ${suite} \
- || die "test suite '${suite}' failed"
- done
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- insinto /etc/layman
- doins etc/layman.cfg || die
-
- doman doc/layman.8
- dohtml doc/layman.8.html
-
- keepdir /var/lib/layman
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- einfo "You are now ready to add overlays into your system."
- einfo
- einfo " layman -L"
- einfo
- einfo "will display a list of available overlays."
- einfo
- elog "Select an overlay and add it using"
- elog
- elog " layman -a overlay-name"
- elog
- elog "If this is the very first overlay you add with layman,"
- elog "you need to append the following statement to your"
- elog "/etc/make.conf file:"
- elog
- elog " source /var/lib/layman/make.conf"
- elog
- elog "If you modify the 'storage' parameter in the layman"
- elog "configuration file (/etc/layman/layman.cfg) you will"
- elog "need to adapt the path given above to the new storage"
- elog "directory."
- elog
- ewarn "Please add the 'source' statement to make.conf only AFTER "
- ewarn "you added your first overlay. Otherwise portage will fail."
-}