summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-01-04 20:32:23 +0000
committerSebastian Pipping <sping@gentoo.org>2010-01-04 20:32:23 +0000
commita509eb3226d700be251054545ffc2ab8a0e04d70 (patch)
tree2601f857fea39c6e6318db22f3a7cda14c78a51f /app-portage
parentUpstream renamed the "trunk" to "emacs-23". (diff)
downloadgentoo-2-a509eb3226d700be251054545ffc2ab8a0e04d70.tar.gz
gentoo-2-a509eb3226d700be251054545ffc2ab8a0e04d70.tar.bz2
gentoo-2-a509eb3226d700be251054545ffc2ab8a0e04d70.zip
app-portage/layman: Bump to 1.2.5
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/layman/ChangeLog7
-rw-r--r--app-portage/layman/layman-1.2.5.ebuild96
2 files changed, 102 insertions, 1 deletions
diff --git a/app-portage/layman/ChangeLog b/app-portage/layman/ChangeLog
index 3e1ff98d3bc2..53af435d0e77 100644
--- a/app-portage/layman/ChangeLog
+++ b/app-portage/layman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/layman
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.86 2010/01/04 20:20:27 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.87 2010/01/04 20:32:23 sping Exp $
+
+*layman-1.2.5 (04 Jan 2010)
+
+ 04 Jan 2010; Sebastian Pipping <sping@gentoo.org> +layman-1.2.5.ebuild:
+ Bump to 1.2.5
04 Jan 2010; Sebastian Pipping <sping@gentoo.org> layman-9999.ebuild:
Propagate upstream changes to live ebuild
diff --git a/app-portage/layman/layman-1.2.5.ebuild b/app-portage/layman/layman-1.2.5.ebuild
new file mode 100644
index 000000000000..6236a83788e6
--- /dev/null
+++ b/app-portage/layman/layman-1.2.5.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-1.2.5.ebuild,v 1.1 2010/01/04 20:32:23 sping Exp $
+
+EAPI="2"
+NEED_PYTHON=2.5
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils distutils
+
+DESCRIPTION="A python script for retrieving gentoo overlays."
+HOMEPAGE="http://layman.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="git subversion test"
+
+COMMON_DEPS="dev-lang/python[xml]"
+DEPEND="${COMMON_DEPS}
+ test? ( dev-util/subversion )"
+RDEPEND="${COMMON_DEPS}
+ git? ( dev-util/git )
+ subversion? (
+ || (
+ >=dev-util/subversion-1.5.4[webdav-neon]
+ >=dev-util/subversion-1.5.4[webdav-serf]
+ )
+ )"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+pkg_setup() {
+ if ! has_version dev-util/subversion; then
+ ewarn "You do not have dev-util/subversion installed!"
+ ewarn "While layman does not exactly depend on this"
+ ewarn "version control system you should note that"
+ ewarn "most available overlays are offered via"
+ ewarn "dev-util/subversion. If you do not install it"
+ ewarn "you will be unable to use these overlays."
+ ewarn
+ fi
+}
+
+src_test() {
+ testing() {
+ # external.py missing in 1.2.5 release tarball ..
+ for suite in layman/tests/dtest.py ; do
+ PYTHONPATH="." "$(PYTHON)" ${suite} \
+ || die "test suite '${suite}' failed"
+ done
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir /etc/layman
+
+ cp etc/* "${D}"/etc/layman/
+
+ doman doc/layman.8
+ dohtml doc/layman.8.html
+
+ keepdir /usr/local/portage/layman
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo "You are now ready to add overlays into your system."
+ einfo
+ einfo "layman -L"
+ einfo
+ einfo "will display a list of available overlays."
+ einfo
+ elog "Select an overlay and add it using"
+ einfo
+ elog "layman -a overlay-name"
+ einfo
+ elog "If this is the very first overlay you add with layman,"
+ elog "you need to append the following statement to your"
+ elog "/etc/make.conf file:"
+ elog
+ elog "source /usr/local/portage/layman/make.conf"
+ elog
+ elog "If you modify the 'storage' parameter in the layman"
+ elog "configuration file (/etc/layman/layman.cfg) you will"
+ elog "need to adapt the path given above to the new storage"
+ elog "directory."
+ einfo
+ ewarn "Please add the 'source' statement to make.conf only AFTER "
+ ewarn "you added your first overlay. Otherwise portage will fail."
+ epause 5
+}