summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-04-17 15:58:50 +0000
committerMichał Górny <mgorny@gentoo.org>2012-04-17 15:58:50 +0000
commitae3ea49d38f6e9e22f3666da82e405b275e0a8bc (patch)
treed7098076ed57721cd198c30d06e341104fb39f08 /app-portage
parentVersion bumped. Removed old versions. (diff)
downloadgentoo-2-ae3ea49d38f6e9e22f3666da82e405b275e0a8bc.tar.gz
gentoo-2-ae3ea49d38f6e9e22f3666da82e405b275e0a8bc.tar.bz2
gentoo-2-ae3ea49d38f6e9e22f3666da82e405b275e0a8bc.zip
Version bump. The new version fixes issues with timeout support in -j1 and Python 2.6 compatibility.
(Portage version: 2.2.0_alpha100_p9/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/ChangeLog9
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.0.1.ebuild39
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.2.2.ebuild40
3 files changed, 48 insertions, 40 deletions
diff --git a/app-portage/smart-live-rebuild/ChangeLog b/app-portage/smart-live-rebuild/ChangeLog
index 2a76b2eeadfe..518db0c6acf6 100644
--- a/app-portage/smart-live-rebuild/ChangeLog
+++ b/app-portage/smart-live-rebuild/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/smart-live-rebuild
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.34 2012/02/09 23:56:08 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.35 2012/04/17 15:58:50 mgorny Exp $
+
+*smart-live-rebuild-1.2.2 (17 Apr 2012)
+
+ 17 Apr 2012; Michał Górny <mgorny@gentoo.org>
+ -smart-live-rebuild-1.0.1.ebuild, +smart-live-rebuild-1.2.2.ebuild:
+ Version bump. The new version fixes issues with timeout support in -j1 and
+ Python 2.6 compatibility.
09 Feb 2012; Matt Turner <mattst88@gentoo.org>
smart-live-rebuild-1.2.1.ebuild:
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.0.1.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.0.1.ebuild
deleted file mode 100644
index 3f7381e4cf42..000000000000
--- a/app-portage/smart-live-rebuild/smart-live-rebuild-1.0.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/smart-live-rebuild-1.0.1.ebuild,v 1.1 2011/06/27 10:03:39 mgorny Exp $
-
-EAPI=3
-
-PYTHON_DEPEND='*:2.6'
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS='2.4 2.5'
-#DISTUTILS_SRC_TEST=setup.py # tests fail with py3k right now
-
-inherit base distutils
-
-DESCRIPTION="Check live packages for updates and emerge them as necessary"
-HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
-SRC_URI="http://cloud.github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=sys-apps/portage-2.1.8.3"
-
-PYTHON_MODNAME=smartliverebuild
-
-src_prepare() {
- base_src_prepare
- distutils_src_prepare
-}
-
-src_install() {
- distutils_src_install
-
- insinto /etc/portage
- newins smart-live-rebuild.conf{.example,} || die
- insinto /usr/share/portage/config/sets
- newins sets.conf.example ${PN}.conf || die
-}
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.2.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.2.ebuild
new file mode 100644
index 000000000000..7879246ace38
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/smart-live-rebuild-1.2.2.ebuild,v 1.1 2012/04/17 15:58:50 mgorny Exp $
+
+EAPI=4
+
+PYTHON_DEPEND='2:2.6'
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+DISTUTILS_SRC_TEST=setup.py
+
+inherit base distutils
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://bitbucket.org/mgorny/smart-live-rebuild/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1
+ !sys-apps/portage[python3]"
+
+PYTHON_MODNAME=smartliverebuild
+
+src_prepare() {
+ base_src_prepare
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf
+}