summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2011-10-21 13:30:08 +0000
committerMike Pagano <mpagano@gentoo.org>2011-10-21 13:30:08 +0000
commitd95fd6bdc5ace2b84203111f59d299b0566c93c7 (patch)
tree2b5055190f5a0bb63af5bfcdc54328365881a1b5 /app-portage
parentFix line handling if package is not installed and contains special character.... (diff)
downloadgentoo-2-d95fd6bdc5ace2b84203111f59d299b0566c93c7.tar.gz
gentoo-2-d95fd6bdc5ace2b84203111f59d299b0566c93c7.tar.bz2
gentoo-2-d95fd6bdc5ace2b84203111f59d299b0566c93c7.zip
Fix line handling if package is not installed and contains special character. Add parameter to ask the user for confirmation before modifiying package files. Update man page for fix-confirm functionality.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portpeek/ChangeLog9
-rw-r--r--app-portage/portpeek/portpeek-2.0.13.ebuild34
2 files changed, 42 insertions, 1 deletions
diff --git a/app-portage/portpeek/ChangeLog b/app-portage/portpeek/ChangeLog
index a86d6a130011..68b8eec4a7bd 100644
--- a/app-portage/portpeek/ChangeLog
+++ b/app-portage/portpeek/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/portpeek
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/ChangeLog,v 1.122 2011/10/21 13:27:24 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/ChangeLog,v 1.123 2011/10/21 13:30:08 mpagano Exp $
+
+*portpeek-2.0.13 (21 Oct 2011)
+
+ 21 Oct 2011; Michael Pagano <mpagano@gentoo.org> +portpeek-2.0.13.ebuild:
+ Fix line handling if package is not installed and contains special character.
+ Add parameter to ask the user for confirmation before modifiying package
+ files. Update man page for fix-confirm functionality.
*portpeek-1.9.74 (21 Oct 2011)
diff --git a/app-portage/portpeek/portpeek-2.0.13.ebuild b/app-portage/portpeek/portpeek-2.0.13.ebuild
new file mode 100644
index 000000000000..cb5a2f1126b7
--- /dev/null
+++ b/app-portage/portpeek/portpeek-2.0.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/portpeek-2.0.13.ebuild,v 1.1 2011/10/21 13:30:08 mpagano Exp $
+
+EAPI="2"
+PYTHON_DEPEND="3"
+
+inherit eutils python
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-portage/gentoolkit-0.3.0.4
+ >=sys-apps/portage-2.1.10.11"
+
+pkg_setup() {
+ python_set_active_version 3
+}
+
+src_prepare() {
+ python_convert_shebangs 3 portpeek
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ doman *.[0-9]
+}