summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2008-02-21 18:30:36 +0000
committerStefan Schweizer <genstef@gentoo.org>2008-02-21 18:30:36 +0000
commitdfd25314353e387a55d0e60c2df2848f61eea3b8 (patch)
tree2f46489e310643c69cabd2b923e5849bf14228f5 /app-portage
parentCleaning up random foo to make repoman fully happy (diff)
downloadgentoo-2-dfd25314353e387a55d0e60c2df2848f61eea3b8.tar.gz
gentoo-2-dfd25314353e387a55d0e60c2df2848f61eea3b8.tar.bz2
gentoo-2-dfd25314353e387a55d0e60c2df2848f61eea3b8.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/eix-0.10.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/eix/eix-0.10.5.ebuild b/app-portage/eix/eix-0.10.5.ebuild
new file mode 100644
index 000000000000..157ba74f72d0
--- /dev/null
+++ b/app-portage/eix/eix-0.10.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.10.5.ebuild,v 1.1 2008/02/21 18:30:36 genstef Exp $
+
+DESCRIPTION="Small utility for searching ebuilds with indexing for fast results"
+HOMEPAGE="http://eix.sourceforge.net"
+SRC_URI="mirror://sourceforge/eix/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="sqlite"
+
+DEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf --with-bzip2 $(use_with sqlite) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ elog "As of >=eix-0.5.4, \"metadata\" is the new default cache."
+ elog "It's independent of the portage-version and the cache used by portage."
+
+ elog /etc/eixrc will not get updated anymore by the eix ebuild.
+ elog Upstream strongly recommends to remove this file resp. to keep
+ elog only those entries which you want to differ from the defaults.
+ elog Use options --dump or --dump-defaults to get an output analogous
+ elog to previous /etc/eixrc files.
+}