summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-15 06:52:09 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-15 06:52:09 +0000
commite51bc57ddb5fd5463d46a5f3c36fa76ca1d944f0 (patch)
tree656956438eb13ab7fa8f355a3349309975f7f2d2 /app-portage
parentBug #226505 - For compatibility with phase execution order in (diff)
downloadgentoo-2-e51bc57ddb5fd5463d46a5f3c36fa76ca1d944f0.tar.gz
gentoo-2-e51bc57ddb5fd5463d46a5f3c36fa76ca1d944f0.tar.bz2
gentoo-2-e51bc57ddb5fd5463d46a5f3c36fa76ca1d944f0.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/conf-update/ChangeLog9
-rw-r--r--app-portage/conf-update/conf-update-1.0.ebuild11
2 files changed, 15 insertions, 5 deletions
diff --git a/app-portage/conf-update/ChangeLog b/app-portage/conf-update/ChangeLog
index 71914b8e5f9b..5c9286a7ec1f 100644
--- a/app-portage/conf-update/ChangeLog
+++ b/app-portage/conf-update/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/conf-update
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/conf-update/ChangeLog,v 1.18 2007/04/08 11:11:58 blubb Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/conf-update/ChangeLog,v 1.19 2008/06/15 06:52:09 zmedico Exp $
+
+ 15 Jun 2008; Zac Medico <zmedico@gentoo.org> conf-update-1.0.ebuild:
+ Bug #226505 - For compatibility with phase execution order in
+ >=portage-2.1.5, call has_version inside pkg_preinst instead of
+ pkg_postinst.
08 Apr 2007; Simon Stelling <blubb@gentoo.org> metadata.xml:
reassign to maintainer-needed
diff --git a/app-portage/conf-update/conf-update-1.0.ebuild b/app-portage/conf-update/conf-update-1.0.ebuild
index 2ce9395b2095..c40dc9043433 100644
--- a/app-portage/conf-update/conf-update-1.0.ebuild
+++ b/app-portage/conf-update/conf-update-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/conf-update/conf-update-1.0.ebuild,v 1.6 2006/11/13 18:42:28 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/conf-update/conf-update-1.0.ebuild,v 1.7 2008/06/15 06:52:09 zmedico Exp $
inherit toolchain-funcs
@@ -49,8 +49,13 @@ src_install() {
doman ${PN}.1
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.12.0"
+ previous_less_than_0_12_0=$?
+}
+
pkg_postinst() {
- if has_version '<app-portage/conf-update-0.12.0' ; then
+ if [[ $previous_less_than_0_12_0 = 0 ]] ; then
ewarn "Note that the format for /etc/conf-update.conf changed in this"
ewarn "version. You should merge the update of that file with e.g."
ewarn "etc-update."