summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-02-26 09:07:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-02-26 09:07:53 +0000
commitec8cb05b2f55b003b2362ed76aacaaffc12d39e4 (patch)
tree6b0f7743e7ee507467bdeb954bdd3f300fbbca79 /app-portage
parentRestricting python bits (diff)
downloadgentoo-2-ec8cb05b2f55b003b2362ed76aacaaffc12d39e4.tar.gz
gentoo-2-ec8cb05b2f55b003b2362ed76aacaaffc12d39e4.tar.bz2
gentoo-2-ec8cb05b2f55b003b2362ed76aacaaffc12d39e4.zip
Restricting pypy and jython
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/porthole/ChangeLog8
-rw-r--r--app-portage/porthole/porthole-0.6.1-r1.ebuild5
-rw-r--r--app-portage/porthole/porthole-0.6.1-r2.ebuild6
3 files changed, 12 insertions, 7 deletions
diff --git a/app-portage/porthole/ChangeLog b/app-portage/porthole/ChangeLog
index e31aec690e35..b43e742331f8 100644
--- a/app-portage/porthole/ChangeLog
+++ b/app-portage/porthole/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-portage/porthole
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/ChangeLog,v 1.52 2011/02/23 07:20:23 fuzzyray Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/ChangeLog,v 1.53 2012/02/26 09:07:53 patrick Exp $
+
+ 26 Feb 2012; Patrick Lauer <patrick@gentoo.org> porthole-0.6.1-r1.ebuild,
+ porthole-0.6.1-r2.ebuild:
+ Restricting pypy and jython
23 Feb 2011; Paul Varner <fuzzyray@gentoo.org> porthole-0.6.1-r1.ebuild,
porthole-0.6.1-r2.ebuild:
diff --git a/app-portage/porthole/porthole-0.6.1-r1.ebuild b/app-portage/porthole/porthole-0.6.1-r1.ebuild
index 1800cb07bffd..a430e2dd6129 100644
--- a/app-portage/porthole/porthole-0.6.1-r1.ebuild
+++ b/app-portage/porthole/porthole-0.6.1-r1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/porthole-0.6.1-r1.ebuild,v 1.8 2011/02/23 07:20:23 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/porthole-0.6.1-r1.ebuild,v 1.9 2012/02/26 09:07:53 patrick Exp $
EAPI="2"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
PYTHON_USE_WITH="xml threads"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
inherit distutils eutils
diff --git a/app-portage/porthole/porthole-0.6.1-r2.ebuild b/app-portage/porthole/porthole-0.6.1-r2.ebuild
index 7fa8f7f78142..733fc5d05dda 100644
--- a/app-portage/porthole/porthole-0.6.1-r2.ebuild
+++ b/app-portage/porthole/porthole-0.6.1-r2.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/porthole-0.6.1-r2.ebuild,v 1.3 2011/02/23 07:20:23 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/porthole-0.6.1-r2.ebuild,v 1.4 2012/02/26 09:07:53 patrick Exp $
EAPI="2"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
PYTHON_USE_WITH="xml threads"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
inherit distutils eutils
@@ -27,7 +28,6 @@ RDEPEND=">=sys-apps/portage-2.1
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( >=sys-devel/gettext-0.14 )"
-RESTRICT_PYTHON_ABIS="3.*"
src_prepare() {
epatch "${FILESDIR}/${P}-masking_status.patch" # bug 307037