summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-23 23:57:07 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-23 23:57:07 +0000
commitf209a9064c0c8ba34e953526a0258cf91a8df94a (patch)
treee5e94a93114849b81c678b9cb025f749a0287115 /app-sci/clustalw
parentdont set EXTRA_ECONF (Manifest recommit) (diff)
downloadgentoo-2-f209a9064c0c8ba34e953526a0258cf91a8df94a.tar.gz
gentoo-2-f209a9064c0c8ba34e953526a0258cf91a8df94a.tar.bz2
gentoo-2-f209a9064c0c8ba34e953526a0258cf91a8df94a.zip
dont set EXTRA_EMAKE
Diffstat (limited to 'app-sci/clustalw')
-rw-r--r--app-sci/clustalw/clustalw-1.83.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/app-sci/clustalw/clustalw-1.83.ebuild b/app-sci/clustalw/clustalw-1.83.ebuild
index 00921c80bb22..f38c83343ccc 100644
--- a/app-sci/clustalw/clustalw-1.83.ebuild
+++ b/app-sci/clustalw/clustalw-1.83.ebuild
@@ -1,39 +1,33 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# Author: Gontran Zepeda <gontran@gontran.net>
-# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/clustalw-1.83.ebuild,v 1.6 2004/07/01 11:50:28 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/clustalw-1.83.ebuild,v 1.7 2004/09/23 23:56:02 vapier Exp $
inherit eutils
DESCRIPTION="Improving the sensitivity of progressive multiple sequence alignment through sequence weighting, position specific gap penalties and weight matrix choice."
-
-# ClustalW is ubiquitous, but this is the contact group.
HOMEPAGE="http://www.embl-heidelberg.de/~seqanal/"
-
-# One source.
SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/unix/clustalw/${PN}${PV}.UNIX.tar.gz"
LICENSE="clustalw"
SLOT="0"
-KEYWORDS="x86 sparc ppc alpha"
+KEYWORDS="alpha ppc sparc x86"
IUSE=""
+
DEPEND="virtual/libc"
S=${WORKDIR}/${PN}${PV}
src_unpack(){
- # let's use gentoo CFLAGS, et al.
unpack ${A}
cd ${S}
epatch ${FILESDIR}/optimize-${PN}${PV}.patch
}
+
src_compile() {
- # clustalw uses only makefile. cool: stupid emake tricks.
- EXTRA_EMAKE="-e ${CFLAGS}"
- emake || die
+ emake -e ${CFLAGS} || die
}
+
src_install() {
- # a mano
- dobin clustalw
+ dobin clustalw || die
dodoc README clustalw.doc clustalw.ms clustalw_help
}