summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-18 08:53:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-18 08:53:26 +0000
commitae811350f3a6fb3177cf0deccdf59bf80823ac86 (patch)
tree50d02c740ecb934a7ddd96ab0bffff2777b9e489 /app-sci/stellarium
parentClosing bug 32956 (diff)
downloadgentoo-2-ae811350f3a6fb3177cf0deccdf59bf80823ac86.tar.gz
gentoo-2-ae811350f3a6fb3177cf0deccdf59bf80823ac86.tar.bz2
gentoo-2-ae811350f3a6fb3177cf0deccdf59bf80823ac86.zip
use edos2unix from eutils; DEPEND on media-libs/libsdl; more error checking/messages; tidy
Diffstat (limited to 'app-sci/stellarium')
-rw-r--r--app-sci/stellarium/ChangeLog7
-rw-r--r--app-sci/stellarium/Manifest4
-rw-r--r--app-sci/stellarium/stellarium-0.5.1.ebuild24
3 files changed, 18 insertions, 17 deletions
diff --git a/app-sci/stellarium/ChangeLog b/app-sci/stellarium/ChangeLog
index a20aae3ca94c..2dc921b37f04 100644
--- a/app-sci/stellarium/ChangeLog
+++ b/app-sci/stellarium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/stellarium
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/stellarium/ChangeLog,v 1.1 2003/07/13 19:30:43 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/stellarium/ChangeLog,v 1.2 2003/11/18 08:53:23 mr_bones_ Exp $
+
+ 18 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org>
+ stellarium-0.5.1.ebuild:
+ use edos2unix from eutils; DEPEND on media-libs/libsdl; more error
+ checking/messages; tidy
*stellarium-0.5.1 (13 Jul 2003)
diff --git a/app-sci/stellarium/Manifest b/app-sci/stellarium/Manifest
index 9d822e81c9c8..4a9f7e2a6a86 100644
--- a/app-sci/stellarium/Manifest
+++ b/app-sci/stellarium/Manifest
@@ -1,4 +1,4 @@
-MD5 f56968cef75cb8e1b9ad4985c7629195 stellarium-0.5.1.ebuild 790
-MD5 0090262dc85462069530c14ca3a146f4 ChangeLog 444
+MD5 ea5a7b9bcb897cd1e37b190db6642b9f ChangeLog 626
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 566aa89ff147d7d6821c89ebf6f6f576 stellarium-0.5.1.ebuild 764
MD5 bcab0b5f5478a8d852f8819a1e1249a8 files/digest-stellarium-0.5.1 69
diff --git a/app-sci/stellarium/stellarium-0.5.1.ebuild b/app-sci/stellarium/stellarium-0.5.1.ebuild
index ffabfcaadff2..37c54f7b9bdd 100644
--- a/app-sci/stellarium/stellarium-0.5.1.ebuild
+++ b/app-sci/stellarium/stellarium-0.5.1.ebuild
@@ -1,35 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/stellarium/stellarium-0.5.1.ebuild,v 1.2 2003/11/04 10:50:40 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/stellarium/stellarium-0.5.1.ebuild,v 1.3 2003/11/18 08:53:23 mr_bones_ Exp $
+
+inherit eutils
DESCRIPTION="Stellarium renders 3D photo-realistic skies in real time."
HOMEPAGE="http://stellarium.free.fr/"
SRC_URI="http://stellarium.free.fr/download/${P}.tar.gz"
+
+KEYWORDS="x86"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
-
IUSE=""
-DEPEND="virtual/opengl
- app-text/dos2unix"
-
-S=${WORKDIR}/${P}
+DEPEND="virtual/x11
+ virtual/opengl
+ media-libs/libsdl"
src_unpack() {
# Configure script is in DOS format for some reason
unpack ${A}
cd ${S}
- dos2unix configure
+ edos2unix configure
chmod 755 configure
}
-src_compile() {
- econf || die
- emake || die
-}
-
src_install() {
einstall || die
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL README TODO || die "dodoc failed"
}