summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-10-14 15:02:34 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-10-14 15:02:34 +0000
commit227c8be36df4511b95d068cf667727c22b03dc8e (patch)
tree6e28976048e05694437d0e7f9d640ad1696fe2dd /app-sci
parentUse gcc-getCC/CXX rather than CC/CXX. (Manifest recommit) (diff)
downloadgentoo-2-227c8be36df4511b95d068cf667727c22b03dc8e.tar.gz
gentoo-2-227c8be36df4511b95d068cf667727c22b03dc8e.tar.bz2
gentoo-2-227c8be36df4511b95d068cf667727c22b03dc8e.zip
Added to x86. Use gcc-getCC rather than CC.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/tree-puzzle/ChangeLog6
-rw-r--r--app-sci/tree-puzzle/tree-puzzle-5.1.ebuild4
-rw-r--r--app-sci/tree-puzzle/tree-puzzle-5.2.ebuild8
3 files changed, 12 insertions, 6 deletions
diff --git a/app-sci/tree-puzzle/ChangeLog b/app-sci/tree-puzzle/ChangeLog
index 9559494b0261..c91cf1a84e70 100644
--- a/app-sci/tree-puzzle/ChangeLog
+++ b/app-sci/tree-puzzle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/tree-puzzle
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tree-puzzle/ChangeLog,v 1.5 2004/07/23 16:01:23 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tree-puzzle/ChangeLog,v 1.6 2004/10/14 15:02:34 ribosome Exp $
+
+ 14 Oct 2004; Olivier Fisette <ribosome@gentoo.org> tree-puzzle-5.1.ebuild,
+ tree-puzzle-5.2.ebuild:
+ Added to x86. Use gcc-getCC from gcc.eclass rather than ${CC}.
23 Jul 2004; Jon Hood <squinky86@gentoo.org> tree-puzzle-5.2.ebuild:
Change virtual/glibc -> virtual/libc.
diff --git a/app-sci/tree-puzzle/tree-puzzle-5.1.ebuild b/app-sci/tree-puzzle/tree-puzzle-5.1.ebuild
index 5b224a63e76a..f1fcb74ea173 100644
--- a/app-sci/tree-puzzle/tree-puzzle-5.1.ebuild
+++ b/app-sci/tree-puzzle/tree-puzzle-5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tree-puzzle/tree-puzzle-5.1.ebuild,v 1.3 2004/06/24 22:19:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tree-puzzle/tree-puzzle-5.1.ebuild,v 1.4 2004/10/14 15:02:34 ribosome Exp $
DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data."
HOMEPAGE="http://www.tree-puzzle.de"
@@ -8,7 +8,7 @@ SRC_URI="http://www.tree-puzzle.de/${P}.tar.gz"
LICENSE="GPL-1"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
IUSE=""
src_compile() {
diff --git a/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild b/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild
index e8f6541908af..40adabbf686c 100644
--- a/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.3 2004/07/23 19:29:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.4 2004/10/14 15:02:34 ribosome Exp $
+
+inherit gcc
DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data."
HOMEPAGE="http://www.tree-puzzle.de"
@@ -8,14 +10,14 @@ SRC_URI="http://www.tree-puzzle.de/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE="mpi"
DEPEND="virtual/libc
mpi? ( sys-cluster/lam-mpi )"
pkg_setup () {
- use mpi && [ ${CC} = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
+ use mpi && [ $(gcc-getCC) = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
Either disable the \"mpi\" USE flag to compile only the non-parallelized
version of the program, or use gcc as your compiler (CC=\"gcc\")."
}