summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-10-29 02:20:13 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-10-29 02:20:13 +0000
commit2aee0d51ae0a838af0d3287222c7a714cac6e1e7 (patch)
treea9ee52f02ae1737d4788d7c51871682f0ad65d8f /app-sci
parentadded libf2c license (diff)
downloadgentoo-2-2aee0d51ae0a838af0d3287222c7a714cac6e1e7.tar.gz
gentoo-2-2aee0d51ae0a838af0d3287222c7a714cac6e1e7.tar.bz2
gentoo-2-2aee0d51ae0a838af0d3287222c7a714cac6e1e7.zip
initial ebuild
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/ghemical/ChangeLog8
-rw-r--r--app-sci/ghemical/files/digest-ghemical-0.901
-rw-r--r--app-sci/ghemical/files/ghemical-0.90-gentoo.patch31
-rw-r--r--app-sci/ghemical/ghemical-0.90.ebuild29
4 files changed, 69 insertions, 0 deletions
diff --git a/app-sci/ghemical/ChangeLog b/app-sci/ghemical/ChangeLog
new file mode 100644
index 000000000000..0d6da137632d
--- /dev/null
+++ b/app-sci/ghemical/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-sci/ghemical
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ghemical/ChangeLog,v 1.1 2002/10/29 02:20:12 hannes Exp $
+
+*ghemical-0.90.ebuild (28 Oct 2002)
+
+ 28 Oct 2002; Hannes Mehnert <hannes@gentoo.org> ghemical-0.90.ebuild,
+ ChangeLog: Initial ebuild.
diff --git a/app-sci/ghemical/files/digest-ghemical-0.90 b/app-sci/ghemical/files/digest-ghemical-0.90
new file mode 100644
index 000000000000..53234c17d9a4
--- /dev/null
+++ b/app-sci/ghemical/files/digest-ghemical-0.90
@@ -0,0 +1 @@
+MD5 a469e583af31c89146397f81aa88289c ghemical-0.90.tgz 2087887
diff --git a/app-sci/ghemical/files/ghemical-0.90-gentoo.patch b/app-sci/ghemical/files/ghemical-0.90-gentoo.patch
new file mode 100644
index 000000000000..601ec7cabcc9
--- /dev/null
+++ b/app-sci/ghemical/files/ghemical-0.90-gentoo.patch
@@ -0,0 +1,31 @@
+--- openbabel/c3d.cpp.org 2002-06-19 23:18:59.000000000 +0200
++++ openbabel/c3d.cpp 2002-10-27 18:47:04.000000000 +0100
+@@ -150,7 +150,7 @@
+ }
+
+ if (!natoms) return(false);
+- divisor = pow(10.0,exponent);
++ divisor = pow((float)10.0,(float)exponent);
+ mol.ReserveAtoms(natoms);
+
+ ttab.SetToType("INT");
+--- src/graphics/views.cpp.org 2002-06-20 13:27:04.000000000 +0200
++++ src/graphics/views.cpp 2002-10-27 19:57:12.000000000 +0100
+@@ -486,7 +486,7 @@
+
+ glInitNames();
+
+- i32s zzz = (i32s) sqrt(dv.size()); // support square datasets only!!!
++ i32s zzz = (i32s) sqrt((double)dv.size()); // support square datasets only!!!
+ for (i32s n1 = 0;n1 < zzz - 1;n1++)
+ {
+ for (i32s n2 = 0;n2 < zzz - 1;n2++)
+@@ -542,7 +542,7 @@
+ if (sy < 0.0) return;
+ if (sy > 1.0) return;
+
+- i32s zzz = (i32s) sqrt(dv.size()); // support square datasets only!!!
++ i32s zzz = (i32s) sqrt((double)dv.size()); // support square datasets only!!!
+ i32s index = (i32s) (((i32s) (sx * zzz)) * zzz + sy * zzz);
+ if (index >= (i32s) dv.size()) return;
+
diff --git a/app-sci/ghemical/ghemical-0.90.ebuild b/app-sci/ghemical/ghemical-0.90.ebuild
new file mode 100644
index 000000000000..ef3dcdf817ef
--- /dev/null
+++ b/app-sci/ghemical/ghemical-0.90.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ghemical/ghemical-0.90.ebuild,v 1.1 2002/10/29 02:20:13 hannes Exp $
+
+DEPEND="gnome-base/gnome-libs
+ dev-libs/libf2c"
+# app-sci/mpqc"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~x86"
+
+DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
+
+HOMEPAGE="http://www.uku.fi/~thassine/ghemical/"
+SRC_URI="http://www.uku.fi/~thassine/ghemical/download/${P}.tgz"
+
+src_compile() {
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch
+ ./configure --prefix=/usr #--enable-mpqc
+ emake
+}
+
+src_install() {
+ sed -e "s:^prefix=.*:prefix=${D}/usr:" Makefile > Makefile.foo
+ mv Makefile.foo Makefile
+ make install
+}