summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-12-03 10:44:47 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-12-03 10:44:47 +0000
commit420e83d2f3a7948adabdc2027bfc3f29a57cfc55 (patch)
tree1ceb1e74a5fffaec0d89efdc98af6777a021c20c /app-sci
parentDisable jikes and fix a small bug in src_config (Manifest recommit) (diff)
downloadgentoo-2-420e83d2f3a7948adabdc2027bfc3f29a57cfc55.tar.gz
gentoo-2-420e83d2f3a7948adabdc2027bfc3f29a57cfc55.tar.bz2
gentoo-2-420e83d2f3a7948adabdc2027bfc3f29a57cfc55.zip
Fixing bug #73146
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/orsa/ChangeLog6
-rw-r--r--app-sci/orsa/orsa-0.6.1.ebuild6
2 files changed, 9 insertions, 3 deletions
diff --git a/app-sci/orsa/ChangeLog b/app-sci/orsa/ChangeLog
index f5c5d7bb094f..cffa86871e1b 100644
--- a/app-sci/orsa/ChangeLog
+++ b/app-sci/orsa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/orsa
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.14 2004/11/22 23:46:19 kingtaco Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.15 2004/12/03 10:44:47 phosphan Exp $
+
+ 03 Dec 2004; Patrick Kursawe <phosphan@gentoo.org> orsa-0.6.1.ebuild:
+ Fixing bug #73146 (adding -lutil to libs, adding write permissions for Qt
+ stuff)
22 Nov 2004; Mike Doty <kingtaco@gentoo.org> :
~amd64 incorrectly added.
diff --git a/app-sci/orsa/orsa-0.6.1.ebuild b/app-sci/orsa/orsa-0.6.1.ebuild
index e6f5a79cdc46..eed6ad51ae06 100644
--- a/app-sci/orsa/orsa-0.6.1.ebuild
+++ b/app-sci/orsa/orsa-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/orsa-0.6.1.ebuild,v 1.5 2004/11/22 23:46:19 kingtaco Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/orsa-0.6.1.ebuild,v 1.6 2004/12/03 10:44:47 phosphan Exp $
inherit base flag-o-matic
@@ -48,10 +48,12 @@ src_compile() {
fi
if ! use qt; then
myconf="${myconf} --with-qt-dir=/no/such/file"
+ else
+ addwrite "${QTDIR}/etc/settings"
fi
econf ${myconf} $(use_with opengl gl) || die "configure failed"
if use mpi; then
- sed -e 's/\(orsa_LDADD = .*\)/\1 -llammpi++ -lmpi -llam -lpthread/' \
+ sed -e 's/\(orsa_LDADD = .*\)/\1 -llammpi++ -lmpi -llam -lpthread -lutil/' \
-i src/orsa/Makefile
fi