summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-10-25 09:20:08 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-10-25 09:20:08 +0000
commit472cf8372b0e8c100e3313049844df60f932ba60 (patch)
tree332e26feffbfa126fb49f32e38d3ff86704ce6cc /app-sci
parentfixed typo in files/smb.conf.example-samba3.gz (Manifest recommit) (diff)
downloadgentoo-2-472cf8372b0e8c100e3313049844df60f932ba60.tar.gz
gentoo-2-472cf8372b0e8c100e3313049844df60f932ba60.tar.bz2
gentoo-2-472cf8372b0e8c100e3313049844df60f932ba60.zip
fixing #68458
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/predict/ChangeLog8
-rw-r--r--app-sci/predict/Manifest2
-rw-r--r--app-sci/predict/files/digest-predict-2.2.2-r21
-rw-r--r--app-sci/predict/predict-2.2.2-r2.ebuild166
4 files changed, 176 insertions, 1 deletions
diff --git a/app-sci/predict/ChangeLog b/app-sci/predict/ChangeLog
index 4ffde8c0b447..448015a5f591 100644
--- a/app-sci/predict/ChangeLog
+++ b/app-sci/predict/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/predict
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/predict/ChangeLog,v 1.9 2004/06/24 22:15:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/predict/ChangeLog,v 1.10 2004/10/25 09:20:08 phosphan Exp $
+
+*predict-2.2.2-r2 (25 Oct 2004)
+
+ 25 Oct 2004; Patrick Kursawe <phosphan@gentoo.org> +predict-2.2.2-r2.ebuild:
+ Removed useless errno definition which caused trouble with newer glibc
+ versions. (see bug #68458)
02 Jun 2004; Aron Griffis <agriffis@gentoo.org> predict-2.2.1.ebuild,
predict-2.2.2-r1.ebuild:
diff --git a/app-sci/predict/Manifest b/app-sci/predict/Manifest
index 560ab23713b4..81b9cc38dfaa 100644
--- a/app-sci/predict/Manifest
+++ b/app-sci/predict/Manifest
@@ -1,7 +1,9 @@
+MD5 f023884c6cd3b075ba61cbac29012220 predict-2.2.2-r2.ebuild 4307
MD5 910e32f06cb9eed3733296d3ec86e1f4 predict-2.2.2-r1.ebuild 4312
MD5 24c3d657d30449ed0321b17d572f4789 predict-2.2.1.ebuild 4536
MD5 1516a9a5c5b8f2d9dd363aa0e55e5c84 ChangeLog 1168
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 729e9f2e1ecbb139b17f650d2916da21 files/digest-predict-2.2.2-r1 66
+MD5 729e9f2e1ecbb139b17f650d2916da21 files/digest-predict-2.2.2-r2 66
MD5 e9851bdcd10870d0cf8dd12a543acb05 files/digest-predict-2.2.1 65
MD5 95dc86360de601d5c7c9d2f7d87c2c79 files/predict-update 4037
diff --git a/app-sci/predict/files/digest-predict-2.2.2-r2 b/app-sci/predict/files/digest-predict-2.2.2-r2
new file mode 100644
index 000000000000..8786565e5599
--- /dev/null
+++ b/app-sci/predict/files/digest-predict-2.2.2-r2
@@ -0,0 +1 @@
+MD5 2512bc6b584ece66de027e46f114ab53 predict-2.2.2.tar.gz 1637893
diff --git a/app-sci/predict/predict-2.2.2-r2.ebuild b/app-sci/predict/predict-2.2.2-r2.ebuild
new file mode 100644
index 000000000000..ab5406ca5aa8
--- /dev/null
+++ b/app-sci/predict/predict-2.2.2-r2.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/predict/predict-2.2.2-r2.ebuild,v 1.1 2004/10/25 09:20:08 phosphan Exp $
+
+DESCRIPTION="Satellite tracking and orbital prediction."
+HOMEPAGE="http://www.qsl.net/kd2bd/predict.html"
+SRC_URI="http://www.amsat.org/amsat/ftp/software/Linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="xforms gtk nls"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="sys-libs/ncurses
+ gtk? ( =x11-libs/gtk+-1.2* )
+ xforms? ( x11-libs/xforms )"
+RDEPEND="gtk? ( =x11-libs/gtk+-1.2* )
+ xforms? ( x11-libs/xforms )"
+
+if [ -x /usr/bin/xearth ]; then
+ EARTHTRACKOK="yes"
+elif [ -x /usr/bin/xplanet ]; then
+ EARTHTRACKOK="yes"
+fi
+
+src_compile() {
+ # predict uses a ncurses based configure script
+ # this is what it does if it was bash based ;)
+
+ # set compiler string to a var so if compiler checks
+ # can be added at a later date
+ COMPILER="cc ${CFLAGS} -fomit-frame-pointer"
+
+ # write predict.h
+ echo "char *predictpath=\"/usr/share/predict/\";" > predict.h
+ echo "char soundcard=1;" >> predict.h
+ echo "char *version=\"${PV}\";" >> predict.h
+
+ # compile predict
+ einfo "compiling predict"
+ ${COMPILER} -L/lib -lm -lncurses -lpthread predict.c -o predict
+
+ # write vocalizer.h
+ cd vocalizer
+ echo "char *path={\"/usr/share/predict/vocalizer/\"};" > vocalizer.h
+
+ # compile vocalizer
+ einfo "compiling vocalizer"
+ ${COMPILER} vocalizer.c -o vocalizer
+
+ einfo "compiling clients"
+
+ # earthtrack
+ if test "${EARTHTRACKOK}" = "yes"; then
+ einfo "compiling earthtrack"
+ cd ${S}/clients/earthtrack
+ ${COMPILER} -lm earthtrack.c -o earthtrack
+ fi
+
+ # kep_reload
+ einfo "compiling kep_reload"
+ cd ${S}/clients/kep_reload
+ ${COMPILER} kep_reload.c -o kep_reload
+
+ # map
+ if use xforms; then
+ einfo "compiling map"
+ cd ${S}/clients/map
+ TCOMP="${COMPILER} -I/usr/X11R6/include -L/usr/X11R6/lib -lforms -lX11 -lm map.c map_cb.c map_main.c -o map"
+ ${TCOMP}
+ fi
+
+ # gsat
+ if use gtk; then
+ # note there are plugins for gsat but they are missing header files and wont compile
+ use nls || myconf="--disable-nls"
+ einfo "compiling gsat"
+ cd ${S}/clients/gsat-*
+ ./configure --prefix=/usr ${myconf}
+ cd src
+ sed -e "s:#define DEFAULTPLUGINSDIR .*:#define DEFAULTPLUGINSDIR \"/usr/lib/gsat/plugins/\":" -i globals.h
+ sed -e 's:int errno;::' -i globals.h
+ cd ..
+ emake
+ fi
+}
+
+src_install() {
+ # install predict
+ cd ${S}
+ dobin predict ${FILESDIR}/predict-update
+ dodoc CHANGES COPYING CREDITS HISTORY README
+ dodoc default/predict.*
+ dodoc docs/pdf/predict.pdf
+ dodoc docs/postscript/predict.ps
+ doman docs/man/predict.1
+
+ #install vocalizer
+ exeinto /usr/bin
+ cd vocalizer
+ doexe vocalizer
+ dodir /usr/share/predict/vocalizer
+ insinto /usr/share/predict/vocalizer
+ dosym /usr/bin/vocalizer /usr/share/predict/vocalizer/vocalizer
+ doins *.wav
+
+ mv README README.vocalizer
+ dodoc README.vocalizer
+
+ # install clients
+
+ # earthtrack
+ if test "${EARTHTRACKOK}" = "yes"; then
+ cd ${S}/clients/earthtrack
+ ln -s earthtrack earthtrack2
+ dobin earthtrack earthtrack2
+ mv README_FIRST README_FIRST.earthtrack
+ mv README README.earthtrack
+ dodoc README_FIRST.earthtrack README.earthtrack
+ fi
+
+ # kep_reload
+ cd ${S}/clients/kep_reload
+ dobin kep_reload
+ mv INSTALL INSTALL.kep_reload
+ mv README README.kep_reload
+ dodoc INSTALL.kep_reload README.kep_reload
+
+ # map
+ if use xforms; then
+ cd ${S}/clients/map
+ dobin map
+ for i in CHANGES README COPYING; do
+ mv ${i} ${i}.map
+ dodoc ${i}.map
+ done
+ fi
+
+ # gsat
+ if use gtk; then
+ # the install seems broken so do manually...
+ cd ${S}/clients/gsat-*
+ dodir /usr/lib/gsat/plugins
+ keepdir /usr/lib/gsat/plugins
+ cd src
+ dobin gsat
+ cd ..
+ for i in AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL NEWS README Plugin_API; do
+ mv ${i} ${i}.gsat
+ dodoc ${i}.gsat
+ done
+ fi
+}
+
+pkg_postinst() {
+ einfo "to use the clients the following line will"
+ einfo "have to be inserted into /etc/services"
+ einfo "predict 1210/udp"
+ einfo "the port can be changed to anything"
+ einfo "the name predict is what is needed to work"
+ einfo "after that is set run 'predict -s'"
+ einfo ""
+ einfo "to get list of satellites run 'predict-update'"
+ einfo "before running predict this script will also update"
+ einfo "the list of satellites so they are up to date."
+}