summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2004-07-28 00:26:32 +0000
committerChris Bainbridge <chrb@gentoo.org>2004-07-28 00:26:32 +0000
commit5f80eb062951829fca7403faf09aae0b89a8d6e8 (patch)
treea38f2941a2ecfabbe88f30346acce9c9b0d92b11 /app-sci
parentfix #46959 #43567 #58127 (Manifest recommit) (diff)
downloadgentoo-2-5f80eb062951829fca7403faf09aae0b89a8d6e8.tar.gz
gentoo-2-5f80eb062951829fca7403faf09aae0b89a8d6e8.tar.bz2
gentoo-2-5f80eb062951829fca7403faf09aae0b89a8d6e8.zip
fix broken paths
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/balsa/balsa-3.4.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/app-sci/balsa/balsa-3.4.ebuild b/app-sci/balsa/balsa-3.4.ebuild
index bcf89ba7e2ae..84a08554489b 100644
--- a/app-sci/balsa/balsa-3.4.ebuild
+++ b/app-sci/balsa/balsa-3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/balsa/balsa-3.4.ebuild,v 1.1 2004/07/27 00:34:52 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/balsa/balsa-3.4.ebuild,v 1.2 2004/07/28 00:26:32 chrb Exp $
inherit eutils
@@ -52,13 +52,16 @@ src_unpack() {
sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I${S}/src/libs/ \2/:" ${WORKDIR}/balsa-sim-verilog-${PV}/libs/Makefile.in
epatch ${FILESDIR}/balsa-tech-3.4-configure.patch
epatch ${FILESDIR}/balsa-sim-3.4-configure.patch
+ sed -i -e 's/ $(bindir)/ $(DESTDIR)$(bindir)/' ${S}/bin/Makefile.in
+ sed -i -e 's/ $(balsatypesdir)/ $(DESTDIR)$(balsatypesdir)/' ${S}/share/balsa/types/Makefile.in
+ sed -i -e 's/ $(balsasimdir)/ $(DESTDIR)$(balsasimdir)/' ${S}/share/balsa/sim/Makefile.in
}
src_compile() {
# compile balsa
einfo "Compiling balsa"
- ./configure --prefix=${D}/usr/ || die "econf failed"
- emake || die
+ ./configure --prefix=/usr/ || die "econf failed"
+ emake || die
# configure AMS035 tech
if [ $TECH_AMS ]; then
@@ -93,7 +96,7 @@ src_install() {
# install balsa
cd ${S}
einfo "Installing balsa"
- make install || die
+ make DESTDIR=${D} install || die
# install manual and examples
dodir /usr/share/doc/${P}/