summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-12-22 10:23:47 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-12-22 10:23:47 +0000
commitdee853ffbd558921d24163b471765cd2072a3561 (patch)
tree165a28a086fef229269accd705e802d61f5bf05a /app-sci
parentInitial import (diff)
downloadgentoo-2-dee853ffbd558921d24163b471765cd2072a3561.tar.gz
gentoo-2-dee853ffbd558921d24163b471765cd2072a3561.tar.bz2
gentoo-2-dee853ffbd558921d24163b471765cd2072a3561.zip
Initial import
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/cdf/ChangeLog10
-rw-r--r--app-sci/cdf/Manifest4
-rw-r--r--app-sci/cdf/cdf-2.7.ebuild53
-rw-r--r--app-sci/cdf/files/digest-cdf-2.72
-rw-r--r--app-sci/cdf/metadata.xml5
5 files changed, 73 insertions, 1 deletions
diff --git a/app-sci/cdf/ChangeLog b/app-sci/cdf/ChangeLog
new file mode 100644
index 000000000000..eac3ef89c848
--- /dev/null
+++ b/app-sci/cdf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-sci/cdf
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/cdf/ChangeLog,v 1.1 2003/12/22 10:23:38 phosphan Exp $
+
+*cdf-2.7 (22 Dec 2003)
+
+ 22 Dec 2003; Patrick Kursawe <phosphan@gentoo.org> cdf-2.7.ebuild,
+ metadata.xml:
+ Initial import
+
diff --git a/app-sci/cdf/Manifest b/app-sci/cdf/Manifest
index 94a6edfb4751..c6e73d66264b 100644
--- a/app-sci/cdf/Manifest
+++ b/app-sci/cdf/Manifest
@@ -1,2 +1,4 @@
-MD5 5520fcbef6a57615e91fe77bb52ebe03 cdf-2.7.ebuild 914
+MD5 e184cf6ffe2c1615dcae79e1a432b0e8 ChangeLog 333
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 90bcbffc562f819f6503cf6e5a1d3e73 cdf-2.7.ebuild 1572
MD5 5b499d4b4c0682ebecd2e795aa95bc04 files/digest-cdf-2.7 133
diff --git a/app-sci/cdf/cdf-2.7.ebuild b/app-sci/cdf/cdf-2.7.ebuild
new file mode 100644
index 000000000000..65864c35ad4e
--- /dev/null
+++ b/app-sci/cdf/cdf-2.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/cdf/cdf-2.7.ebuild,v 1.1 2003/12/22 10:23:38 phosphan Exp $
+
+MY_P="${P/-}"
+MY_P="${MY_P/.}"
+
+DESCRIPTION="CDF library and toolkit for storing, manipulating, and accessing multi-dimensional data sets"
+HOMEPAGE="http://nssdc.gsfc.nasa.gov/cdf/cdf_home.html"
+SRC_URI="ftp://nssdcftp.gsfc.nasa.gov/standards/cdf/dist/${MY_P}/unix/${MY_P}-dist-cdf.tar.gz
+ java? ( ftp://nssdcftp.gsfc.nasa.gov/standards/cdf/dist/${MY_P}/unix/${MY_P}-dist-java.tar.gz )"
+LICENSE="CDF"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ncurses"
+
+RDEPEND="ncurses? ( sys-libs/ncurses )"
+DEPEND="${RDEPEND}
+ java? ( virtual/jdk
+ dev-java/java-config )"
+
+S=${WORKDIR}/${MY_P}-dist
+
+src_compile() {
+ local myconf
+ if use ncurses; then
+ myconf="CURSES=yes"
+ else
+ myconf="CURSES=no"
+ fi
+ emake OS=linux ENV=gnu ${myconf} all || die "make failed"
+ make test || die "test failed"
+ if use java; then
+ export CDF_BASE="${S}"
+ export CDF_LIB="${S}/src/lib"
+ cd cdfjava/jni
+ cc -c cdfNativeLibrary.c -I${CDF_BASE}/src/include \
+ -I$(java-config -O)/include -I$(java-config -O)/include/linux \
+ -o cdfNativeLibrary.o || die "cc failed"
+ ld -shared cdfNativeLibrary.o -L${CDF_LIB} -lcdf \
+ -o ../lib/libcdfNativeLibrary.so -lc -lm || die "ld failed"
+ fi
+}
+
+src_install() {
+ make INSTALLDIR="${D}/usr" install || die "install failed"
+ if use java; then
+ cd ${S}/cdfjava
+ dolib lib/libcdfNativeLibrary.so
+ insinto /usr/share/cdf
+ doins */*.jar
+ fi
+}
diff --git a/app-sci/cdf/files/digest-cdf-2.7 b/app-sci/cdf/files/digest-cdf-2.7
new file mode 100644
index 000000000000..4fdacdb0e0cb
--- /dev/null
+++ b/app-sci/cdf/files/digest-cdf-2.7
@@ -0,0 +1,2 @@
+MD5 1b95b51f54a0bb787a97aa733381f7a9 cdf27-dist-cdf.tar.gz 872734
+MD5 c7803f13511a7c2753fdcab45a4e6bee cdf27-dist-java.tar.gz 552932
diff --git a/app-sci/cdf/metadata.xml b/app-sci/cdf/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/app-sci/cdf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>