summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-03-01 06:16:26 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-03-01 06:16:26 +0000
commite595022525e40075b17025532d98325378a124ad (patch)
treea5bec4a95234ab1e044386a583c6ed8a98504aaa /app-sci
parentVersion bump to 2.7 series, technically OpenRasMol but it's the continuation ... (diff)
downloadgentoo-2-e595022525e40075b17025532d98325378a124ad.tar.gz
gentoo-2-e595022525e40075b17025532d98325378a124ad.tar.bz2
gentoo-2-e595022525e40075b17025532d98325378a124ad.zip
Adding beta version. This should stay ~arch until considered stable upstream.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/rasmol/ChangeLog7
-rw-r--r--app-sci/rasmol/files/digest-rasmol-2.7.2.11
-rw-r--r--app-sci/rasmol/rasmol-2.7.2.1.ebuild58
3 files changed, 65 insertions, 1 deletions
diff --git a/app-sci/rasmol/ChangeLog b/app-sci/rasmol/ChangeLog
index 25b7e63e4b4e..6361d4e27ede 100644
--- a/app-sci/rasmol/ChangeLog
+++ b/app-sci/rasmol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/rasmol
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/ChangeLog,v 1.6 2004/03/01 06:04:34 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/ChangeLog,v 1.7 2004/03/01 06:16:26 spyderous Exp $
+
+*rasmol-2.7.2.1 (01 Mar 2004)
+
+ 01 Mar 2004; Donnie Berkholz <spyderous@gentoo.org>; rasmol-2.7.2.1.ebuild:
+ Adding beta version. This should stay ~arch until considered stable upstream.
*rasmol-2.7.1.1 (01 Mar 2004)
diff --git a/app-sci/rasmol/files/digest-rasmol-2.7.2.1 b/app-sci/rasmol/files/digest-rasmol-2.7.2.1
new file mode 100644
index 000000000000..dfc148145a01
--- /dev/null
+++ b/app-sci/rasmol/files/digest-rasmol-2.7.2.1
@@ -0,0 +1 @@
+MD5 8dce1ab6bd8dccdfbb4baa3c35f0400e RasMol_2.7.2.1.tar.gz 4804035
diff --git a/app-sci/rasmol/rasmol-2.7.2.1.ebuild b/app-sci/rasmol/rasmol-2.7.2.1.ebuild
new file mode 100644
index 000000000000..73afdb2b790b
--- /dev/null
+++ b/app-sci/rasmol/rasmol-2.7.2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.2.1.ebuild,v 1.1 2004/03/01 06:16:26 spyderous Exp $
+
+MY_P="RasMol_${PV}"
+
+DESCRIPTION="Free program that displays molecular structure."
+HOMEPAGE="http://www.openrasmol.org/"
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="public-domain"
+DEPEND="virtual/x11"
+
+SRC_URI="http://www.bernstein-plus-sons.com/software/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Hack required for build
+ cd src
+ ln -s ../doc
+ gunzip doc/rasmol.1.gz
+}
+
+src_compile() {
+ cd src
+ xmkmf || die "xmkmf failed"
+ make DEPTHDEF=-DEIGHTBIT CC=${CC} \
+ CDEBUGFLAGS="${CFLAGS}" \
+ || die "8-bit make failed"
+ mv rasmol rasmol.8
+ make clean
+ make DEPTHDEF=-DSIXTEENBIT CC=${CC} \
+ CDEBUGFLAGS="${CFLAGS}" \
+ || die "16-bit make failed"
+ mv rasmol rasmol.16
+ make clean
+ make DEPTHDEF=-DTHIRTYTWOBIT CC=${CC} \
+ CDEBUGFLAGS="${CFLAGS}" \
+ || die "32-bit make failed"
+ mv rasmol rasmol.32
+ make clean
+}
+
+src_install () {
+ newbin ${FILESDIR}/rasmol.sh.debian rasmol
+ insinto /usr/lib/${PN}
+ doins doc/rasmol.hlp
+ exeinto /usr/lib/${PN}
+ doexe src/rasmol.{8,16,32}
+ dodoc INSTALL PROJECTS README TODO doc/*.{ps,pdf}.gz doc/rasmol.txt.gz
+ doman doc/rasmol.1
+ insinto /usr/lib/${PN}/databases
+ doins data/*
+}