summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-03 18:22:36 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-03 18:22:36 +0000
commit29085ce8cc5ccf9f0c3e29488c065b177b91b271 (patch)
tree84bfb425af3fdf0abebcdcc3b395109683886632 /app-shells/bash
parentsci-physics/root: Imported latest fixes from sci overlay, including LD and CX... (diff)
downloadgentoo-2-29085ce8cc5ccf9f0c3e29488c065b177b91b271.tar.gz
gentoo-2-29085ce8cc5ccf9f0c3e29488c065b177b91b271.tar.bz2
gentoo-2-29085ce8cc5ccf9f0c3e29488c065b177b91b271.zip
More USE=-readline fixes.
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-4.2_p24.ebuild5
-rw-r--r--app-shells/bash/files/bash-4.2-no-readline.patch19
3 files changed, 28 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index c808d89bb81a..ed4b8df86240 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.307 2012/03/28 18:14:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.308 2012/04/03 18:22:36 vapier Exp $
+
+ 03 Apr 2012; Mike Frysinger <vapier@gentoo.org> bash-4.2_p24.ebuild,
+ +files/bash-4.2-no-readline.patch:
+ More USE=-readline fixes.
28 Mar 2012; Mike Frysinger <vapier@gentoo.org> bash-4.2_p24.ebuild:
Make readline optional.
diff --git a/app-shells/bash/bash-4.2_p24.ebuild b/app-shells/bash/bash-4.2_p24.ebuild
index a752a81d5ab2..69a82b482675 100644
--- a/app-shells/bash/bash-4.2_p24.ebuild
+++ b/app-shells/bash/bash-4.2_p24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p24.ebuild,v 1.5 2012/03/28 18:14:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p24.ebuild,v 1.6 2012/04/03 18:22:36 vapier Exp $
EAPI="1"
@@ -78,6 +78,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-4.2-execute-job-control.patch #383237
epatch "${FILESDIR}"/${PN}-4.2-parallel-build.patch
+ epatch "${FILESDIR}"/${PN}-4.2-no-readline.patch
}
src_compile() {
@@ -124,6 +125,8 @@ src_compile() {
$(use_enable mem-scramble) \
$(use_with mem-scramble bash-malloc) \
$(use_enable readline) \
+ $(use_enable readline history) \
+ $(use_enable readline bang-history) \
${myconf}
emake || die
diff --git a/app-shells/bash/files/bash-4.2-no-readline.patch b/app-shells/bash/files/bash-4.2-no-readline.patch
new file mode 100644
index 000000000000..14eb6bf421e9
--- /dev/null
+++ b/app-shells/bash/files/bash-4.2-no-readline.patch
@@ -0,0 +1,19 @@
+fix building when readline is disabled
+
+--- a/builtins/complete.def
++++ b/builtins/complete.def
+@@ -49,6 +49,8 @@ $END
+
+ #include <config.h>
+
++#ifdef READLINE
++
+ #include <stdio.h>
+
+ #include "../bashtypes.h"
+@@ -867,3 +869,5 @@ compopt_builtin (list)
+
+ return (ret);
+ }
++
++#endif