summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-15 17:48:17 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-15 17:48:17 +0000
commited02f2cfd7d3795bd8d1916142daf861a3b42fb0 (patch)
tree67b4986338d0547fbfb60ba3e2e1fe16dac88b21 /app-shells/bash
parentKeyword ~amd64 (thanks to sera in #gentoo-bugs). (diff)
downloadgentoo-2-ed02f2cfd7d3795bd8d1916142daf861a3b42fb0.tar.gz
gentoo-2-ed02f2cfd7d3795bd8d1916142daf861a3b42fb0.tar.bz2
gentoo-2-ed02f2cfd7d3795bd8d1916142daf861a3b42fb0.zip
Fix parallel build issues with pathnames.h in lib/sh/ #284633 by Justin Lecher.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/files/bash-4.0-parallel-build.patch17
2 files changed, 23 insertions, 1 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index c0c8b9f88c86..1f1020c17743 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.231 2009/10/10 14:57:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.232 2009/10/15 17:48:15 vapier Exp $
+
+ 15 Oct 2009; Mike Frysinger <vapier@gentoo.org>
+ files/bash-4.0-parallel-build.patch:
+ Fix parallel build issues with pathnames.h in lib/sh/ #284633 by Justin
+ Lecher.
10 Oct 2009; Raúl Porcel <armin76@gentoo.org> bash-4.0_p28.ebuild:
m68k stable wrt #270008
diff --git a/app-shells/bash/files/bash-4.0-parallel-build.patch b/app-shells/bash/files/bash-4.0-parallel-build.patch
index aed92c644429..79e04c8cc295 100644
--- a/app-shells/bash/files/bash-4.0-parallel-build.patch
+++ b/app-shells/bash/files/bash-4.0-parallel-build.patch
@@ -18,3 +18,20 @@ patch by Peter Alfredsen
test.o: general.h xmalloc.h bashtypes.h variables.h arrayfunc.h conftypes.h array.h hashlib.h
test.o: quit.h ${BASHINCDIR}/maxpath.h unwind_prot.h dispose_cmd.h
test.o: make_cmd.h subst.h sig.h pathnames.h externs.h test.h
+
+http://bugs.gentoo.org/284633
+
+and another ...
+
+--- bash-4.0/lib/sh/Makefile.in
++++ bash-4.0/lib/sh/Makefile.in
+@@ -136,6 +136,9 @@
+ ${BUILD_DIR}/version.h: ${BUILD_DIR}/config.h ${BUILD_DIR}/Makefile Makefile
+ -( cd ${BUILD_DIR} && ${MAKE} ${MFLAGS} version.h )
+
++${BUILD_DIR}/pathnames.h: ${BUILD_DIR}/config.h ${BUILD_DIR}/Makefile Makefile
++ -( cd ${BUILD_DIR} && ${MAKE} ${MFLAGS} pathnames.h )
++
+ # rules for losing makes, like SunOS
+ casemod.o: casemod.c
+ clktck.o: clktck.c