summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-27 18:06:26 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-27 18:06:26 +0000
commit0c26bf963ad05d1b31b124d815f772ed285539f9 (patch)
tree09b7230b667cbb3491d572649b2fe6885f0e4f3e /app-shells/dash/dash-0.5.4.11.ebuild
parentBump to 2.12.5. Primarily bug fixes. Also pull in an upstream patch to fix co... (diff)
downloadgentoo-2-0c26bf963ad05d1b31b124d815f772ed285539f9.tar.gz
gentoo-2-0c26bf963ad05d1b31b124d815f772ed285539f9.tar.bz2
gentoo-2-0c26bf963ad05d1b31b124d815f772ed285539f9.zip
Version bump. This is a stable candidate.
(Portage version: 2.2_rc3/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'app-shells/dash/dash-0.5.4.11.ebuild')
-rw-r--r--app-shells/dash/dash-0.5.4.11.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-shells/dash/dash-0.5.4.11.ebuild b/app-shells/dash/dash-0.5.4.11.ebuild
new file mode 100644
index 000000000000..0a101de96942
--- /dev/null
+++ b/app-shells/dash/dash-0.5.4.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.4.11.ebuild,v 1.1 2008/07/27 18:06:26 loki_val Exp $
+
+inherit autotools eutils flag-o-matic
+
+DEB_PV=${PV%.*}
+DEB_PATCH=${PV##*.}
+DEB_PF="${PN}_${DEB_PV}-${DEB_PATCH}"
+MY_P="${PN}-${DEB_PV}"
+
+DESCRIPTION="DASH is a direct descendant of the NetBSD version of ash (the Almquist SHell) and is POSIX compliant"
+HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
+SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${PN}-${DEB_PV}.tar.gz
+ mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libedit static"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${WORKDIR}"/${DEB_PF}.diff
+ cd "${S}"
+ epatch debian/diff/*
+
+ # Fix the invalid sort
+ sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
+
+ # Always statically link libedit in to ensure we always boot if it changes
+ # which it has done in the past.
+ local s="s/-ledit/-Wl,-Bstatic -ledit -Wl,-Bdynamic -lcurses/g"
+ use static && s="s/-ledit/-ledit -lcurses/g"
+ sed -i -e "${s}" configure.ac || die "Failed to sed configure.ac"
+
+ # May as well, as the debian patches force this anyway
+ eautoreconf
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf \
+ --bindir=/bin \
+ $(use_with libedit) \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog debian/changelog
+}