summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-28 18:46:27 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-28 18:46:27 +0000
commitcf55cf2e8805b6aa918c42a12d724d7e95992baa (patch)
tree006796410800124e934fcf27a9dcd7564abef559 /app-shells/dash
parentStable for HPPA (bug #207663). (diff)
downloadgentoo-2-cf55cf2e8805b6aa918c42a12d724d7e95992baa.tar.gz
gentoo-2-cf55cf2e8805b6aa918c42a12d724d7e95992baa.tar.bz2
gentoo-2-cf55cf2e8805b6aa918c42a12d724d7e95992baa.zip
Make sure we install into /bin #207942 by Martin.
(Portage version: 2.1.4)
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/ChangeLog5
-rw-r--r--app-shells/dash/dash-0.5.4.6-r1.ebuild58
-rw-r--r--app-shells/dash/files/digest-dash-0.5.4.6-r16
3 files changed, 69 insertions, 0 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index d02ccbac3bd4..fe6e6f21cf4c 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/dash
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+*dash-0.5.4.6-r1 (28 Jan 2008)
+
+ 28 Jan 2008; Mike Frysinger <vapier@gentoo.org> +dash-0.5.4.6-r1.ebuild:
+ Make sure we install into /bin #207942 by Martin.
+
*dash-0.5.4.6 (28 Jan 2008)
28 Jan 2008; Mike Frysinger <vapier@gentoo.org> +dash-0.5.4.6.ebuild:
diff --git a/app-shells/dash/dash-0.5.4.6-r1.ebuild b/app-shells/dash/dash-0.5.4.6-r1.ebuild
new file mode 100644
index 000000000000..04b6a77a53c4
--- /dev/null
+++ b/app-shells/dash/dash-0.5.4.6-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.4.6-r1.ebuild,v 1.1 2008/01/28 18:46:26 vapier Exp $
+
+inherit autotools eutils flag-o-matic
+
+DEB_PV=${PV%.*}
+DEB_PATCH=${PV##*.}
+DEB_PF="${PN}_${DEB_PV}-${DEB_PATCH}"
+MY_P="${PN}-${DEB_PV}"
+
+DESCRIPTION="DASH is a direct descendant of the NetBSD version of ash (the Almquist SHell) and is POSIX compliant"
+HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
+SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${PN}-${DEB_PV}.tar.gz
+ mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86"
+IUSE="libedit static"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${WORKDIR}"/${DEB_PF}.diff
+ cd "${S}"
+ epatch debian/diff/*
+
+ # Fix the invalid sort
+ sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
+
+ # Always statically link libedit in to ensure we always boot if it changes
+ # which it has done in the past.
+ local s="s/-ledit/-Wl,-Bstatic -ledit -Wl,-Bdynamic -lcurses/g"
+ use static && s="s/-ledit/-ledit -lcurses/g"
+ sed -i -e "${s}" configure.ac || die "Failed to sed configure.ac"
+
+ # May as well, as the debian patches force this anyway
+ eautoreconf
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf \
+ --bindir=/bin \
+ $(use_with libedit) \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog debian/changelog
+}
diff --git a/app-shells/dash/files/digest-dash-0.5.4.6-r1 b/app-shells/dash/files/digest-dash-0.5.4.6-r1
new file mode 100644
index 000000000000..211e8cc74e23
--- /dev/null
+++ b/app-shells/dash/files/digest-dash-0.5.4.6-r1
@@ -0,0 +1,6 @@
+MD5 bc457e490a589d2f87f2333616b67931 dash-0.5.4.tar.gz 212145
+RMD160 322fc2fffc5fddf4223d39c57eaeb9b4222303fa dash-0.5.4.tar.gz 212145
+SHA256 a9dc8f0237f632dd2c1bfeff80b1052e75fafaef0d767e3beab0bd8becced623 dash-0.5.4.tar.gz 212145
+MD5 1cf4a88f7b2686f38e8fa03cd5e8f2cd dash_0.5.4-6.diff.gz 124115
+RMD160 2901a9ab59cc804c656201ce3cfca0129ff3ca24 dash_0.5.4-6.diff.gz 124115
+SHA256 2f3c32162b36703a6af9a357822a645bbb86e29f2af6544f102707de1aa8bba6 dash_0.5.4-6.diff.gz 124115