summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-03-18 04:01:39 +0000
committerMike Gilbert <floppym@gentoo.org>2012-03-18 04:01:39 +0000
commit40dcfab1b5414b307df6f0b3e7837a30c22c5c0c (patch)
tree48fad1c1403fd0e25c6508576c5b3cc30ebfcdde /app-shells/ksh
parentDrop old app-misc/task mask. (diff)
downloadgentoo-2-40dcfab1b5414b307df6f0b3e7837a30c22c5c0c.tar.gz
gentoo-2-40dcfab1b5414b307df6f0b3e7837a30c22c5c0c.tar.bz2
gentoo-2-40dcfab1b5414b307df6f0b3e7837a30c22c5c0c.zip
Restore last version with stable keywords.
(Portage version: 2.2.0_alpha91/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-shells/ksh')
-rw-r--r--app-shells/ksh/ChangeLog7
-rw-r--r--app-shells/ksh/ksh-93.20071105.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index c86aa33b1f8e..0d954a1c2f8a 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/ksh
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.46 2012/03/18 03:54:21 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.47 2012/03/18 04:01:39 floppym Exp $
+
+*ksh-93.20071105 (18 Mar 2012)
+
+ 18 Mar 2012; Mike Gilbert <floppym@gentoo.org> +ksh-93.20071105.ebuild:
+ Restore last version with stable keywords.
*ksh-93.20120229 (18 Mar 2012)
diff --git a/app-shells/ksh/ksh-93.20071105.ebuild b/app-shells/ksh/ksh-93.20071105.ebuild
new file mode 100644
index 000000000000..175d636531aa
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20071105.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20071105.ebuild,v 1.10 2012/03/18 04:01:39 floppym Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+RELEASE="2007-11-05"
+LOCALE_RELEASE="2007-11-05"
+INIT_RELEASE="${RELEASE}"
+
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="http://www.kornshell.com/"
+SRC_URI="nls? ( mirror://gentoo/ast-ksh-locale.${LOCALE_RELEASE}.tgz )
+ mirror://gentoo/INIT.${INIT_RELEASE}.tgz
+ mirror://gentoo/ast-ksh.${RELEASE}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ~ppc64 s390 sparc x86"
+IUSE="nls"
+
+DEPEND="!app-shells/pdksh"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ # the AT&T build tools look in here for packages.
+ mkdir -p "${S}"/lib/package/tgz
+
+ # move the packages into place.
+ cp "${DISTDIR}"/ast-ksh.${RELEASE}.tgz "${S}"/lib/package/tgz/ || die
+
+ if use nls; then
+ cp "${DISTDIR}"/ast-ksh-locale.${LOCALE_RELEASE}.tgz "${S}"/lib/package/tgz/ || die
+ fi
+
+ # INIT provides the basic tools to start building.
+ unpack INIT.${INIT_RELEASE}.tgz
+
+ # run through /bin/sh due to #141906
+ sed -i '1i#!/bin/sh' "${S}"/bin/package || die
+
+ # `package read` will unpack any tarballs put in place.
+ "${S}"/bin/package read || die
+}
+
+src_compile() {
+ strip-flags; export CCFLAGS="${CFLAGS}"
+
+ cd "${S}"; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
+
+ # install the optional locale data.
+ if use nls; then
+ cd "${S}"; ./bin/package only make ast-ksh-locale CC="$(tc-getCC)"
+ fi
+}
+
+src_install() {
+ exeinto /bin
+
+ doexe "${S}"/arch/linux.*/bin/ksh || die
+
+ newman "${S}"/arch/linux.*/man/man1/sh.1 ksh.1
+
+ dodoc lib/package/LICENSES/ast
+ dohtml lib/package/ast-ksh.html
+
+ if use nls; then
+ dodir /usr/share
+ mv "${S}"/share/lib/locale "${D}"/usr/share
+ find "${D}"/usr/share/locale -type f -name 'LC_TIME' -exec rm -rf {} \; 2>/dev/null
+ fi
+}