summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-21 11:49:19 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-21 11:49:19 +0000
commitad5a26abae501866723be5ce89946771ca6ea44f (patch)
tree0f88a06bc44157ca159bc7ad4daf4cc834c7f438 /app-shells/tcsh
parentNo more gzipped HTML documentation (diff)
downloadgentoo-2-ad5a26abae501866723be5ce89946771ca6ea44f.tar.gz
gentoo-2-ad5a26abae501866723be5ce89946771ca6ea44f.tar.bz2
gentoo-2-ad5a26abae501866723be5ce89946771ca6ea44f.zip
No more gzipped HTML documentation
Diffstat (limited to 'app-shells/tcsh')
-rw-r--r--app-shells/tcsh/ChangeLog9
-rw-r--r--app-shells/tcsh/files/digest-tcsh-6.10-r31
-rw-r--r--app-shells/tcsh/tcsh-6.10-r3.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/app-shells/tcsh/ChangeLog b/app-shells/tcsh/ChangeLog
index e3a2a0beaa3c..e85ae614673d 100644
--- a/app-shells/tcsh/ChangeLog
+++ b/app-shells/tcsh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/tcsh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.1 2002/02/01 21:53:09 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.2 2002/03/21 11:49:19 seemant Exp $
+
+*tcsh-6.10-r3 (21 Mar 2002)
+
+ 21 Mar 2002; Seemant Kulleen <seemant@gentoo.org> tcsh-6.10-r3.ebuild :
+
+ HTML documentation will not get gzipped any longer. Thanks to
+ stefan@mdy.univie.ac.at for pointing this out.
*tcsh-6.10-r2 (1 Feb 2002)
diff --git a/app-shells/tcsh/files/digest-tcsh-6.10-r3 b/app-shells/tcsh/files/digest-tcsh-6.10-r3
new file mode 100644
index 000000000000..1d2487bf5af0
--- /dev/null
+++ b/app-shells/tcsh/files/digest-tcsh-6.10-r3
@@ -0,0 +1 @@
+MD5 f459c423074d85dfaa55439eb908a053 tcsh-6.10.tar.gz 665733
diff --git a/app-shells/tcsh/tcsh-6.10-r3.ebuild b/app-shells/tcsh/tcsh-6.10-r3.ebuild
new file mode 100644
index 000000000000..43c97fb126e8
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.10-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r3.ebuild,v 1.1 2002/03/21 11:49:19 seemant Exp $
+
+S=${WORKDIR}/${P}.00
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+#ugh, astron.com doesn't support passive ftp... maybe another source?
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${P}.tar.gz"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ perl? ( sys-devel/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
+}
+
+src_compile() {
+
+ ./configure \
+ --prefix=/ \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install install.man || die
+ if [ "`use perl`" ]
+ then
+ perl tcsh.man2html || die
+ dohtml tcsh.html/*.html
+ fi
+ dosym tcsh /bin/csh
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ insinto /etc
+ doins ${FILESDIR}/csh.cshrc ${FILESDIR}/csh.login
+}
+
+
+