summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-08 07:35:00 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-08 07:35:00 +0000
commit9f4d9800210058f41dcb550efff853684d0458c5 (patch)
tree3b6e8dcb96e917c7d71ed0c2db26be6a90b484d3 /app-shells/zsh
parentFixed compile error when using tetex-2; bug #70378. Thanks to the_sprif@hotma... (diff)
downloadgentoo-2-9f4d9800210058f41dcb550efff853684d0458c5.tar.gz
gentoo-2-9f4d9800210058f41dcb550efff853684d0458c5.tar.bz2
gentoo-2-9f4d9800210058f41dcb550efff853684d0458c5.zip
Fixed maketest. Thanks to Marien Zwart <m_zwart@123mail.org>; bug #70364.
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/ChangeLog6
-rw-r--r--app-shells/zsh/zsh-4.0.9-r4.ebuild13
-rw-r--r--app-shells/zsh/zsh-4.2.1-r1.ebuild3
3 files changed, 19 insertions, 3 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 80880819bb1d..844ddd3585ab 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/zsh
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.64 2004/11/06 15:43:02 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.65 2004/11/08 07:35:00 usata Exp $
+
+ 08 Nov 2004; Mamoru KOMACHI <usata@gentoo.org> zsh-4.0.9-r4.ebuild,
+ zsh-4.2.1-r1.ebuild:
+ Fixed maketest. Thanks to Marien Zwart <m_zwart@123mail.org>; bug #70364.
*zsh-4.2.1-r1 (07 Nov 2004)
*zsh-4.0.9-r4 (07 Nov 2004)
diff --git a/app-shells/zsh/zsh-4.0.9-r4.ebuild b/app-shells/zsh/zsh-4.0.9-r4.ebuild
index 6aac3c5871f3..ffe1d63fe8cb 100644
--- a/app-shells/zsh/zsh-4.0.9-r4.ebuild
+++ b/app-shells/zsh/zsh-4.0.9-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.9-r4.ebuild,v 1.1 2004/11/06 15:43:02 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.9-r4.ebuild,v 1.2 2004/11/08 07:35:00 usata Exp $
inherit flag-o-matic eutils
@@ -61,6 +61,7 @@ src_compile() {
}
src_test() {
+ addpredict /dev/ptmx
make check || die "make check failed"
}
@@ -98,3 +99,13 @@ pkg_preinst() {
mv ${ROOT}/etc/zsh/zshenv ${ROOT}/etc/zsh/zprofile
fi
}
+
+pkg_postinst() {
+ einfo
+ einfo "If you want to enable Portage completion,"
+ einfo "emerge app-shells/zsh-completion and add"
+ einfo " autoload -U compinit"
+ einfo " compinit"
+ einfo "to your ~/.zshrc"
+ einfo
+}
diff --git a/app-shells/zsh/zsh-4.2.1-r1.ebuild b/app-shells/zsh/zsh-4.2.1-r1.ebuild
index 6837ec8756fc..1b8a79c83ea7 100644
--- a/app-shells/zsh/zsh-4.2.1-r1.ebuild
+++ b/app-shells/zsh/zsh-4.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.2.1-r1.ebuild,v 1.1 2004/11/06 15:43:02 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.2.1-r1.ebuild,v 1.2 2004/11/08 07:35:00 usata Exp $
inherit eutils
@@ -80,6 +80,7 @@ src_compile() {
}
src_test() {
+ addpredict /dev/ptmx
make check || die "make check failed"
}