summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-01-04 15:43:21 +0000
committerTorsten Veller <tove@gentoo.org>2009-01-04 15:43:21 +0000
commite6afa7d34ebab3dbb2a0a7dc1245db9a0a1c4d6f (patch)
tree54fec50d33f2dfa75b1f72cc80b36debfeeb9cd6 /app-shells/zsh
parentamd64/x86 stable, bug #253166 (diff)
downloadgentoo-2-e6afa7d34ebab3dbb2a0a7dc1245db9a0a1c4d6f.tar.gz
gentoo-2-e6afa7d34ebab3dbb2a0a7dc1245db9a0a1c4d6f.tar.bz2
gentoo-2-e6afa7d34ebab3dbb2a0a7dc1245db9a0a1c4d6f.zip
Version bump (#246544)
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-tuxonice i686)
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/ChangeLog8
-rw-r--r--app-shells/zsh/files/prompt_gentoo_setup-133
-rw-r--r--app-shells/zsh/zsh-4.3.9.ebuild183
3 files changed, 223 insertions, 1 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index d8a356708d57..257d4140a4bb 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/zsh
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.134 2008/06/29 10:46:16 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.135 2009/01/04 15:43:20 tove Exp $
+
+*zsh-4.3.9 (04 Jan 2009)
+
+ 04 Jan 2009; Torsten Veller <tove@gentoo.org>
+ +files/prompt_gentoo_setup-1, +zsh-4.3.9.ebuild:
+ Version bump (#246544)
29 Jun 2008; Torsten Veller <tove@gentoo.org> zsh-4.3.4-r1.ebuild:
Add missing die: || "..." -> || die "..."
diff --git a/app-shells/zsh/files/prompt_gentoo_setup-1 b/app-shells/zsh/files/prompt_gentoo_setup-1
new file mode 100644
index 000000000000..0d071e9864be
--- /dev/null
+++ b/app-shells/zsh/files/prompt_gentoo_setup-1
@@ -0,0 +1,33 @@
+# gentoo prompt theme
+
+prompt_gentoo_help () {
+ cat <<'EOF'
+This prompt is color-scheme-able. You can invoke it thus:
+
+ prompt gentoo [<promptcolor> [<usercolor> [<rootcolor>]]]
+
+EOF
+}
+
+prompt_gentoo_setup () {
+ prompt_gentoo_prompt=${1:-'blue'}
+ prompt_gentoo_user=${2:-'green'}
+ prompt_gentoo_root=${3:-'red'}
+
+ if [ "$USER" = 'root' ]
+ then
+ base_prompt="%B%F{$prompt_gentoo_root}%m%k "
+ else
+ base_prompt="%B%F{$prompt_gentoo_user}%n@%m%k "
+ fi
+ post_prompt="%b%f%k"
+
+ #setopt noxtrace localoptions
+
+ path_prompt="%B%F{$prompt_gentoo_prompt}%1~"
+ PS1="$base_prompt$path_prompt %# $post_prompt"
+ PS2="$base_prompt$path_prompt %_> $post_prompt"
+ PS3="$base_prompt$path_prompt ?# $post_prompt"
+}
+
+prompt_gentoo_setup "$@"
diff --git a/app-shells/zsh/zsh-4.3.9.ebuild b/app-shells/zsh/zsh-4.3.9.ebuild
new file mode 100644
index 000000000000..20e94c240188
--- /dev/null
+++ b/app-shells/zsh/zsh-4.3.9.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.9.ebuild,v 1.1 2009/01/04 15:43:20 tove Exp $
+
+# doc package for -dev version exists?
+doc_available=true
+
+inherit flag-o-matic eutils multilib
+
+MY_PV=${PV/_p/-dev-}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+zsh_ftp="ftp://ftp.zsh.org/pub"
+
+if [[ ${PV} != "${MY_PV}" ]] ; then
+ ZSH_URI="${zsh_ftp}/development/${PN}-${MY_PV}.tar.bz2"
+ if ${doc_available} ; then
+ ZSH_DOC_URI="${zsh_ftp}/development/${PN}-${MY_PV}-doc.tar.bz2"
+ else
+ ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
+ fi
+else
+ ZSH_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ ${zsh_ftp}/${P}.tar.bz2"
+ ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
+fi
+
+LOVERS_PV=0.5.orig
+LOVERS_P=zsh-lovers-${LOVERS_PV}
+LOVERS_URI="http://deb.grml.org/pool/main/z/zsh-lovers"
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+SRC_URI="${ZSH_URI}
+ examples? ( ${LOVERS_URI}/zsh-lovers_${LOVERS_PV}.tar.gz )
+ doc? ( ${ZSH_DOC_URI} )"
+
+LICENSE="ZSH gdbm? ( GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="caps debug doc examples gdbm maildir pcre static unicode"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ caps? ( sys-libs/libcap )
+ pcre? ( >=dev-libs/libpcre-3.9 )
+ gdbm? ( sys-libs/gdbm )"
+DEPEND="sys-apps/groff
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix zshall problem with soelim
+ ln -s Doc man1
+ mv Doc/zshall.1 Doc/zshall.1.soelim
+ soelim Doc/zshall.1.soelim > Doc/zshall.1
+
+ epatch "${FILESDIR}/${PN}"-init.d-gentoo.diff
+}
+
+src_compile() {
+ local myconf=
+
+ if use static ; then
+ myconf="${myconf} --disable-dynamic"
+ append-ldflags -static
+ fi
+ if use debug ; then
+ myconf="${myconf} \
+ --enable-zsh-debug \
+ --enable-zsh-mem-debug \
+ --enable-zsh-mem-warning \
+ --enable-zsh-secure-free \
+ --enable-zsh-hash-debug"
+ fi
+
+ econf \
+ --bindir=/bin \
+ --libdir=/usr/$(get_libdir) \
+ --enable-etcdir=/etc/zsh \
+ --enable-fndir=/usr/share/zsh/${PV%_*}/functions \
+ --enable-site-fndir=/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --enable-ldflags="${LDFLAGS}" \
+ --with-term-lib="ncursesw ncurses" \
+ --with-tcsetpgrp \
+ $(use_enable maildir maildir-support) \
+ $(use_enable pcre) \
+ $(use_enable caps cap) \
+ $(use_enable unicode multibyte) \
+ $(use_enable gdbm ) \
+ ${myconf} || die "configure failed"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ # removed cap and curses because linking failes
+ sed -i \
+ -e "s/link=no/link=static/g" \
+ -e 's/cap.mdd link=static/cap.mdd link=no/' \
+ -e 's/curses.mdd link=static/curses.mdd link=no/' \
+ config.modules || die
+# else
+# sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" Makefile
+ fi
+
+ emake || die "make failed"
+}
+
+src_test() {
+ addpredict /dev/ptmx
+ make check || ewarn "make check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.info || die
+
+ # Bug 207019
+ rm "${D}"/bin/${PN}-${MY_PV} || die
+
+ insinto /etc/zsh
+ doins "${FILESDIR}"/zprofile || die
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/${PV%_*}/functions/Prompts
+ newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup || die
+
+ # install miscellaneous scripts; bug #54520
+ local i
+ sed -i -e "s:/usr/local:/usr:g" "${S}"/{Util,Misc}/* || die
+ for i in Util Misc ; do
+ insinto /usr/share/zsh/${PV%_*}/${i}
+ doins ${i}/* || die
+ done
+
+ dodoc ChangeLog* META-FAQ NEWS README config.modules
+
+ if use doc ; then
+ cd "${WORKDIR}/${PN}-${PV%_*}"
+ dohtml -r Doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf} || die
+ cd -
+ fi
+
+ if use examples ; then
+ cd "${WORKDIR}/${LOVERS_P/.orig/}"
+# asciidoc zsh-lovers.1.txt
+# mv zsh-lovers.1.html zsh-lovers.html
+# a2x -f manpage zsh-lovers.1.txt
+# a2x -f pdf zsh-lovers.1.txt
+# mv zsh-lovers.1.pdf zsh-lovers.pdf
+
+ doman zsh-lovers.1 || die "doman zsh-lovers failed"
+ dohtml zsh-lovers.html || die "dohtml zsh-lovers failed"
+ docinto zsh-lovers
+ dodoc zsh.vim README || die
+ insinto /usr/share/doc/${PF}/zsh-lovers
+# doins zsh-lovers.pdf refcard.pdf || die
+ doins zsh-lovers.{ps,pdf} refcard.{dvi,ps,pdf} || die
+ doins -r zsh_people || die "doins zsh_people failed"
+ cd -
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_postinst() {
+ # should link to http://www.gentoo.org/doc/en/zsh.xml
+ elog
+ elog "If you want to enable Portage completions and Gentoo prompt,"
+ elog "emerge app-shells/zsh-completion and add"
+ elog " autoload -U compinit promptinit"
+ elog " compinit"
+ elog " promptinit; prompt gentoo"
+ elog "to your ~/.zshrc"
+ elog
+ elog "Also, if you want to enable cache for the completions, add"
+ elog " zstyle ':completion::complete:*' use-cache 1"
+ elog "to your ~/.zshrc"
+ elog
+}