summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-05-13 08:48:24 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-05-13 08:48:24 +0000
commit0a7598e8528acd836fc5bdc76c54a6761c2c3837 (patch)
treea0e13bb3b76c244be3d55321cdc3c6a1fd359dea /app-shells
parentDon't install binaries in the 3.2 slot to avoid file collisions between slots. (diff)
downloadgentoo-2-0a7598e8528acd836fc5bdc76c54a6761c2c3837.tar.gz
gentoo-2-0a7598e8528acd836fc5bdc76c54a6761c2c3837.tar.bz2
gentoo-2-0a7598e8528acd836fc5bdc76c54a6761c2c3837.zip
Added yet another upstream fix. Removed old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/bash-4.3_p11-r5.ebuild (renamed from app-shells/bash/bash-4.3_p11-r2.ebuild)7
-rw-r--r--app-shells/bash/files/bash-4.3-bind-compund-arry.patch10
3 files changed, 22 insertions, 3 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index d6e9df3c4182..424feb9a8bec 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.368 2014/05/07 15:28:10 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.369 2014/05/13 08:48:24 polynomial-c Exp $
+
+*bash-4.3_p11-r5 (13 May 2014)
+
+ 13 May 2014; Lars Wendler <polynomial-c@gentoo.org> -bash-4.3_p11-r2.ebuild,
+ +bash-4.3_p11-r5.ebuild, +files/bash-4.3-bind-compund-arry.patch:
+ Added yet another upstream fix. Removed old.
*bash-4.3_p11-r4 (07 May 2014)
diff --git a/app-shells/bash/bash-4.3_p11-r2.ebuild b/app-shells/bash/bash-4.3_p11-r5.ebuild
index ca5fe1d62ed1..18ce03b2619c 100644
--- a/app-shells/bash/bash-4.3_p11-r2.ebuild
+++ b/app-shells/bash/bash-4.3_p11-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p11-r2.ebuild,v 1.1 2014/04/26 20:14:20 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p11-r5.ebuild,v 1.1 2014/05/13 08:48:24 polynomial-c Exp $
EAPI="4"
@@ -84,7 +84,10 @@ src_prepare() {
touch -r . doc/*
epatch "${FILESDIR}"/${PN}-4.3-jobs-run-sigchld-trap.patch \
- "${FILESDIR}"/${PN}-4.3-complete-dequoting.patch
+ "${FILESDIR}"/${PN}-4.3-complete-dequoting.patch \
+ "${FILESDIR}"/${PN}-4.3-extglob-directory.patch \
+ "${FILESDIR}"/${PN}-4.3-localvar-invisible.patch \
+ "${FILESDIR}"/${PN}-4.3-bind-compund-arry.patch
epatch_user
}
diff --git a/app-shells/bash/files/bash-4.3-bind-compund-arry.patch b/app-shells/bash/files/bash-4.3-bind-compund-arry.patch
new file mode 100644
index 000000000000..c46bc33eca5b
--- /dev/null
+++ b/app-shells/bash/files/bash-4.3-bind-compund-arry.patch
@@ -0,0 +1,10 @@
+*** ../bash-4.3-patched/arrayfunc.c 2014-03-28 10:54:21.000000000 -0400
+--- arrayfunc.c 2014-05-12 11:19:00.000000000 -0400
+***************
+*** 180,183 ****
+--- 180,184 ----
+ FREE (newval);
+
++ VUNSETATTR (entry, att_invisible); /* no longer invisible */
+ return (entry);
+ }