summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-02-23 03:45:24 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-02-23 03:45:24 +0000
commit1d927cdfc476396cc3cacbe8b77bf72ff5e5dfc0 (patch)
tree4055ab2827b668b4982dee6f7e609771048a8328 /app-shells
parentAdded gDesklets desklets without an upstream home (bug #259971) (diff)
downloadgentoo-2-1d927cdfc476396cc3cacbe8b77bf72ff5e5dfc0.tar.gz
gentoo-2-1d927cdfc476396cc3cacbe8b77bf72ff5e5dfc0.tar.bz2
gentoo-2-1d927cdfc476396cc3cacbe8b77bf72ff5e5dfc0.zip
Version bump. Includes new portage options and a new repoman bash-completion module
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/gentoo-bashcomp/ChangeLog9
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20090222.ebuild35
2 files changed, 43 insertions, 1 deletions
diff --git a/app-shells/gentoo-bashcomp/ChangeLog b/app-shells/gentoo-bashcomp/ChangeLog
index 4038952a5351..c5d553cbf6fd 100644
--- a/app-shells/gentoo-bashcomp/ChangeLog
+++ b/app-shells/gentoo-bashcomp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/gentoo-bashcomp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.21 2009/02/21 20:29:09 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/ChangeLog,v 1.22 2009/02/23 03:45:24 darkside Exp $
+
+*gentoo-bashcomp-20090222 (23 Feb 2009)
+
+ 23 Feb 2009; Jeremy Olexa <darkside@gentoo.org>
+ +gentoo-bashcomp-20090222.ebuild:
+ Version bump. Includes new portage options and a new repoman bash-completion
+ module
*gentoo-bashcomp-20080521-r1 (21 Feb 2009)
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20090222.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20090222.ebuild
new file mode 100644
index 000000000000..22e1b97b0a13
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20090222.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/gentoo-bashcomp-20090222.ebuild,v 1.1 2009/02/23 03:45:24 darkside Exp $
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-shells/bash-completion"
+
+src_install() {
+ insinto /usr/share/bash-completion
+ doins gentoo || die "failed to install gentoo module"
+ doins repoman || die "failed to install repoman module"
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ # can't use bash-completion.eclass.
+ elog "To enable command-line completion for ${PN}, run:"
+ elog
+ elog " eselect bashcomp enable gentoo"
+ elog
+ elog "to install locally, or"
+ elog
+ elog " eselect bashcomp enable --global gentoo"
+ elog
+ elog "to install system-wide. (and/or repoman instead of gentoo if you use"
+ elog "repoman frequently)"
+}