summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-09 03:50:39 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-09 03:50:39 +0000
commit1e850450c0ae38de21629361a7bf9c2d4af2e1e1 (patch)
tree007810fdb15dbcd422c91c6cbb74ecdeb5118d26 /app-shells
parentold (diff)
downloadgentoo-2-1e850450c0ae38de21629361a7bf9c2d4af2e1e1.tar.gz
gentoo-2-1e850450c0ae38de21629361a7bf9c2d4af2e1e1.tar.bz2
gentoo-2-1e850450c0ae38de21629361a7bf9c2d4af2e1e1.zip
Fix parallel build in glob dir #300143 by Tiago Pereira.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/bash-4.1.ebuild4
-rw-r--r--app-shells/bash/files/bash-4.0-parallel-build.patch28
-rw-r--r--app-shells/bash/files/bash-4.1-parallel-build.patch23
4 files changed, 59 insertions, 3 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index ad903563da63..f18076c33166 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.243 2010/01/05 00:52:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.244 2010/01/09 03:50:39 vapier Exp $
+
+ 09 Jan 2010; Mike Frysinger <vapier@gentoo.org>
+ files/bash-4.0-parallel-build.patch, bash-4.1.ebuild,
+ +files/bash-4.1-parallel-build.patch:
+ Fix parallel build in glob dir #300143 by Tiago Pereira.
*bash-4.1 (05 Jan 2010)
diff --git a/app-shells/bash/bash-4.1.ebuild b/app-shells/bash/bash-4.1.ebuild
index d6df758a8430..4f19458329f6 100644
--- a/app-shells/bash/bash-4.1.ebuild
+++ b/app-shells/bash/bash-4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1.ebuild,v 1.1 2010/01/05 00:52:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.1.ebuild,v 1.2 2010/01/09 03:50:39 vapier Exp $
EAPI="1"
@@ -76,7 +76,7 @@ src_unpack() {
epause
epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
fi
- sed -i '/\.o: .*shell\.h/s:$: pathnames.h:' Makefile.in #267613
+ epatch "${FILESDIR}"/${PN}-4.1-parallel-build.patch
fi
}
diff --git a/app-shells/bash/files/bash-4.0-parallel-build.patch b/app-shells/bash/files/bash-4.0-parallel-build.patch
index 79e04c8cc295..8384e2c9019c 100644
--- a/app-shells/bash/files/bash-4.0-parallel-build.patch
+++ b/app-shells/bash/files/bash-4.0-parallel-build.patch
@@ -35,3 +35,31 @@ and another ...
# rules for losing makes, like SunOS
casemod.o: casemod.c
clktck.o: clktck.c
+
+http://bugs.gentoo.org/300143
+
+and another ...
+
+--- bash-4.0/lib/glob/Makefile.in
++++ bash-4.0/lib/glob/Makefile.in
+@@ -119,6 +119,11 @@
+ mostlyclean: clean
+ -( cd doc && $(MAKE) $(MFLAGS) $@ )
+
++# Dependencies
++
++${BUILD_DIR}/pathnames.h: ${BUILD_DIR}/config.h ${BUILD_DIR}/Makefile Makefile
++ -( cd ${BUILD_DIR} && ${MAKE} ${MFLAGS} pathnames.h )
++
+ ######################################################################
+ # #
+ # Dependencies for the object files which make up this library. #
+@@ -136,7 +141,7 @@
+ strmatch.o: $(BUILD_DIR)/config.h
+ strmatch.o: $(BASHINCDIR)/stdc.h
+
+-glob.o: $(BUILD_DIR)/config.h
++glob.o: $(BUILD_DIR)/config.h $(topdir)/shell.h $(BUILD_DIR)/pathnames.h
+ glob.o: $(topdir)/bashtypes.h $(BASHINCDIR)/ansi_stdlib.h $(topdir)/bashansi.h
+ glob.o: $(BASHINCDIR)/posixstat.h $(BASHINCDIR)/memalloc.h
+ glob.o: strmatch.h glob.h
diff --git a/app-shells/bash/files/bash-4.1-parallel-build.patch b/app-shells/bash/files/bash-4.1-parallel-build.patch
new file mode 100644
index 000000000000..ae44bcc0cf6d
--- /dev/null
+++ b/app-shells/bash/files/bash-4.1-parallel-build.patch
@@ -0,0 +1,23 @@
+--- bash-4.1/lib/glob/Makefile.in
++++ bash-4.1/lib/glob/Makefile.in
+@@ -119,6 +119,11 @@
+ mostlyclean: clean
+ -( cd doc && $(MAKE) $(MFLAGS) $@ )
+
++# Dependencies
++
++${BUILD_DIR}/pathnames.h: ${BUILD_DIR}/config.h ${BUILD_DIR}/Makefile Makefile
++ -( cd ${BUILD_DIR} && ${MAKE} ${MFLAGS} pathnames.h )
++
+ ######################################################################
+ # #
+ # Dependencies for the object files which make up this library. #
+@@ -136,7 +141,7 @@
+ strmatch.o: $(BUILD_DIR)/config.h
+ strmatch.o: $(BASHINCDIR)/stdc.h
+
+-glob.o: $(BUILD_DIR)/config.h
++glob.o: $(BUILD_DIR)/config.h $(topdir)/shell.h $(BUILD_DIR)/pathnames.h
+ glob.o: $(topdir)/bashtypes.h $(BASHINCDIR)/ansi_stdlib.h $(topdir)/bashansi.h
+ glob.o: $(BASHINCDIR)/posixstat.h $(BASHINCDIR)/memalloc.h
+ glob.o: strmatch.h glob.h