summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-06 22:52:36 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-06 22:52:36 +0000
commit2a4ae49c6ea1f22baf3105816e2ef77179aad311 (patch)
tree5ba8589ab5e20713fa25050e989a78711a284425 /app-shells
parentFix bug 306569 by not loading vim plugins while calling vim in gtkdoc-fixxref (diff)
downloadgentoo-2-2a4ae49c6ea1f22baf3105816e2ef77179aad311.tar.gz
gentoo-2-2a4ae49c6ea1f22baf3105816e2ef77179aad311.tar.bz2
gentoo-2-2a4ae49c6ea1f22baf3105816e2ef77179aad311.zip
Avoid autotool depends #304901 by Kevin Morgan.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-4.0_p37.ebuild5
-rw-r--r--app-shells/bash/files/bash-4.0-configure.patch25
3 files changed, 34 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 4de861e8bcae..d2a00a789591 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.246 2010/02/04 00:46:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.247 2010/03/06 22:52:36 vapier Exp $
+
+ 06 Mar 2010; Mike Frysinger <vapier@gentoo.org> bash-4.0_p37.ebuild,
+ +files/bash-4.0-configure.patch:
+ Avoid autotool depends #304901 by Kevin Morgan.
04 Feb 2010; Mike Frysinger <vapier@gentoo.org> bash-4.1_p2.ebuild:
Move USE=bashlogger from custom patch to supported define #303333 by
diff --git a/app-shells/bash/bash-4.0_p37.ebuild b/app-shells/bash/bash-4.0_p37.ebuild
index 7971f9b1772a..4abf017d2414 100644
--- a/app-shells/bash/bash-4.0_p37.ebuild
+++ b/app-shells/bash/bash-4.0_p37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0_p37.ebuild,v 1.1 2010/01/21 05:43:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0_p37.ebuild,v 1.2 2010/03/06 22:52:36 vapier Exp $
EAPI="1"
@@ -65,6 +65,9 @@ src_unpack() {
[[ ${READLINE_PLEVEL} -gt 0 ]] && epatch $(patches -s ${READLINE_PLEVEL} readline ${READLINE_VER})
cd ../..
+ # bash40-037 touches configure.in :x
+ epatch "${FILESDIR}"/${PN}-4.0-configure.patch #304901
+
if ! use vanilla ; then
sed -i '1i#define NEED_FPURGE_DECL' execute_cmd.c # needs fpurge() decl
epatch "${FILESDIR}"/${PN}-3.2-parallel-build.patch #189671
diff --git a/app-shells/bash/files/bash-4.0-configure.patch b/app-shells/bash/files/bash-4.0-configure.patch
new file mode 100644
index 000000000000..e57cb6b2402e
--- /dev/null
+++ b/app-shells/bash/files/bash-4.0-configure.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/304901
+
+newer patches touch configure ... we don't want autotool deps, so update
+the files ourselves
+
+--- bash-4.0/configure
++++ bash-4.0/configure
+@@ -5806,7 +5806,7 @@
+ # static version specified as -llibname to override the
+ # dynamic version
+ case "${host_os}" in
+- darwin[89]*) READLINE_LIB='${READLINE_LIBRARY}' ;;
++ darwin[89]*|darwin10*) READLINE_LIB='${READLINE_LIBRARY}' ;;
+ *) READLINE_LIB=-lreadline ;;
+ esac
+ fi
+@@ -5847,7 +5847,7 @@
+ # static version specified as -llibname to override the
+ # dynamic version
+ case "${host_os}" in
+- darwin[89]*) HISTORY_LIB='${HISTORY_LIBRARY}' ;;
++ darwin[89]*|darwin10*) HISTORY_LIB='${HISTORY_LIBRARY}' ;;
+ *) HISTORY_LIB=-lhistory ;;
+ esac
+ fi