summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2008-12-04 20:46:06 +0000
committerFabian Groffen <grobian@gentoo.org>2008-12-04 20:46:06 +0000
commit4008a78c8b8dcbd599d090a9c0040794d917b62c (patch)
treed4602436fce9e77d10bf6b7324744bf4fbf453d3 /app-shells
parentRestrict to one gtkhtml slot, bug #247636. (diff)
downloadgentoo-2-4008a78c8b8dcbd599d090a9c0040794d917b62c.tar.gz
gentoo-2-4008a78c8b8dcbd599d090a9c0040794d917b62c.tar.bz2
gentoo-2-4008a78c8b8dcbd599d090a9c0040794d917b62c.zip
Version bump, thanks to Anton Yuzhaninov for notifying me
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/tcsh/ChangeLog7
-rw-r--r--app-shells/tcsh/tcsh-6.16.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/app-shells/tcsh/ChangeLog b/app-shells/tcsh/ChangeLog
index 838fbde0bbfa..17301dd2238b 100644
--- a/app-shells/tcsh/ChangeLog
+++ b/app-shells/tcsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/tcsh
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.84 2008/08/03 15:30:33 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.85 2008/12/04 20:46:06 grobian Exp $
+
+*tcsh-6.16 (04 Dec 2008)
+
+ 04 Dec 2008; Fabian Groffen <grobian@gentoo.org> +tcsh-6.16.ebuild:
+ Version bump, thanks to Anton Yuzhaninov for notifying me
03 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-shells/tcsh/tcsh-6.16.ebuild b/app-shells/tcsh/tcsh-6.16.ebuild
new file mode 100644
index 000000000000..ca669f5fd463
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.16.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.16.ebuild,v 1.1 2008/12/04 20:46:06 grobian Exp $
+
+inherit eutils
+
+CONFVER="1.6"
+
+MY_P="${P}.00"
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
+ mirror://gentoo/tcsh-config-${CONFVER}.tar.bz2
+ http://www.gentoo.org/~grobian/distfiles/tcsh-config-${CONFVER}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="perl catalogs"
+RESTRICT="test"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ perl? ( dev-lang/perl )
+ !app-shells/csh" # bug #119703
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${MY_P/16/14}"-debian-dircolors.patch # bug #120792
+ epatch "${FILESDIR}"/${PN}-6.14-makefile.patch # bug #151951
+
+ if use catalogs ; then
+ einfo "enabling NLS catalogs support..."
+ sed -i -e "s/#undef NLS_CATALOGS/#define NLS_CATALOGS/" \
+ config_f.h || die
+ eend $?
+ fi
+}
+
+src_compile() {
+ econf --prefix=/ || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man || die
+
+ if use perl ; then
+ perl tcsh.man2html tcsh.man || die
+ dohtml tcsh.html/*.html
+ fi
+
+ insinto /etc
+ doins \
+ "${WORKDIR}"/tcsh-config/csh.cshrc \
+ "${WORKDIR}"/tcsh-config/csh.login
+
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ # bug #119703: add csh -> tcsh symlink
+ dosym /bin/tcsh /bin/csh
+}