summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-01 03:45:54 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-01 03:45:54 +0000
commit5358b66223c6590f1c332fc102f302c8498645e9 (patch)
tree3b2251633a46aa6f23b7689dbe8e163afdc0adf3 /app-shells
parentfixed urls for ppc binaries; installer fails with glibc errors. (diff)
downloadgentoo-2-5358b66223c6590f1c332fc102f302c8498645e9.tar.gz
gentoo-2-5358b66223c6590f1c332fc102f302c8498645e9.tar.bz2
gentoo-2-5358b66223c6590f1c332fc102f302c8498645e9.zip
manpage
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sandboxshell/ChangeLog5
-rw-r--r--app-shells/sandboxshell/Manifest5
-rw-r--r--app-shells/sandboxshell/files/sandboxshell.186
-rw-r--r--app-shells/sandboxshell/sandboxshell-0.1.ebuild3
4 files changed, 95 insertions, 4 deletions
diff --git a/app-shells/sandboxshell/ChangeLog b/app-shells/sandboxshell/ChangeLog
index 34702c218d6d..8341c0733679 100644
--- a/app-shells/sandboxshell/ChangeLog
+++ b/app-shells/sandboxshell/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for app-shells/sandboxshell
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/ChangeLog,v 1.1 2003/07/09 14:53:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/ChangeLog,v 1.2 2003/08/01 03:45:50 vapier Exp $
*sandboxshell-0.1 (09 Jul 2003)
+ 31 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added manpage.
+
09 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
Initial import. Ebuild submitted by me.
diff --git a/app-shells/sandboxshell/Manifest b/app-shells/sandboxshell/Manifest
index 6e9c69714fae..208ff830f322 100644
--- a/app-shells/sandboxshell/Manifest
+++ b/app-shells/sandboxshell/Manifest
@@ -1,5 +1,6 @@
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-sandboxshell-0.1 0
MD5 540f05af4f7a2f11076c74fab84d6fae files/sandboxshell 1280
MD5 efdff08ba9889ecf839b72ef3f3df410 files/sandboxshell.conf 1646
-MD5 e9b12ed968232649b988e6240b669d67 sandboxshell-0.1.ebuild 645
-MD5 13d32120b2140672efccbbdbba87e66e ChangeLog 356
+MD5 400c9d8f0525d35bee24fb48622e00c6 files/sandboxshell.1 3116
+MD5 e5e23bcd97369c96fc590aeefb317ab2 sandboxshell-0.1.ebuild 680
+MD5 5bcd1edda798c9fb34a0c50da58f205f ChangeLog 426
diff --git a/app-shells/sandboxshell/files/sandboxshell.1 b/app-shells/sandboxshell/files/sandboxshell.1
new file mode 100644
index 000000000000..21de8c8364a4
--- /dev/null
+++ b/app-shells/sandboxshell/files/sandboxshell.1
@@ -0,0 +1,86 @@
+.TH "SANDBOXSHELL" "1" "Jul 2003" "WH0RD.ORG" "Gentoo"
+.SH "NAME"
+sandboxshell \- Launch a bash shell inside of the Portage sandbox
+.SH "SYNOPSIS"
+.TP
+.BR sandboxshell
+.SH "DESCRIPTION"
+\fBsandboxshell\fR serves two basic functions. The first (and
+original reason for design) was to aid in the debugging of ebuilds
+for Gentoo. The second is to provide access to a safe environment
+for running programs whose functions are not entirely known. A
+good example would be an installer obtained off of the internet
+for a game. Who knows where it is going to be writing files !
+.SH "USAGE"
+For debugging ebuilds, simply change dir anywhere below the build
+root for the package. For example, if you are working on the
+package app-games/aaquake2, it will be based in the directory
+(by default) /var/tmp/portage/aaquake2-0.1/. Simply enter that
+directory and then run \fBsandboxshell\fR. The portage environment
+will automatically be detected and you can load it if you want.
+This environment should be an exact duplicate of the portage
+environment under which ebuild scripts run. So if you are
+trying to track down a bug in the compile stage, you need not
+keep running `ebuild aaquake2-0.1.ebuild clean unpack compile`
+and then waiting for it to break.
+.br
+When you are finished using the shell, just type `exit` like you
+would when leaving any other shell.
+.SH "DEFAULT SETUP"
+The defaults can be adjusted via \fI/etc/sandboxshell.conf\fR.
+The default working setup will grant write permissions to the
+following directories (and their subdirectories):
+.br
+/dev/tty
+.br
+/dev/pts
+.br
+/dev/null
+.br
+/tmp
+.br
+${PWD}
+.br
+Additionally, the shell we be granted read only access to /.
+.SH "HELPER FUNCTIONS"
+To manipulate the sandbox environment, a few functions have been
+provided so that you do not have to manipulate the relevant
+variables yourself.
+.TP
+.BR sandboxon
+This will turn on the sandbox. Basically that means that
+control over reading/writing files will be filtered by the
+access controls in the sandbox.
+.TP
+.BR sandboxoff
+This will turn on the sandbox. Basically that means that
+control over reading/writing files will no longer be filtered.
+.TP
+.BR "addread " \fI<path>\fR
+Allow the shell to read \fIpath\fR and everything below it.
+.TP
+.BR "addwrite " \fI<path>\fR
+Allow the shell to write to \fIpath\fR and everything below it.
+.TP
+.BR "adddeny " \fI<path>\fR
+Prevent the shell from writing to \fIpath\fR and everything below it.
+.TP
+.BR "addpredict " \fI<path>\fR
+Add fake access to write to \fIpath\fR and everything below it.
+This means that write calls will not fail, but they will not
+actually succeed either. The shell says that the operation
+worked just fine when in reality nothing happened.
+.SH "REPORTING BUGS"
+Please report any bugs you encounter through our website:
+.LP
+\fBhttp://bugs.gentoo.org/\fR
+.SH "SEE ALSO"
+.BR ebuild (5)
+.SH "FILES"
+.TP
+\fB/etc/sandboxshell.conf\fR
+The bash script loaded when the shell is initially launched.
+.SH "AUTHORS"
+Mike Frysinger <vapier@gentoo.org>
+.SH "CVS HEADER"
+$Id: sandboxshell.1,v 1.1 2003/08/01 03:45:11 vapier Exp $
diff --git a/app-shells/sandboxshell/sandboxshell-0.1.ebuild b/app-shells/sandboxshell/sandboxshell-0.1.ebuild
index 3a3a1ef7e978..50921090d3b9 100644
--- a/app-shells/sandboxshell/sandboxshell-0.1.ebuild
+++ b/app-shells/sandboxshell/sandboxshell-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/sandboxshell-0.1.ebuild,v 1.1 2003/07/09 14:53:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/sandboxshell-0.1.ebuild,v 1.2 2003/08/01 03:45:50 vapier Exp $
DESCRIPTION="launch a sandboxed shell ... useful for debugging ebuilds"
HOMEPAGE="http://wh0rd.org/"
@@ -19,6 +19,7 @@ S=${WORKDIR}
src_install() {
dobin ${FILESDIR}/sandboxshell
+ domain ${FILESDIR}/sandboxshell.1
insinto /etc
doins ${FILESDIR}/sandboxshell.conf
}