summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-27 17:31:12 +0000
committerMichał Górny <mgorny@gentoo.org>2014-08-27 17:31:12 +0000
commit979f8bbbe0e02415ffbfe783db2a477465e99b71 (patch)
tree2d851b197aa64cd85e8d9fe78c7d2ede2df1bf9b /app-shells
parentMask new bash-completion for testing, documentation work and bugfixing. (diff)
downloadgentoo-2-979f8bbbe0e02415ffbfe783db2a477465e99b71.tar.gz
gentoo-2-979f8bbbe0e02415ffbfe783db2a477465e99b71.tar.bz2
gentoo-2-979f8bbbe0e02415ffbfe783db2a477465e99b71.zip
Introduce a first work-in-progress (masked) version using upstream layout and autoloading. It comes with Gentoo-specific blacklisting support and a new bash-completion module for it.
(Portage version: 2.2.11_p165/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog9
-rw-r--r--app-shells/bash-completion/bash-completion-2.1-r90.ebuild73
2 files changed, 81 insertions, 1 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 374ea95e8d58..791336fc70f6 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.262 2014/08/27 08:13:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.263 2014/08/27 17:31:12 mgorny Exp $
+
+*bash-completion-2.1-r90 (27 Aug 2014)
+
+ 27 Aug 2014; Michał Górny <mgorny@gentoo.org> +bash-completion-2.1-r90.ebuild:
+ Introduce a first work-in-progress (masked) version using upstream layout and
+ autoloading. It comes with Gentoo-specific blacklisting support and a new
+ bash-completion module for it.
*bash-completion-2.1-r1 (27 Aug 2014)
diff --git a/app-shells/bash-completion/bash-completion-2.1-r90.ebuild b/app-shells/bash-completion/bash-completion-2.1-r90.ebuild
new file mode 100644
index 000000000000..8b9bfa9b0e33
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-2.1-r90.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-2.1-r90.ebuild,v 1.1 2014/08/27 17:31:12 mgorny Exp $
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="http://bash-completion.alioth.debian.org/"
+SRC_URI="http://bash-completion.alioth.debian.org/files/${P}.tar.bz2
+ http://dev.gentoo.org/~mgorny/dist/bashcomp2-pre1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+RDEPEND="|| ( >=app-shells/bash-4.1 app-shells/zsh )
+ sys-apps/miscfiles
+ !app-admin/eselect-bashcomp"
+
+src_prepare() {
+ epatch "${WORKDIR}"/bashcomp2-pre1/*.patch
+}
+
+src_test() { :; } # Skip testsuite because of interactive shell wrt #477066
+
+src_install() {
+ default
+
+ # use the copies from >=sys-apps/util-linux-2.23 wrt #468544 -> hd and ncal
+ # becomes dead symlinks as a result
+ local file
+ for file in cal dmesg eject hd hexdump hwclock ionice look ncal renice rtcwake; do
+ rm "${ED}"/usr/share/bash-completion/completions/${file} || die
+ done
+
+ # use the copy from app-editors/vim-core:
+ rm "${ED}"/usr/share/bash-completion/completions/xxd || die
+
+ # use the copy from net-misc/networkmanager:
+ rm "${ED}"/usr/share/bash-completion/completions/nmcli || die
+
+ dodoc AUTHORS CHANGES README
+
+ # install the eselect module
+ insinto /usr/share/eselect/modules
+ doins "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect
+ doman "${WORKDIR}"/bashcomp2-pre1/bashcomp.eselect.5
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.1-r90 ${v}; then
+ ewarn "For bash-completion autoloader to work, all completions need to"
+ ewarn "be installed in /usr/share/bash-completion/completions. You may"
+ ewarn "need to rebuild packages that installed completions in the old"
+ ewarn "location. You can do this using:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
+ fi
+ done
+
+ if has_version 'app-shells/zsh'; then
+ elog
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ elog
+ fi
+}