summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-05-18 10:06:59 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-05-18 10:06:59 +0000
commita594b407147fadefaad13303bfff67440d19b32c (patch)
tree1f735b0cdf9a48374ea799350b85519d5b7a49ce /app-shells
parentVersion bump. Removed old (diff)
downloadgentoo-2-a594b407147fadefaad13303bfff67440d19b32c.tar.gz
gentoo-2-a594b407147fadefaad13303bfff67440d19b32c.tar.bz2
gentoo-2-a594b407147fadefaad13303bfff67440d19b32c.zip
Version bump. Removed old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/bash-4.3_p11-r5.ebuild238
-rw-r--r--app-shells/bash/bash-4.3_p18.ebuild (renamed from app-shells/bash/bash-4.3_p11-r4.ebuild)7
-rw-r--r--app-shells/bash/files/bash-4.3-bind-compound-arry.patch10
-rw-r--r--app-shells/bash/files/bash-4.3-complete-dequoting.patch26
-rw-r--r--app-shells/bash/files/bash-4.3-extglob-directory.patch100
-rw-r--r--app-shells/bash/files/bash-4.3-jobs-run-sigchld-trap.patch12
-rw-r--r--app-shells/bash/files/bash-4.3-localvar-invisible.patch18
8 files changed, 8 insertions, 411 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index d57f24376161..21ba5b4ae9b5 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.370 2014/05/14 07:08:53 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.371 2014/05/18 10:06:59 polynomial-c Exp $
+
+*bash-4.3_p18 (18 May 2014)
+
+ 18 May 2014; Lars Wendler <polynomial-c@gentoo.org> -bash-4.3_p11-r4.ebuild,
+ -bash-4.3_p11-r5.ebuild, +bash-4.3_p18.ebuild:
+ Version bump. Removed old.
14 May 2014; Lars Wendler <polynomial-c@gentoo.org> bash-4.3_p11-r5.ebuild,
+files/bash-4.3-bind-compound-arry.patch,
diff --git a/app-shells/bash/bash-4.3_p11-r5.ebuild b/app-shells/bash/bash-4.3_p11-r5.ebuild
deleted file mode 100644
index 1820d598dae5..000000000000
--- a/app-shells/bash/bash-4.3_p11-r5.ebuild
+++ /dev/null
@@ -1,238 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p11-r5.ebuild,v 1.2 2014/05/14 07:08:53 polynomial-c Exp $
-
-EAPI="4"
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-# Official patchlevel
-# See ftp://ftp.cwru.edu/pub/bash/bash-4.3-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_PV=${MY_PV/_/-}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-patches() {
- local opt=$1 plevel=${2:-${PLEVEL}} pn=${3:-${PN}} pv=${4:-${MY_PV}}
- [[ ${plevel} -eq 0 ]] && return 1
- eval set -- {1..${plevel}}
- set -- $(printf "${pn}${pv/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${pn} ; do
- printf "${u}/${pn}-${pv}-patches/%s " "$@"
- done
- fi
-}
-
-# The version of readline this bash normally ships with.
-READLINE_VER="6.3"
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://tiswww.case.edu/php/chet/bash/bashtop.html"
-SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
-[[ ${PV} == *_rc* ]] && SRC_URI+=" ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="afs bashlogger examples mem-scramble +net nls plugins +readline vanilla"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-${READLINE_VER} )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}
- !<sys-apps/portage-2.1.6.7_p1
- !<sys-apps/paludis-0.26.0_alpha5"
-# we only need yacc when the .y files get patched (bash42-005)
-DEPEND+=" virtual/yacc"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if is-flag -malign-double ; then #7332
- eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
- eerror "as it breaks LFS (struct stat64) on x86."
- die "remove -malign-double from your CFLAGS mr ricer"
- fi
- if use bashlogger ; then
- ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
- ewarn "This will log ALL output you enter into the shell, you have been warned."
- fi
-}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-}
-
-src_prepare() {
- # Include official patches
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
-
- # Clean out local libs so we know we use system ones w/releases.
- if [[ ${PV} != *_rc* ]] ; then
- rm -rf lib/{readline,termcap}/*
- touch lib/{readline,termcap}/Makefile.in # for config.status
- sed -ri -e 's:\$[(](RL|HIST)_LIBSRC[)]/[[:alpha:]]*.h::g' Makefile.in || die
- fi
-
- # Avoid regenerating docs after patches #407985
- sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
- touch -r . doc/*
-
- epatch "${FILESDIR}"/${PN}-4.3-jobs-run-sigchld-trap.patch \
- "${FILESDIR}"/${PN}-4.3-complete-dequoting.patch \
- "${FILESDIR}"/${PN}-4.3-extglob-directory.patch \
- "${FILESDIR}"/${PN}-4.3-localvar-invisible.patch \
- "${FILESDIR}"/${PN}-4.3-bind-compound-arry.patch
-
- epatch_user
-}
-
-src_configure() {
- local myconf=()
-
- # For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
- append-cppflags \
- -DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
- -DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
- -DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
- -DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
- -DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC \
- $(use bashlogger && echo -DSYSLOG_HISTORY)
-
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf+=( --disable-nls )
-
- # Historically, we always used the builtin readline, but since
- # our handling of SONAME upgrades has gotten much more stable
- # in the PM (and the readline ebuild itself preserves the old
- # libs during upgrades), linking against the system copy should
- # be safe.
- # Exact cached version here doesn't really matter as long as it
- # is at least what's in the DEPEND up above.
- export ac_cv_rl_version=${READLINE_VER}
-
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
-
- if [[ ${PV} != *_rc* ]] ; then
- # Use system readline only with released versions.
- myconf+=( --with-installed-readline=. )
- fi
-
- use plugins && append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
- tc-export AR #444070
- econf \
- --docdir='$(datarootdir)'/doc/${PF} \
- --htmldir='$(docdir)/html' \
- --with-curses \
- $(use_with afs) \
- $(use_enable net net-redirections) \
- --disable-profiling \
- $(use_enable mem-scramble) \
- $(use_with mem-scramble bash-malloc) \
- $(use_enable readline) \
- $(use_enable readline history) \
- $(use_enable readline bang-history) \
- "${myconf[@]}"
-}
-
-src_compile() {
- emake
-
- if use plugins ; then
- emake -C examples/loadables all others
- fi
-}
-
-src_install() {
- local d f
-
- default
-
- dodir /bin
- mv "${ED}"/usr/bin/bash "${ED}"/bin/ || die
- dosym bash /bin/rbash
-
- insinto /etc/bash
- doins "${FILESDIR}"/{bashrc,bash_logout}
- insinto /etc/skel
- for f in bash{_logout,_profile,rc} ; do
- newins "${FILESDIR}"/dot-${f} .${f}
- done
-
- local sed_args=(
- -e "s:#${USERLAND}#@::"
- -e '/#@/d'
- )
- if ! use readline ; then
- sed_args+=( #432338
- -e '/^shopt -s histappend/s:^:#:'
- -e 's:use_color=true:use_color=false:'
- )
- fi
- sed -i \
- "${sed_args[@]}" \
- "${ED}"/etc/skel/.bashrc \
- "${ED}"/etc/bash/bashrc || die
-
- if use plugins ; then
- exeinto /usr/$(get_libdir)/bash
- doexe $(echo examples/loadables/*.o | sed 's:\.o::g')
- insinto /usr/include/bash-plugins
- doins *.h builtins/*.h examples/loadables/*.h include/*.h \
- lib/{glob/glob.h,tilde/tilde.h}
- fi
-
- if use examples ; then
- for d in examples/{functions,misc,scripts,scripts.noah,scripts.v2} ; do
- exeinto /usr/share/doc/${PF}/${d}
- insinto /usr/share/doc/${PF}/${d}
- for f in ${d}/* ; do
- if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
- doexe ${f}
- else
- doins ${f}
- fi
- done
- done
- fi
-
- doman doc/*.1
- newdoc CWRU/changelog ChangeLog
- dosym bash.info /usr/share/info/bashref.info
-}
-
-pkg_preinst() {
- if [[ -e ${EROOT}/etc/bashrc ]] && [[ ! -d ${EROOT}/etc/bash ]] ; then
- mkdir -p "${EROOT}"/etc/bash
- mv -f "${EROOT}"/etc/bashrc "${EROOT}"/etc/bash/
- fi
-
- if [[ -L ${EROOT}/bin/sh ]] ; then
- # rewrite the symlink to ensure that its mtime changes. having /bin/sh
- # missing even temporarily causes a fatal error with paludis.
- local target=$(readlink "${EROOT}"/bin/sh)
- local tmp=$(emktemp "${EROOT}"/bin)
- ln -sf "${target}" "${tmp}"
- mv -f "${tmp}" "${EROOT}"/bin/sh
- fi
-}
-
-pkg_postinst() {
- # If /bin/sh does not exist, provide it
- if [[ ! -e ${EROOT}/bin/sh ]] ; then
- ln -sf bash "${EROOT}"/bin/sh
- fi
-}
diff --git a/app-shells/bash/bash-4.3_p11-r4.ebuild b/app-shells/bash/bash-4.3_p18.ebuild
index b5a0d9f8e52c..64f8a2d61b11 100644
--- a/app-shells/bash/bash-4.3_p11-r4.ebuild
+++ b/app-shells/bash/bash-4.3_p18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p11-r4.ebuild,v 1.1 2014/05/07 15:28:10 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.3_p18.ebuild,v 1.1 2014/05/18 10:06:59 polynomial-c Exp $
EAPI="4"
@@ -83,11 +83,6 @@ src_prepare() {
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/*
- epatch "${FILESDIR}"/${PN}-4.3-jobs-run-sigchld-trap.patch \
- "${FILESDIR}"/${PN}-4.3-complete-dequoting.patch \
- "${FILESDIR}"/${PN}-4.3-extglob-directory.patch \
- "${FILESDIR}"/${PN}-4.3-localvar-invisible.patch
-
epatch_user
}
diff --git a/app-shells/bash/files/bash-4.3-bind-compound-arry.patch b/app-shells/bash/files/bash-4.3-bind-compound-arry.patch
deleted file mode 100644
index c46bc33eca5b..000000000000
--- a/app-shells/bash/files/bash-4.3-bind-compound-arry.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-*** ../bash-4.3-patched/arrayfunc.c 2014-03-28 10:54:21.000000000 -0400
---- arrayfunc.c 2014-05-12 11:19:00.000000000 -0400
-***************
-*** 180,183 ****
---- 180,184 ----
- FREE (newval);
-
-+ VUNSETATTR (entry, att_invisible); /* no longer invisible */
- return (entry);
- }
diff --git a/app-shells/bash/files/bash-4.3-complete-dequoting.patch b/app-shells/bash/files/bash-4.3-complete-dequoting.patch
deleted file mode 100644
index 498d9cfb48d2..000000000000
--- a/app-shells/bash/files/bash-4.3-complete-dequoting.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-*** ../bash-4.3-patched/bashline.c 2014-02-09 19:56:58.000000000 -0500
---- bashline.c 2014-04-25 14:57:52.000000000 -0400
-***************
-*** 4168,4174 ****
-
- qc = rl_dispatching ? rl_completion_quote_character : 0;
-! dfn = bash_dequote_filename ((char *)text, qc);
- m1 = rl_completion_matches (dfn, rl_filename_completion_function);
-! free (dfn);
-
- if (m1 == 0 || m1[0] == 0)
---- 4209,4222 ----
-
- qc = rl_dispatching ? rl_completion_quote_character : 0;
-! /* If rl_completion_found_quote != 0, rl_completion_matches will call the
-! filename dequoting function, causing the directory name to be dequoted
-! twice. */
-! if (rl_dispatching && rl_completion_found_quote == 0)
-! dfn = bash_dequote_filename ((char *)text, qc);
-! else
-! dfn = (char *)text;
- m1 = rl_completion_matches (dfn, rl_filename_completion_function);
-! if (dfn != text)
-! free (dfn);
-
- if (m1 == 0 || m1[0] == 0)
diff --git a/app-shells/bash/files/bash-4.3-extglob-directory.patch b/app-shells/bash/files/bash-4.3-extglob-directory.patch
deleted file mode 100644
index aa3e49a09114..000000000000
--- a/app-shells/bash/files/bash-4.3-extglob-directory.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-*** ../bash-4.3-patched/lib/glob/glob.c 2014-03-28 10:54:23.000000000 -0400
---- lib/glob/glob.c 2014-05-02 10:24:28.000000000 -0400
-***************
-*** 124,127 ****
---- 124,129 ----
- extern wchar_t *glob_patscan_wc __P((wchar_t *, wchar_t *, int));
-
-+ extern char *glob_dirscan __P((char *, int));
-+
- /* Compile `glob_loop.c' for single-byte characters. */
- #define CHAR unsigned char
-***************
-*** 188,191 ****
---- 190,196 ----
- pe = glob_patscan (pp, se, 0); /* end of extglob pattern (( */
- /* we should check for invalid extglob pattern here */
-+ if (pe == 0)
-+ return 0;
-+
- /* if pe != se we have more of the pattern at the end of the extglob
- pattern. Check the easy case first ( */
-***************
-*** 1016,1020 ****
- char **result;
- unsigned int result_size;
-! char *directory_name, *filename, *dname;
- unsigned int directory_len;
- int free_dirname; /* flag */
---- 1021,1025 ----
- char **result;
- unsigned int result_size;
-! char *directory_name, *filename, *dname, *fn;
- unsigned int directory_len;
- int free_dirname; /* flag */
-***************
-*** 1032,1035 ****
---- 1037,1052 ----
- /* Find the filename. */
- filename = strrchr (pathname, '/');
-+ #if defined (EXTENDED_GLOB)
-+ if (filename && extended_glob)
-+ {
-+ fn = glob_dirscan (pathname, '/');
-+ #if DEBUG_MATCHING
-+ if (fn != filename)
-+ fprintf (stderr, "glob_filename: glob_dirscan: fn (%s) != filename (%s)\n", fn ? fn : "(null)", filename);
-+ #endif
-+ filename = fn;
-+ }
-+ #endif
-+
- if (filename == NULL)
- {
-*** ../bash-4.3-patched/lib/glob/gmisc.c 2014-03-28 10:54:23.000000000 -0400
---- lib/glob/gmisc.c 2014-05-02 09:35:57.000000000 -0400
-***************
-*** 43,46 ****
---- 43,48 ----
- #define WRPAREN L')'
-
-+ extern char *glob_patscan __P((char *, char *, int));
-+
- /* Return 1 of the first character of WSTRING could match the first
- character of pattern WPAT. Wide character version. */
-***************
-*** 376,377 ****
---- 378,410 ----
- return matlen;
- }
-+
-+ /* Skip characters in PAT and return the final occurrence of DIRSEP. This
-+ is only called when extended_glob is set, so we have to skip over extglob
-+ patterns x(...) */
-+ char *
-+ glob_dirscan (pat, dirsep)
-+ char *pat;
-+ int dirsep;
-+ {
-+ char *p, *d, *pe, *se;
-+
-+ d = pe = se = 0;
-+ for (p = pat; p && *p; p++)
-+ {
-+ if (extglob_pattern_p (p))
-+ {
-+ if (se == 0)
-+ se = p + strlen (p) - 1;
-+ pe = glob_patscan (p + 2, se, 0);
-+ if (pe == 0)
-+ continue;
-+ else if (*pe == 0)
-+ break;
-+ p = pe - 1; /* will do increment above */
-+ continue;
-+ }
-+ if (*p == dirsep)
-+ d = p;
-+ }
-+ return d;
-+ }
diff --git a/app-shells/bash/files/bash-4.3-jobs-run-sigchld-trap.patch b/app-shells/bash/files/bash-4.3-jobs-run-sigchld-trap.patch
deleted file mode 100644
index c97c5aeac6e0..000000000000
--- a/app-shells/bash/files/bash-4.3-jobs-run-sigchld-trap.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-https://lists.gnu.org/archive/html/bug-bash/2014-04/msg00061.html
-
-*** ../bash-4.3-patched/jobs.c 2014-03-28 10:54:19.000000000 -0400
---- jobs.c 2014-04-15 08:47:03.000000000 -0400
-***************
-*** 3598,3601 ****
---- 3598,3602 ----
- unwind_protect_pointer (the_pipeline);
- unwind_protect_pointer (subst_assign_varlist);
-+ unwind_protect_pointer (this_shell_builtin);
-
- /* We have to add the commands this way because they will be run
diff --git a/app-shells/bash/files/bash-4.3-localvar-invisible.patch b/app-shells/bash/files/bash-4.3-localvar-invisible.patch
deleted file mode 100644
index dbfffbbf4cf5..000000000000
--- a/app-shells/bash/files/bash-4.3-localvar-invisible.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-*** ../bash-4.3-patched/variables.c 2014-02-14 11:55:12.000000000 -0500
---- variables.c 2014-05-07 10:53:57.000000000 -0400
-***************
-*** 2198,2205 ****
- old_var = find_variable (name);
- if (old_var && local_p (old_var) && old_var->context == variable_context)
-! {
-! VUNSETATTR (old_var, att_invisible); /* XXX */
-! return (old_var);
-! }
-
- was_tmpvar = old_var && tempvar_p (old_var);
---- 2260,2264 ----
- old_var = find_variable (name);
- if (old_var && local_p (old_var) && old_var->context == variable_context)
-! return (old_var);
-
- was_tmpvar = old_var && tempvar_p (old_var);