summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-11-17 12:47:47 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-11-17 12:47:47 +0000
commitae7e15a295e29cdc21d4d6de0f2c3b8231a6ec17 (patch)
tree5eb319d74339986d084770aeb367d7d3ef987524 /app-shells
parentVersion bump. (diff)
downloadgentoo-2-ae7e15a295e29cdc21d4d6de0f2c3b8231a6ec17.tar.gz
gentoo-2-ae7e15a295e29cdc21d4d6de0f2c3b8231a6ec17.tar.bz2
gentoo-2-ae7e15a295e29cdc21d4d6de0f2c3b8231a6ec17.zip
Security bump (bug #509044). Removed old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/ChangeLog8
-rw-r--r--app-shells/fish/fish-2.1.1.ebuild (renamed from app-shells/fish/fish-2.0.0.ebuild)26
2 files changed, 29 insertions, 5 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index a4a4d2be5be6..7ca7d95539cb 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/fish
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.68 2014/08/09 12:12:09 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.69 2014/11/17 12:47:47 polynomial-c Exp $
+
+*fish-2.1.1 (17 Nov 2014)
+
+ 17 Nov 2014; Lars Wendler <polynomial-c@gentoo.org> -fish-2.0.0.ebuild,
+ +fish-2.1.1.ebuild:
+ Security bump (bug #509044). Removed old.
09 Aug 2014; Agostino Sarubbo <ago@gentoo.org> fish-2.1.0-r2.ebuild:
Stable for ppc, wrt bug #493316
diff --git a/app-shells/fish/fish-2.0.0.ebuild b/app-shells/fish/fish-2.1.1.ebuild
index 358fdf240874..cd0e5fec65ae 100644
--- a/app-shells/fish/fish-2.0.0.ebuild
+++ b/app-shells/fish/fish-2.1.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-2.0.0.ebuild,v 1.5 2014/02/11 12:28:14 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-2.1.1.ebuild,v 1.1 2014/11/17 12:47:47 polynomial-c Exp $
EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
inherit base autotools
DESCRIPTION="fish is the Friendly Interactive SHell"
@@ -12,18 +14,21 @@ SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="X"
DEPEND="sys-libs/ncurses
sys-devel/bc
sys-devel/gettext
X? ( x11-misc/xsel )"
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}"
+# fish can add man-page completions from lzma and xz compressed man pages
+# through a python script. That's why we depend on python here (bug #490478)
+RDEPEND="${DEPEND}"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.0-tinfo.patch #459768
+
eautoreconf
}
@@ -36,6 +41,14 @@ src_configure() {
--bindir="${EPREFIX}"/bin
}
+src_test() {
+ if has_version ~${CATEGORY}/${P} ; then
+ emake test
+ else
+ ewarn "The test suite only works when the package is already installed"
+ fi
+}
+
pkg_postinst() {
elog "fish is now installed on your system."
elog "To run fish, type 'fish' in your terminal."
@@ -53,5 +66,10 @@ pkg_postinst() {
elog "browser of your choice to get acces to ${PN}'s help system:"
elog " BROWSER=\"/usr/bin/firefox\""
elog
+ elog "In order to get lzma and xz support for man-page completion please"
+ elog "emerge one of the following packages:"
+ elog " dev-python/backports-lzma"
+ elog " >=dev-lang/python-3.3"
+ elog
elog "Have fun!"
}