summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2013-10-31 02:44:10 +0000
committerJeff Horelick <jdhore@gentoo.org>2013-10-31 02:44:10 +0000
commitf1830de58213bb7fad44e6caea50f759ac84df62 (patch)
tree82de1f68b43dad0e5893e36c20acc7ad8e4652fd /app-shells
parentversion bump for vserver fixes and starting a port to GNU/kFreeBSD for Debian. (diff)
downloadgentoo-2-f1830de58213bb7fad44e6caea50f759ac84df62.tar.gz
gentoo-2-f1830de58213bb7fad44e6caea50f759ac84df62.tar.bz2
gentoo-2-f1830de58213bb7fad44e6caea50f759ac84df62.zip
Version bump
(Portage version: 2.2.7/cvs/Linux i686, signed Manifest commit with key 23E9E900)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/ChangeLog7
-rw-r--r--app-shells/fish/fish-2.1.0.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index 4a38f95e584d..055a4796e962 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/fish
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.59 2013/09/05 19:24:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.60 2013/10/31 02:44:10 jdhore Exp $
+
+*fish-2.1.0 (31 Oct 2013)
+
+ 31 Oct 2013; Jeff Horelick <jdhore@gentoo.org> +fish-2.1.0.ebuild:
+ Version bump
05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> fish-2.0.0.ebuild:
Stable for x86, wrt bug #480226
diff --git a/app-shells/fish/fish-2.1.0.ebuild b/app-shells/fish/fish-2.1.0.ebuild
new file mode 100644
index 000000000000..d54d9ab1bd30
--- /dev/null
+++ b/app-shells/fish/fish-2.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-2.1.0.ebuild,v 1.1 2013/10/31 02:44:10 jdhore Exp $
+
+EAPI=5
+
+inherit base autotools
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bc
+ sys-devel/gettext
+ www-client/htmlview
+ X? ( x11-misc/xsel )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --bindir="${EPREFIX}"/bin
+}
+
+pkg_postinst() {
+ elog "fish is now installed on your system."
+ elog "To run fish, type 'fish' in your terminal."
+ elog
+ elog "To use fish as your login shell:"
+ elog "* add the line '${EPREFIX}/bin/${PN}'"
+ elog "* to the file '${EPREFIX}/etc/shells'."
+ elog "* use the command 'chsh -s ${EPREFIX}/bin/${PN}'."
+ elog
+ elog "To set your colors, run 'fish_config'"
+ elog "To scan your man pages for completions, run 'fish_update_completions'"
+ elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
+ elog
+ elog "Have fun!"
+}