summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2011-04-12 21:07:58 +0000
committerJonathan Callen <abcd@gentoo.org>2011-04-12 21:07:58 +0000
commita652e9053d52ca06ef150ca684ffb7c0e5c454d1 (patch)
tree1709c1dbe4ffb7b93d13aed119c506a2e03fefcf /app-text/a2ps
parentarm stable, bug #361525 (diff)
downloadgentoo-2-a652e9053d52ca06ef150ca684ffb7c0e5c454d1.tar.gz
gentoo-2-a652e9053d52ca06ef150ca684ffb7c0e5c454d1.tar.bz2
gentoo-2-a652e9053d52ca06ef150ca684ffb7c0e5c454d1.zip
Add prefix support, bump EAPI to 3, add prefix keywords
(Portage version: 2.2.0_alpha29_p11/cvs/Linux i686)
Diffstat (limited to 'app-text/a2ps')
-rw-r--r--app-text/a2ps/ChangeLog5
-rw-r--r--app-text/a2ps/a2ps-4.14-r2.ebuild18
2 files changed, 15 insertions, 8 deletions
diff --git a/app-text/a2ps/ChangeLog b/app-text/a2ps/ChangeLog
index 9f48c7dc7026..d52b7188ac5e 100644
--- a/app-text/a2ps/ChangeLog
+++ b/app-text/a2ps/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/a2ps
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.98 2011/01/10 20:39:43 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.99 2011/04/12 21:07:58 abcd Exp $
+
+ 12 Apr 2011; Jonathan Callen <abcd@gentoo.org> a2ps-4.14-r2.ebuild:
+ Add prefix support, bump EAPI to 3, add prefix keywords
*a2ps-4.14-r2 (10 Jan 2011)
diff --git a/app-text/a2ps/a2ps-4.14-r2.ebuild b/app-text/a2ps/a2ps-4.14-r2.ebuild
index feb9bbf208a3..a5cc92929827 100644
--- a/app-text/a2ps/a2ps-4.14-r2.ebuild
+++ b/app-text/a2ps/a2ps-4.14-r2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.14-r2.ebuild,v 1.1 2011/01/10 20:39:43 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.14-r2.ebuild,v 1.2 2011/04/12 21:07:58 abcd Exp $
+EAPI=3
inherit eutils autotools elisp-common
DESCRIPTION="Any to PostScript filter"
@@ -11,7 +12,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="emacs nls latex vanilla userland_BSD userland_GNU linguas_ja"
RESTRICT="test"
@@ -38,8 +39,9 @@ S="${WORKDIR}/${PN}-${PV:0:4}"
src_unpack() {
unpack ${P}.tar.gz
- cd "${S}"
+}
+src_prepare() {
epatch "${FILESDIR}/${PN}-4.13c-locale-gentoo.diff"
# this will break
#epatch "${FILESDIR}/${PN}-4.13c-stdarg.patch"
@@ -76,7 +78,7 @@ src_unpack() {
eautoreconf
}
-src_compile() {
+src_configure() {
local myconf="COM_netscape=no COM_acroread=no"
if ! use emacs ; then
@@ -90,17 +92,19 @@ src_compile() {
export LANG=C LC_ALL=C
econf \
- --sysconfdir=/etc/a2ps \
+ --sysconfdir="${EPREFIX}"/etc/a2ps \
$(use_enable nls) \
- ${myconf} || die "econf failed"
+ ${myconf}
+}
+src_compile() {
# parallel make b0rked
emake -j1 || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" \
- lispdir="${SITELISP}/${PN}" \
+ lispdir="${EPREFIX}${SITELISP}/${PN}" \
install || die "emake install failed"
if use emacs; then