summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-01-18 14:10:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-01-18 14:10:56 +0000
commit38dbe4bdc2715a5e48aa875c6e768b91743fb70e (patch)
treeab61522fc12a5299d60ac742e2cfb25b453cd206 /app-text/antiword/antiword-0.37.ebuild
parentsecurity.mask app-cdr/cdrx (diff)
downloadgentoo-2-38dbe4bdc2715a5e48aa875c6e768b91743fb70e.tar.gz
gentoo-2-38dbe4bdc2715a5e48aa875c6e768b91743fb70e.tar.bz2
gentoo-2-38dbe4bdc2715a5e48aa875c6e768b91743fb70e.zip
Version bump, which also fixes bug #119309 by Carlo. Additionally, user's optimisation flags are used during the compile, and the makefile is patched to work with gentoo's filesystem hierarchy. More makefile fixes should be on their way soon to install the man pages, at least. The future (once this version hits stable) holds that I'll incorporate more of the debian patch (just the security bit of it for kantiword.sh was used this time) and make the gantiword script as well as .desktop entries etc.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-text/antiword/antiword-0.37.ebuild')
-rw-r--r--app-text/antiword/antiword-0.37.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/antiword/antiword-0.37.ebuild b/app-text/antiword/antiword-0.37.ebuild
new file mode 100644
index 000000000000..a7cf0dabd9ce
--- /dev/null
+++ b/app-text/antiword/antiword-0.37.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/antiword-0.37.ebuild,v 1.1 2006/01/18 14:10:56 seemant Exp $
+
+inherit eutils
+
+IUSE="kde"
+PATCHVER=0.1
+DESCRIPTION="free MS Word reader"
+HOMEPAGE="http://www.winfield.demon.nl"
+SRC_URI="http://www.winfield.demon.nl/linux/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo-${PATCHVER}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+
+DEPEND="virtual/ghostscript"
+
+PATCHDIR=${WORKDIR}/gentoo-antiword/patches
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ EPATCH_SUFFIX="diff" \
+ epatch ${PATCHDIR}
+}
+
+src_compile() {
+ emake OPT="${CFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR=${D} global_install || die
+
+ use kde || rm -f ${D}/usr/bin/kantiword
+
+ insinto /usr/share/${PN}/examples
+ doins Docs/testdoc.doc Docs/antiword.php
+
+ cd Docs
+ doman antiword.1
+ dodoc COPYING ChangeLog Exmh Emacs FAQ History Netscape \
+ QandA ReadMe Mozilla Mutt
+}