summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-05-22 17:39:58 +0000
committerSebastian Pipping <sping@gentoo.org>2011-05-22 17:39:58 +0000
commitae2d3057655b3cc9cbf8646c8cfa39a6fd931e7b (patch)
treeea44755b156b3e0d15661699a07ce723b39ec16f /app-text/asciidoc
parentnet-misc/aria2: Bump to 1.11.2 (diff)
downloadgentoo-2-ae2d3057655b3cc9cbf8646c8cfa39a6fd931e7b.tar.gz
gentoo-2-ae2d3057655b3cc9cbf8646c8cfa39a6fd931e7b.tar.bz2
gentoo-2-ae2d3057655b3cc9cbf8646c8cfa39a6fd931e7b.zip
app-text/asciidoc: Bump to 8.6.5
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/ChangeLog7
-rw-r--r--app-text/asciidoc/asciidoc-8.6.5.ebuild107
2 files changed, 113 insertions, 1 deletions
diff --git a/app-text/asciidoc/ChangeLog b/app-text/asciidoc/ChangeLog
index 35922e2076b2..cb58df6739b4 100644
--- a/app-text/asciidoc/ChangeLog
+++ b/app-text/asciidoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/asciidoc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/ChangeLog,v 1.68 2011/04/05 05:05:33 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/ChangeLog,v 1.69 2011/05/22 17:39:58 sping Exp $
+
+*asciidoc-8.6.5 (22 May 2011)
+
+ 22 May 2011; Sebastian Pipping <sping@gentoo.org> +asciidoc-8.6.5.ebuild:
+ Bump to 8.6.5, looks trivial
05 Apr 2011; Ulrich Mueller <ulm@gentoo.org> asciidoc-8.2.6.ebuild:
Depend on dev-lang/python because virtual/python will go away, bug 358849.
diff --git a/app-text/asciidoc/asciidoc-8.6.5.ebuild b/app-text/asciidoc/asciidoc-8.6.5.ebuild
new file mode 100644
index 000000000000..36da3a5e464c
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-8.6.5.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/asciidoc-8.6.5.ebuild,v 1.1 2011/05/22 17:39:58 sping Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="3.*"
+
+[ "$PV" == "9999" ] && inherit mercurial autotools
+inherit python
+
+DESCRIPTION="A text document format for writing short documents, articles, books and UNIX man pages"
+HOMEPAGE="http://www.methods.co.nz/asciidoc/"
+if [ "$PV" == "9999" ]; then
+ EHG_REPO_URI="https://asciidoc.googlecode.com/hg/"
+ SRC_URI=""
+ KEYWORDS=""
+ S=${WORKDIR}/hg
+else
+ SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples highlight test vim-syntax"
+
+RDEPEND=">=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ media-gfx/graphviz
+ app-text/docbook-xml-dtd:4.5
+ highlight? ( dev-util/source-highlight )
+"
+DEPEND="test? ( dev-util/source-highlight
+ media-sound/lilypond
+ media-gfx/imagemagick
+ dev-texlive/texlive-latex
+ app-text/dvipng
+ media-gfx/graphviz )
+"
+
+if [ "$PV" == "9999" ]; then
+ DEPEND="${DEPEND}
+ dev-util/aap
+ www-client/lynx
+ dev-util/source-highlight"
+fi
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ if ! use vim-syntax; then
+ sed -i -e '/^install/s/install-vim//' Makefile.in
+ else
+ sed -i\
+ -e "/^vimdir/s:@sysconfdir@/vim:${EPREFIX}/usr/share/vim/vimfiles:" \
+ -e 's:/etc/vim::' \
+ Makefile.in || die
+ fi
+
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ "${S}/asciidoc.py" || die
+
+ [ "$PV" == "9999" ] && eautoconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_compile() {
+ default
+
+ if [ "$PV" == "9999" ]; then
+ ( cd doc && aap -f main.aap ../{CHANGELOG,README,BUGS} )
+ fi
+}
+
+src_install() {
+ use vim-syntax && dodir /usr/share/vim/vimfiles
+
+ emake DESTDIR="${D}" install || die "install failed"
+
+ python_convert_shebangs -r 2 "${D}"
+
+ if use examples; then
+ # This is a symlink to a directory
+ rm examples/website/images || die
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ dosym ../../../asciidoc/images /usr/share/doc/${PF}/examples || die
+ fi
+
+ dodoc BUGS CHANGELOG README docbook-xsl/asciidoc-docbook-xsl.txt \
+ dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt || die
+}
+
+src_test() {
+ cd tests || die
+ ASCIIDOC_PY=../asciidoc.py "$(PYTHON)" test${PN}.py update || die
+ ASCIIDOC_PY=../asciidoc.py "$(PYTHON)" test${PN}.py run || die
+}