summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 13:32:55 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 13:32:55 +0000
commit1b69604f38dbb180d06f765b6754c39df5b253ec (patch)
tree9d4c9bfbaebbc1e45d6805135050bfeefff253a2 /app-text/bibletime
parentVersion bump to 1.3.18, wrt to bug #432928 (diff)
downloadgentoo-2-1b69604f38dbb180d06f765b6754c39df5b253ec.tar.gz
gentoo-2-1b69604f38dbb180d06f765b6754c39df5b253ec.tar.bz2
gentoo-2-1b69604f38dbb180d06f765b6754c39df5b253ec.zip
Version bump wrt bug #344871, remove old. Fixes bug #418467.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'app-text/bibletime')
-rw-r--r--app-text/bibletime/ChangeLog10
-rw-r--r--app-text/bibletime/bibletime-2.6.ebuild35
-rw-r--r--app-text/bibletime/bibletime-2.9.1.ebuild50
3 files changed, 58 insertions, 37 deletions
diff --git a/app-text/bibletime/ChangeLog b/app-text/bibletime/ChangeLog
index ce2730fd6aa1..a6c9acaa44b8 100644
--- a/app-text/bibletime/ChangeLog
+++ b/app-text/bibletime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/bibletime
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.61 2010/05/16 02:03:03 beandog Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.62 2012/09/04 13:32:55 johu Exp $
+
+*bibletime-2.9.1 (04 Sep 2012)
+
+ 04 Sep 2012; Johannes Huber <johu@gentoo.org> +bibletime-2.9.1.ebuild,
+ -bibletime-2.6.ebuild:
+ Version bump wrt bug #344871, remove old. Fixes bug #418467.
*bibletime-2.6 (16 May 2010)
diff --git a/app-text/bibletime/bibletime-2.6.ebuild b/app-text/bibletime/bibletime-2.6.ebuild
deleted file mode 100644
index 1e2a57f164f5..000000000000
--- a/app-text/bibletime/bibletime-2.6.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-2.6.ebuild,v 1.1 2010/05/16 02:03:03 beandog Exp $
-
-EAPI="2"
-inherit cmake-utils
-
-DESCRIPTION="Qt4 Bible study application using the SWORD library."
-HOMEPAGE="http://www.bibletime.info/"
-SRC_URI="mirror://sourceforge/bibletime/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug"
-
-# bug 313657
-RESTRICT="test"
-
-RDEPEND=">=app-text/sword-1.6.0
- >=dev-cpp/clucene-0.9.16a
- x11-libs/qt-dbus:4
- x11-libs/qt-gui:4
- x11-libs/qt-webkit:4"
-DEPEND="${RDEPEND}
- dev-libs/boost
- x11-libs/qt-test:4"
-
-DOCS="ChangeLog README"
-
-src_configure() {
- mycmakeargs="${mycmakeargs}
- -DUSE_QT_WEBKIT=ON"
- cmake-utils_src_configure
-}
diff --git a/app-text/bibletime/bibletime-2.9.1.ebuild b/app-text/bibletime/bibletime-2.9.1.ebuild
new file mode 100644
index 000000000000..37765062d33e
--- /dev/null
+++ b/app-text/bibletime/bibletime-2.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-2.9.1.ebuild,v 1.1 2012/09/04 13:32:55 johu Exp $
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Bible study application using the SWORD library."
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/project/bibletime/BibleTime%202/BibleTime%202%20source%20code/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+# bug 313657
+# RESTRICT="test"
+
+RDEPEND="
+ >=app-text/sword-1.6.0
+ >=dev-cpp/clucene-2.3.3.4
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+ dev-libs/icu
+ net-misc/curl
+ sys-libs/zlib
+ x11-libs/qt-test:4"
+
+DOCS=( ChangeLog README )
+
+src_prepare() {
+ sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt;:" \
+ -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_WEBKIT=ON
+ )
+
+ cmake-utils_src_configure
+}