summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-27 10:50:47 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-27 10:50:47 +0000
commit69ee3122e23be67a451d4fb4a6f6b8fa731bfd49 (patch)
treeb21162081ab563ecd08650c5bbfb97d6b549afd8 /app-text/bibletime
parentAdd patch to fix possible parallel make issues, thanks to Martin von Gagern (diff)
downloadgentoo-2-69ee3122e23be67a451d4fb4a6f6b8fa731bfd49.tar.gz
gentoo-2-69ee3122e23be67a451d4fb4a6f6b8fa731bfd49.tar.bz2
gentoo-2-69ee3122e23be67a451d4fb4a6f6b8fa731bfd49.zip
Bump to 2.0.1. Lots of new deps. Fixes #274750
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/bibletime')
-rw-r--r--app-text/bibletime/ChangeLog7
-rw-r--r--app-text/bibletime/bibletime-2.0.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/app-text/bibletime/ChangeLog b/app-text/bibletime/ChangeLog
index 6eb684ade88e..9be5871fbbd5 100644
--- a/app-text/bibletime/ChangeLog
+++ b/app-text/bibletime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/bibletime
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.53 2009/05/29 14:25:49 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.54 2009/06/27 10:50:47 patrick Exp $
+
+*bibletime-2.0.1 (27 Jun 2009)
+
+ 27 Jun 2009; Patrick Lauer <patrick@gentoo.org> +bibletime-2.0.1.ebuild:
+ Bump to 2.0.1. Lots of new deps. Fixes #274750
*bibletime-2.0 (29 May 2009)
diff --git a/app-text/bibletime/bibletime-2.0.1.ebuild b/app-text/bibletime/bibletime-2.0.1.ebuild
new file mode 100644
index 000000000000..2f1f5b2e7f25
--- /dev/null
+++ b/app-text/bibletime/bibletime-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-2.0.1.ebuild,v 1.1 2009/06/27 10:50:47 patrick Exp $
+
+EAPI=2
+
+inherit cmake-utils
+
+DESCRIPTION="Qt Bible study application using the SWORD library."
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/bibletime/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=app-text/sword-1.5.10
+ dev-cpp/clucene
+ dev-libs/boost
+ >=x11-libs/qt-webkit-4.4.0:4"
+DEPEND="${RDEPEND}
+ dev-util/cmake
+ x11-libs/qt-test"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DUSE_QT_WEBKIT=ON"
+ cmake-utils_src_configure
+}