summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-08-01 10:48:21 +0000
committerPeter Volkov <pva@gentoo.org>2010-08-01 10:48:21 +0000
commitea32a03ba593d33a0871d70645a65f825adcfc81 (patch)
treeccaec7b95b044070837359013cb298671fd5cacc /app-text/dictd
parentx86 stable, bug 324077 (diff)
downloadgentoo-2-ea32a03ba593d33a0871d70645a65f825adcfc81.tar.gz
gentoo-2-ea32a03ba593d33a0871d70645a65f825adcfc81.tar.bz2
gentoo-2-ea32a03ba593d33a0871d70645a65f825adcfc81.zip
Do not use non-posix pushd/popd inside init script, bug #330679, thank ferret for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/dictd')
-rw-r--r--app-text/dictd/ChangeLog6
-rw-r--r--app-text/dictd/files/1.10.11/dictd.initd11
2 files changed, 12 insertions, 5 deletions
diff --git a/app-text/dictd/ChangeLog b/app-text/dictd/ChangeLog
index 4cebd880c3e4..e83cf2052cc7 100644
--- a/app-text/dictd/ChangeLog
+++ b/app-text/dictd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/dictd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.86 2010/05/21 15:42:12 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.87 2010/08/01 10:48:21 pva Exp $
+
+ 01 Aug 2010; Peter Volkov <pva@gentoo.org> files/1.10.11/dictd.initd:
+ Do not use non-posix pushd/popd inside init script, bug #330679, thank
+ ferret for report.
21 May 2010; Peter Volkov <pva@gentoo.org> dictd-1.11.2.ebuild:
amd64 stable, bug 310023
diff --git a/app-text/dictd/files/1.10.11/dictd.initd b/app-text/dictd/files/1.10.11/dictd.initd
index 6bf1b1c218af..f39ac119b4e4 100644
--- a/app-text/dictd/files/1.10.11/dictd.initd
+++ b/app-text/dictd/files/1.10.11/dictd.initd
@@ -1,12 +1,12 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/files/1.10.11/dictd.initd,v 1.3 2008/11/08 18:36:21 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/files/1.10.11/dictd.initd,v 1.4 2010/08/01 10:48:21 pva Exp $
DICTD_PID="/var/run/dictd.pid"
prepconfig() {
- local TMPCONF INDEXFILES CNT DNAME DICT
+ local TMPCONF INDEXFILES CNT DNAME DICT SAVEDIR
if [ ! -e "${DICTDCONF}" ]; then
eerror "Config file ${DICTDCONF} not found."
return 1
@@ -19,7 +19,9 @@ prepconfig() {
eerror "${DLIBDIR} doesn't exist, no dictionaries found."
return 1
fi
- pushd ${DLIBDIR} >/dev/null
+
+ SAVEDIR=${PWD}
+ cd "${DLIBDIR}"
INDEXFILES=$(ls *.index)
if [ -z "${INDEXFILES}" ]; then
eerror "No dictionaries found at ${DLIBDIR}."
@@ -49,7 +51,8 @@ prepconfig() {
CNT=$(expr ${CNT} + 1)
done
- popd >/dev/null
+
+ cd "${SAVEDIR}"
mv "${TMPCONF}" "${DICTDCONF}"
chown 0:dictd "${DICTDCONF}"
chmod g+r "${DICTDCONF}"