summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-10-02 08:51:04 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-10-02 08:51:04 +0000
commitfd8706ff89425af9122b056da5cde54192a460bf (patch)
treec64194473652b507de7a29b1a8ab7a10e70d3b4f /app-text/dictd
parentAdded patch to fix gcc33 multi-line issue; Closes Bug #29227; Also added gnuc... (diff)
downloadgentoo-2-fd8706ff89425af9122b056da5cde54192a460bf.tar.gz
gentoo-2-fd8706ff89425af9122b056da5cde54192a460bf.tar.bz2
gentoo-2-fd8706ff89425af9122b056da5cde54192a460bf.zip
Added patch to fix gcc33 multi-line issue; Closes Bug #29227; Also added gnuconfig support to detect sparc arch properly
Diffstat (limited to 'app-text/dictd')
-rw-r--r--app-text/dictd/ChangeLog11
-rw-r--r--app-text/dictd/Manifest4
-rw-r--r--app-text/dictd/dictd-1.8.0.ebuild16
-rw-r--r--app-text/dictd/files/dictd-1.8.0-gcc33-multiline-string-fix.patch12
4 files changed, 37 insertions, 6 deletions
diff --git a/app-text/dictd/ChangeLog b/app-text/dictd/ChangeLog
index eed2145f55f3..64ab91d16532 100644
--- a/app-text/dictd/ChangeLog
+++ b/app-text/dictd/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for app-text/dictd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.7 2003/07/11 20:35:22 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.8 2003/10/02 08:51:01 kumba Exp $
- 19 Jan 2003; Olivier Reisch <doctomoe@gentoo.org> dictd-1.8.0.ebuild:
- Added ~ppc keyword
*dictd-1.8.0 (14 Dec 2002)
+ 02 Oct 2003; Joshua Kinard <kumba@gentoo.org> dictd-1.8.0.ebuild:
+ Added a patch to fix a multi-line string issue with gcc-3.3.1. Closes Bug #29227.
+ Also added gnuconfig support in as dictd does not understand the sparc architecture.
+
+ 19 Jan 2003; Olivier Reisch <doctomoe@gentoo.org> dictd-1.8.0.ebuild:
+ Added ~ppc keyword
+
14 Dec 2002; Seemant Kulleen <seemant@gentoo.org> dictd-1.8.0.ebuild
files/digest-dictd-1.8.0 files/1.8.0/* :
diff --git a/app-text/dictd/Manifest b/app-text/dictd/Manifest
index a0bf67ce12f3..1413d2566351 100644
--- a/app-text/dictd/Manifest
+++ b/app-text/dictd/Manifest
@@ -1,6 +1,6 @@
-MD5 6d4174ac104707a367f7799737eab5a9 ChangeLog 1539
+MD5 06c0726502723c1784064ea4cd16a67c ChangeLog 1540
MD5 b601c97cf1de09b0be4ce55148f56467 dictd-1.5.5-r6.ebuild 1293
-MD5 9ffcf3220d3b35cbaad85302f4a8c8fe dictd-1.8.0.ebuild 1578
+MD5 5b83f579fe1db4edba1be320a67830e4 dictd-1.8.0.ebuild 1578
MD5 9aac19f201e5a765d5ff77a0a5ffedd3 files/digest-dictd-1.5.5-r6 63
MD5 7182349beb0e6f90f1d2c46cc8c5a3bc files/digest-dictd-1.8.0 63
MD5 a97d38377255fef9ec22c3bf4c23fd6b files/dictd-1.8.0-gcc33-multiline-string-fix.patch 542
diff --git a/app-text/dictd/dictd-1.8.0.ebuild b/app-text/dictd/dictd-1.8.0.ebuild
index 7fc1d1b22f7f..5a0d130125b9 100644
--- a/app-text/dictd/dictd-1.8.0.ebuild
+++ b/app-text/dictd/dictd-1.8.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.8.0.ebuild,v 1.8 2003/09/18 21:42:36 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.8.0.ebuild,v 1.9 2003/10/02 08:51:01 kumba Exp $
+
+inherit gnuconfig
DESCRIPTION="Dictionary Client/Server for the DICT protocol"
HOMEPAGE="http://www.dict.org/"
@@ -12,7 +14,19 @@ KEYWORDS="x86 ppc ~sparc ia64"
DEPEND="virtual/glibc"
+src_unpack() {
+ unpack ${A}
+
+ # Patch to fix a gcc-3.3.x multi-line string issue.
+ # Closes Bug #29227
+ epatch ${FILESDIR}/${P}-gcc33-multiline-string-fix.patch
+}
+
src_compile() {
+
+ # Update config.sub and config.guess so dictd understands the sparc architecture
+ gnuconfig_update
+
econf --with-etcdir=/etc/dict || die
make || die
}
diff --git a/app-text/dictd/files/dictd-1.8.0-gcc33-multiline-string-fix.patch b/app-text/dictd/files/dictd-1.8.0-gcc33-multiline-string-fix.patch
new file mode 100644
index 000000000000..05b71e2ec946
--- /dev/null
+++ b/app-text/dictd/files/dictd-1.8.0-gcc33-multiline-string-fix.patch
@@ -0,0 +1,12 @@
+--- dictd-1.8.0/dictfmt.c 2003-09-21 10:59:06.000000000 +1200
++++ dictd-1.8.0-gentoo/dictfmt.c 2003-09-21 11:18:37.000000000 +1200
+@@ -369,7 +369,7 @@
+ several words to have the same definition\n\
+ Example: autumn%%%fall can be used\n\
+ if '--headword-separator %%%' is supplied",
+-"--without-headword with this parameter supplied
++"--without-headword with this parameter supplied\n\
+ head words will not be copied to .dict file",
+ 0 };
+ const char **p = help_msg;
+