summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-06-06 14:33:13 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-06-06 14:33:13 +0000
commitf01a6bdaf1e6927d357ad45aa67414bbe8e992fd (patch)
treec334fe457ef8ae40b3342679644e67456f00bffb /app-text/diction
parentupdate metadata.xml (diff)
downloadgentoo-2-f01a6bdaf1e6927d357ad45aa67414bbe8e992fd.tar.gz
gentoo-2-f01a6bdaf1e6927d357ad45aa67414bbe8e992fd.tar.bz2
gentoo-2-f01a6bdaf1e6927d357ad45aa67414bbe8e992fd.zip
fixes for bad style and UTF-8/de stuff. Thanks to James and to: Matthias Langer in bug #131637 and bug #135485
(Portage version: 2.1_rc4-r3)
Diffstat (limited to 'app-text/diction')
-rw-r--r--app-text/diction/ChangeLog12
-rw-r--r--app-text/diction/diction-1.07-r1.ebuild36
-rw-r--r--app-text/diction/diction-1.09-r1.ebuild33
-rw-r--r--app-text/diction/files/diction-1.07-style-fail-on-bad-lang.patch18
-rw-r--r--app-text/diction/files/diction-1.09-style-fail-on-bad-lang.patch18
-rw-r--r--app-text/diction/files/digest-diction-1.07-r13
-rw-r--r--app-text/diction/files/digest-diction-1.09-r13
7 files changed, 122 insertions, 1 deletions
diff --git a/app-text/diction/ChangeLog b/app-text/diction/ChangeLog
index 8bc8d1e0df3a..691e144f5c0b 100644
--- a/app-text/diction/ChangeLog
+++ b/app-text/diction/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-text/diction
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/diction/ChangeLog,v 1.12 2006/06/01 14:25:54 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/diction/ChangeLog,v 1.13 2006/06/06 14:33:13 seemant Exp $
+
+*diction-1.09-r1 (06 Jun 2006)
+*diction-1.07-r1 (06 Jun 2006)
+
+ 06 Jun 2006; Seemant Kulleen <seemant@gentoo.org>
+ +files/diction-1.07-style-fail-on-bad-lang.patch,
+ +files/diction-1.09-style-fail-on-bad-lang.patch, -diction-1.07.ebuild,
+ +diction-1.07-r1.ebuild, -diction-1.09.ebuild, +diction-1.09-r1.ebuild:
+ fixes for bad style and UTF-8/de stuff. Thanks to James and to: Matthias
+ Langer in bug #131637 and bug #135485
01 Jun 2006; Seemant Kulleen <seemant@gentoo.org> diction-1.07.ebuild:
stabling on amd64
diff --git a/app-text/diction/diction-1.07-r1.ebuild b/app-text/diction/diction-1.07-r1.ebuild
new file mode 100644
index 000000000000..32aeb7335de8
--- /dev/null
+++ b/app-text/diction/diction-1.07-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/diction/diction-1.07-r1.ebuild,v 1.1 2006/06/06 14:33:13 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="Diction and style checkers for english and german texts"
+HOMEPAGE="http://www.gnu.org/software/diction/diction.html"
+SRC_URI="http://www.moria.de/~michael/diction/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="unicode"
+
+DEPEND="sys-devel/gettext"
+RDEPEND="virtual/libintl"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+
+ epatch ${FILESDIR}/${P}-style-fail-on-bad-lang.patch
+ if use unicode; then
+ iconv -f ISO-8859-1 -t UTF-8 de > de.new || die "charset conversion failed."
+ mv de.new de
+ fi
+}
+
+src_compile() {
+ ./configure --prefix=/usr ||die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install
+}
diff --git a/app-text/diction/diction-1.09-r1.ebuild b/app-text/diction/diction-1.09-r1.ebuild
new file mode 100644
index 000000000000..319bc844b323
--- /dev/null
+++ b/app-text/diction/diction-1.09-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/diction/diction-1.09-r1.ebuild,v 1.1 2006/06/06 14:33:13 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="Diction and style checkers for english and german texts"
+HOMEPAGE="http://www.gnu.org/software/diction/diction.html"
+SRC_URI="http://www.moria.de/~michael/diction/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="unicode"
+
+DEPEND="sys-devel/gettext"
+RDEPEND="virtual/libintl"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+
+ epatch ${FILESDIR}/${P}-style-fail-on-bad-lang.patch
+ if use unicode; then
+ iconv -f ISO-8859-1 -t UTF-8 de > de.new || die "charset conversion failed."
+ mv de.new de
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dodoc NEWS README
+}
+
diff --git a/app-text/diction/files/diction-1.07-style-fail-on-bad-lang.patch b/app-text/diction/files/diction-1.07-style-fail-on-bad-lang.patch
new file mode 100644
index 000000000000..b7538161a728
--- /dev/null
+++ b/app-text/diction/files/diction-1.07-style-fail-on-bad-lang.patch
@@ -0,0 +1,18 @@
+# Fix for problem spotted by Matthias Langer in bug #131637
+
+Index: diction-1.07/style.c
+===================================================================
+--- diction-1.07/style.c {cset 980e7b47-4932-44e5-a761-6c69c6a771e1}
++++ diction-1.07/style.c {local clone}
+@@ -894,6 +894,11 @@ int main(int argc, char *argv[]) /*{{{*/
+ }
+ /*}}}*/
+ newHit(&lengths);
++ if (strcmp(docLanguage,"de") && strcmp(docLanguage,"en"))
++ {
++ fprintf(stderr,_("style: Incorrect language option `%s'.\n"),docLanguage);
++ exit(1);
++ }
+ if (optind==argc) sentence("style",stdin,"(stdin)",style,docLanguage,0);
+ else while (optind<argc)
+ {
diff --git a/app-text/diction/files/diction-1.09-style-fail-on-bad-lang.patch b/app-text/diction/files/diction-1.09-style-fail-on-bad-lang.patch
new file mode 100644
index 000000000000..261398de8fa7
--- /dev/null
+++ b/app-text/diction/files/diction-1.09-style-fail-on-bad-lang.patch
@@ -0,0 +1,18 @@
+# Fix for problem spotted by Matthias Langer in bug #131637
+
+Index: diction-1.10/style.c
+===================================================================
+--- diction-1.10/style.c {cset f20f6f20-d7da-4aa0-9160-88cf480ce937}
++++ diction-1.10/style.c {local clone}
+@@ -911,6 +911,11 @@ int main(int argc, char *argv[]) /*{{{*/
+ }
+ /*}}}*/
+ newHit(&lengths);
++ if (strcmp(docLanguage,"de") && strcmp(docLanguage,"en"))
++ {
++ fprintf(stderr,_("style: Incorrect language option `%s'.\n"),docLanguage);
++ exit(1);
++ }
+ if (optind==argc) sentence("style",stdin,"(stdin)",style,docLanguage);
+ else while (optind<argc)
+ {
diff --git a/app-text/diction/files/digest-diction-1.07-r1 b/app-text/diction/files/digest-diction-1.07-r1
new file mode 100644
index 000000000000..be1210780988
--- /dev/null
+++ b/app-text/diction/files/digest-diction-1.07-r1
@@ -0,0 +1,3 @@
+MD5 ee0756a8bcd6b1c186b38b6c1cf8af4b diction-1.07.tar.gz 111608
+RMD160 84442bfaf9b3f42f3de0c8e403422c6794d55d73 diction-1.07.tar.gz 111608
+SHA256 ed42a38b8cc69c7251bd4a7a01d3a9ffad131c5c633449d08e6659850102915f diction-1.07.tar.gz 111608
diff --git a/app-text/diction/files/digest-diction-1.09-r1 b/app-text/diction/files/digest-diction-1.09-r1
new file mode 100644
index 000000000000..1173ddf0e689
--- /dev/null
+++ b/app-text/diction/files/digest-diction-1.09-r1
@@ -0,0 +1,3 @@
+MD5 eb82a90bbc93141f10deed301902d160 diction-1.09.tar.gz 144704
+RMD160 e4f09341a6950e905a5ba902f676b3060fedd95c diction-1.09.tar.gz 144704
+SHA256 7c17e7d80e8d494ed5409236ad6ba24ee064643175c69e0b841e31bd9762c69e diction-1.09.tar.gz 144704