summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-06-24 05:27:42 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-06-24 05:27:42 +0000
commit250f876ab497dd5f3f10e7c0b0a7b8c151b22b31 (patch)
treeb1748fc49e75b98221c941b15123aaca265017c2 /app-text/djvu
parentUSE flag change qt->qt3/qt4 bug #137785 (diff)
downloadgentoo-2-250f876ab497dd5f3f10e7c0b0a7b8c151b22b31.tar.gz
gentoo-2-250f876ab497dd5f3f10e7c0b0a7b8c151b22b31.tar.bz2
gentoo-2-250f876ab497dd5f3f10e7c0b0a7b8c151b22b31.zip
USE flag change qt->qt3/qt4 bug #137785
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'app-text/djvu')
-rw-r--r--app-text/djvu/ChangeLog7
-rw-r--r--app-text/djvu/djvu-3.5.12.ebuild10
-rw-r--r--app-text/djvu/djvu-3.5.14-r1.ebuild10
-rw-r--r--app-text/djvu/djvu-3.5.14.ebuild10
-rw-r--r--app-text/djvu/djvu-3.5.16.ebuild8
-rw-r--r--app-text/djvu/djvu-3.5.17.ebuild8
6 files changed, 29 insertions, 24 deletions
diff --git a/app-text/djvu/ChangeLog b/app-text/djvu/ChangeLog
index 30a14f937174..8f8027202671 100644
--- a/app-text/djvu/ChangeLog
+++ b/app-text/djvu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/djvu
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.42 2006/06/08 12:43:33 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.43 2006/06/24 05:27:42 cardoe Exp $
+
+ 24 Jun 2006; Doug Goldstein <cardoe@gentoo.org> djvu-3.5.12.ebuild,
+ djvu-3.5.14.ebuild, djvu-3.5.14-r1.ebuild, djvu-3.5.16.ebuild,
+ djvu-3.5.17.ebuild:
+ USE flag change qt->qt3/qt4 bug #137785
08 Jun 2006; Joseph Jezak <josejx@gentoo.org> djvu-3.5.16.ebuild:
Marked ppc stable.
diff --git a/app-text/djvu/djvu-3.5.12.ebuild b/app-text/djvu/djvu-3.5.12.ebuild
index 25be4ecd5d05..5adbad96eb82 100644
--- a/app-text/djvu/djvu-3.5.12.ebuild
+++ b/app-text/djvu/djvu-3.5.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.12.ebuild,v 1.10 2005/07/21 15:32:08 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.12.ebuild,v 1.11 2006/06/24 05:27:42 cardoe Exp $
inherit nsplugins flag-o-matic
@@ -13,10 +13,10 @@ SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 sparc ~amd64"
-IUSE="xml qt"
+IUSE="xml qt3"
DEPEND=">=media-libs/jpeg-6b-r2
- qt? ( <x11-libs/qt-4 )"
+ qt3? ( <x11-libs/qt-4 )"
S=${WORKDIR}/${MY_P}
@@ -28,7 +28,7 @@ src_compile() {
local myconf=""
use xml \
&& myconf="${myconf} --enable-xmltools"
- use qt \
+ use qt3 \
|| myconf="${myconf} --without-qt"
econf ${myconf} || die
diff --git a/app-text/djvu/djvu-3.5.14-r1.ebuild b/app-text/djvu/djvu-3.5.14-r1.ebuild
index 954d789356d1..d1d334b7fcf0 100644
--- a/app-text/djvu/djvu-3.5.14-r1.ebuild
+++ b/app-text/djvu/djvu-3.5.14-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.14-r1.ebuild,v 1.3 2005/07/21 15:32:08 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.14-r1.ebuild,v 1.4 2006/06/24 05:27:42 cardoe Exp $
inherit nsplugins flag-o-matic fdo-mime
@@ -13,11 +13,11 @@ SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
-IUSE="xml qt jpeg tiff debug threads nls nsplugin kde"
+IUSE="xml qt3 jpeg tiff debug threads nls nsplugin kde"
DEPEND="jpeg? ( >=media-libs/jpeg-6b-r2 )
tiff? ( media-libs/tiff )
- qt? ( <x11-libs/qt-4 )"
+ qt3? ( <x11-libs/qt-4 )"
S=${WORKDIR}/${MY_P}
@@ -44,7 +44,7 @@ src_compile() {
econf --enable-desktopfiles \
$(use_enable xml xmltools) \
- $(use_with qt) \
+ $(use_with qt3 qt) \
$(use_with jpeg) \
$(use_with tiff) \
$(use_enable threads) \
diff --git a/app-text/djvu/djvu-3.5.14.ebuild b/app-text/djvu/djvu-3.5.14.ebuild
index c9585136a7a1..e3e1f34c519f 100644
--- a/app-text/djvu/djvu-3.5.14.ebuild
+++ b/app-text/djvu/djvu-3.5.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.14.ebuild,v 1.7 2005/07/21 15:32:08 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.14.ebuild,v 1.8 2006/06/24 05:27:42 cardoe Exp $
inherit nsplugins flag-o-matic
@@ -13,10 +13,10 @@ SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 sparc amd64 ppc"
-IUSE="xml qt"
+IUSE="xml qt3"
DEPEND=">=media-libs/jpeg-6b-r2
- qt? ( <x11-libs/qt-4 )"
+ qt3? ( <x11-libs/qt-4 )"
S=${WORKDIR}/${MY_P}
@@ -28,7 +28,7 @@ src_compile() {
local myconf=""
use xml \
&& myconf="${myconf} --enable-xmltools"
- use qt \
+ use qt3 \
|| myconf="${myconf} --without-qt"
econf ${myconf} || die "econf failed"
diff --git a/app-text/djvu/djvu-3.5.16.ebuild b/app-text/djvu/djvu-3.5.16.ebuild
index 4d3fe636ab82..5aaa26cca46d 100644
--- a/app-text/djvu/djvu-3.5.16.ebuild
+++ b/app-text/djvu/djvu-3.5.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.16.ebuild,v 1.13 2006/06/08 12:43:33 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.16.ebuild,v 1.14 2006/06/24 05:27:42 cardoe Exp $
inherit nsplugins flag-o-matic fdo-mime eutils multilib toolchain-funcs
@@ -13,11 +13,11 @@ SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ia64 ppc ppc64 sparc x86"
-IUSE="xml qt jpeg tiff debug threads nls nsplugin kde"
+IUSE="xml qt3 jpeg tiff debug threads nls nsplugin kde"
DEPEND="jpeg? ( >=media-libs/jpeg-6b-r2 )
tiff? ( media-libs/tiff )
- qt? ( <x11-libs/qt-4 )"
+ qt3? ( <x11-libs/qt-4 )"
S=${WORKDIR}/${MY_P}
@@ -49,7 +49,7 @@ src_compile() {
fi
# When enabling qt it must be compiled with threads. See bug #89544.
- if use qt ; then
+ if use qt3 ; then
QTCONF=" --with-qt --enable-threads "
elif use threads ; then
QTCONF=" --enable-threads "
diff --git a/app-text/djvu/djvu-3.5.17.ebuild b/app-text/djvu/djvu-3.5.17.ebuild
index 1f61e082469c..2524f6bb0254 100644
--- a/app-text/djvu/djvu-3.5.17.ebuild
+++ b/app-text/djvu/djvu-3.5.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.17.ebuild,v 1.4 2006/06/02 07:33:38 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.17.ebuild,v 1.5 2006/06/24 05:27:42 cardoe Exp $
inherit nsplugins flag-o-matic fdo-mime eutils multilib toolchain-funcs
@@ -13,11 +13,11 @@ SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="xml qt jpeg tiff debug threads nls nsplugin kde"
+IUSE="xml qt3 jpeg tiff debug threads nls nsplugin kde"
DEPEND="jpeg? ( >=media-libs/jpeg-6b-r2 )
tiff? ( media-libs/tiff )
- qt? ( <x11-libs/qt-4 )"
+ qt3? ( <x11-libs/qt-4 )"
S="${WORKDIR}/${MY_P}"
@@ -45,7 +45,7 @@ src_compile() {
fi
# When enabling qt it must be compiled with threads. See bug #89544.
- if use qt ; then
+ if use qt3 ; then
QTCONF=" --with-qt --enable-threads "
elif use threads ; then
QTCONF=" --enable-threads "