summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-08-04 04:25:45 +0000
committerMamoru Komachi <usata@gentoo.org>2003-08-04 04:25:45 +0000
commit5b7da7046d70fe399238a7cd814e8419dd178bc3 (patch)
treed861f676bded41e5fd7df65b430abf0f55ddf745 /app-text/dvipdfmx
parentnew ebuild, closing bug #23126 (diff)
downloadgentoo-2-5b7da7046d70fe399238a7cd814e8419dd178bc3.tar.gz
gentoo-2-5b7da7046d70fe399238a7cd814e8419dd178bc3.tar.bz2
gentoo-2-5b7da7046d70fe399238a7cd814e8419dd178bc3.zip
new ebuild, closing bug #23126
Diffstat (limited to 'app-text/dvipdfmx')
-rw-r--r--app-text/dvipdfmx/ChangeLog9
-rw-r--r--app-text/dvipdfmx/Manifest3
-rw-r--r--app-text/dvipdfmx/dvipdfmx-20030728.ebuild78
-rw-r--r--app-text/dvipdfmx/files/digest-dvipdfmx-200307281
4 files changed, 90 insertions, 1 deletions
diff --git a/app-text/dvipdfmx/ChangeLog b/app-text/dvipdfmx/ChangeLog
new file mode 100644
index 000000000000..3b90ed077d9a
--- /dev/null
+++ b/app-text/dvipdfmx/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-text/dvipdfmx
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvipdfmx/ChangeLog,v 1.1 2003/08/04 04:25:38 usata Exp $
+
+*dvipdfmx-20030728 (04 Aug 2003)
+
+ 04 Aug 2003; Mamoru KOMACHI <usata@gentoo.org> dvipdfmx-20030728.ebuild:
+ Initial import. This closes bug #23126.
+
diff --git a/app-text/dvipdfmx/Manifest b/app-text/dvipdfmx/Manifest
index eeff26681aed..70d3fbbe1b2c 100644
--- a/app-text/dvipdfmx/Manifest
+++ b/app-text/dvipdfmx/Manifest
@@ -1,2 +1,3 @@
-MD5 3f77ff72baa5edee82b6e01495326f1f dvipdfmx-20030728.ebuild 1832
+MD5 e42269a52da70006c2de50f742512998 dvipdfmx-20030728.ebuild 1835
+MD5 3ee2fed283cfe0d6d31a38fcd6def4d4 ChangeLog 368
MD5 92c72fa573cc873b27c1b85ef1d058ea files/digest-dvipdfmx-20030728 69
diff --git a/app-text/dvipdfmx/dvipdfmx-20030728.ebuild b/app-text/dvipdfmx/dvipdfmx-20030728.ebuild
new file mode 100644
index 000000000000..6edbf33c69c3
--- /dev/null
+++ b/app-text/dvipdfmx/dvipdfmx-20030728.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvipdfmx/dvipdfmx-20030728.ebuild,v 1.1 2003/08/04 04:25:38 usata Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="DVI to PDF translator with multi-byte character support"
+SRC_URI="http://project.ktug.or.kr/dvipdfmx/snapshot/${P}.tar.gz"
+HOMEPAGE="http://project.ktug.or.kr/dvipdfmx/"
+
+KEYWORDS="~x86 ~alpha ~ppc ~sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/tetex
+ >=sys-apps/sed-4
+ >=media-libs/libpng-1.2.1
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/openssl-0.9.6i"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_install () {
+ einstall || die
+
+ dodoc BUGS COPYING ChangeLog FONTMAP INSTALL README TODO
+}
+
+pkg_postinst () {
+ #einfo
+ #einfo "You need modify /usr/share/texmf/web2c/texmf.cnf"
+ #einfo "in order to convert DVI correctly."
+ #einfo "For example, if you have Acrobat Reader 5 and"
+ #einfo "Asian fonts installed, you may want to add"
+ #einfo
+ #einfo "CMAPINPUTS = .;/opt/Acrobat5/Resource/Font//"
+ #einfo
+ #einfo "If you have xpdf installed,"
+ #einfo
+ #einfo "you may want to add"
+ #einfo
+ #einfo "CMAPINPUTS = .;/usr/share/xpdf//"
+ #einfo
+ #einfo "respectively."
+ #einfo
+
+ einfo
+ einfo "Automatically adding CMAPINPUTS to /usr/share/texmf/web2c/texmf.cnf"
+ if [ ! `grep -q CMAPINPUTS /usr/share/texmf/web2c/texmf.cnf` ]; then
+ cat >>/usr/share/texmf/web2c/texmf.cnf<<-EOF
+ % automatically added by ${PF}.ebuild -- do not edit by hand!
+ CMAPINPUTS = .;/opt/Acrobat5/Resource/Font//;/usr/share/xpdf//
+ % done
+ EOF
+ fi
+
+ sleep 3
+ einfo "Done."
+ einfo
+
+ mktexlsr
+}
+
+pkg_postrm () {
+ if [ -e /usr/share/texmf/web2c/texmf.cnf ] ; then
+ sed -i -e "/${PF}\.ebuild/,+2d" \
+ /usr/share/texmf/web2c/texmf.cnf
+ fi
+
+ mktexlsr
+}
diff --git a/app-text/dvipdfmx/files/digest-dvipdfmx-20030728 b/app-text/dvipdfmx/files/digest-dvipdfmx-20030728
new file mode 100644
index 000000000000..755bf6fc7728
--- /dev/null
+++ b/app-text/dvipdfmx/files/digest-dvipdfmx-20030728
@@ -0,0 +1 @@
+MD5 ec0b61506bfbbaebc917048e5981ca64 dvipdfmx-20030728.tar.gz 297460