summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2008-07-18 20:25:04 +0000
committerSerkan Kaba <serkan@gentoo.org>2008-07-18 20:25:04 +0000
commitd6a92597f8d65a8f83a13589c3e8d2a5188d8f25 (patch)
tree3dba274e6d6bcf24864b2b92062f08b2bcbb7f6d /app-text/enchant
parentAdd aspell, hunspell, zemberek USE flags for app-text/enchant. (diff)
downloadgentoo-2-d6a92597f8d65a8f83a13589c3e8d2a5188d8f25.tar.gz
gentoo-2-d6a92597f8d65a8f83a13589c3e8d2a5188d8f25.tar.bz2
gentoo-2-d6a92597f8d65a8f83a13589c3e8d2a5188d8f25.zip
Version bump. Add myself as a maintainer. Add support for zemberek-server. Drop support for ispell wrt bug #bug #132433. Fix bug #207025, bug #226213, bug #230971.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8 x86_64)
Diffstat (limited to 'app-text/enchant')
-rw-r--r--app-text/enchant/ChangeLog12
-rw-r--r--app-text/enchant/enchant-1.4.2.ebuild53
-rw-r--r--app-text/enchant/metadata.xml12
3 files changed, 74 insertions, 3 deletions
diff --git a/app-text/enchant/ChangeLog b/app-text/enchant/ChangeLog
index 80ce3b67b12d..a8bf370a9199 100644
--- a/app-text/enchant/ChangeLog
+++ b/app-text/enchant/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/enchant
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/ChangeLog,v 1.78 2007/11/27 03:38:06 jer Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/ChangeLog,v 1.79 2008/07/18 20:25:04 serkan Exp $
+
+*enchant-1.4.2 (18 Jul 2008)
+
+ 18 Jul 2008; Serkan Kaba <serkan@gentoo.org> metadata.xml,
+ +enchant-1.4.2.ebuild:
+ Version bump. Add myself as a maintainer. Add support for zemberek-server.
+ Drop support for ispell wrt bug #bug #132433. Fix bug #207025, bug
+ #226213, bug #230971.
27 Nov 2007; Jeroen Roovers <jer@gentoo.org> enchant-1.3.0.ebuild:
Stable for HPPA (bug #199322).
diff --git a/app-text/enchant/enchant-1.4.2.ebuild b/app-text/enchant/enchant-1.4.2.ebuild
new file mode 100644
index 000000000000..9055e2b8d54e
--- /dev/null
+++ b/app-text/enchant/enchant-1.4.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/enchant-1.4.2.ebuild,v 1.1 2008/07/18 20:25:04 serkan Exp $
+
+EAPI="1"
+inherit libtool confutils autotools
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="http://www.abisource.com/enchant/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aspell +hunspell zemberek"
+
+COMMON_DEPENDS=">=dev-libs/glib-2
+ aspell? ( virtual/aspell-dict )
+ hunspell? ( >=app-text/hunspell-1.2.1 )
+ zemberek? ( dev-libs/dbus-glib )"
+
+RDEPEND="${COMMON_DEPENDS}
+ zemberek? ( app-text/zemberek-server )"
+
+# libtool is needed for the install-sh to work
+DEPEND="${COMMON_DEPENDS}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ confutils_require_any aspell hunspell zemberek
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:noinst_PROGRAMS:check_PROGRAMS:' tests/Makefile.am \
+ || die "unable to remove testdefault build"
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable aspell) \
+ $(use_enable hunspell myspell) \
+ $(use_enable zemberek) \
+ --disable-ispell \
+ --with-myspell-dir=/usr/share/myspell/ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO
+}
diff --git a/app-text/enchant/metadata.xml b/app-text/enchant/metadata.xml
index 669f23da60ac..3a6ddfeda0f2 100644
--- a/app-text/enchant/metadata.xml
+++ b/app-text/enchant/metadata.xml
@@ -1,5 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>gnome-office</herd>
+ <maintainer>
+ <email>serkan@gentoo.org</email>
+ <name>Serkan Kaba</name>
+ <description>Maintainer</description>
+ </maintainer>
+ <herd>gnome-office</herd>
+ <use>
+ <flag name="aspell">Adds support for <pkg>app-text/aspell</pkg> spell checker</flag>
+ <flag name="hunspell">Adds support for <pkg>app-text/hunspell</pkg> spell checker</flag>
+ <flag name="zemberek">Adds support for <pkg>app-text/zemberek-server</pkg> spell checker server</flag>
+ </use>
</pkgmetadata>