summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-10-29 20:37:01 +0000
committerAchim Gottinger <achim@gentoo.org>2000-10-29 20:37:01 +0000
commit1b5ea6763da5b9159d10ad39b9546d33b1516d94 (patch)
tree53a0339c392d391a906ec8195b5c18f079d296ed /app-text/ghostscript
parentNow a threaded version of perl is build. The tests pass all now. (diff)
downloadgentoo-2-1b5ea6763da5b9159d10ad39b9546d33b1516d94.tar.gz
gentoo-2-1b5ea6763da5b9159d10ad39b9546d33b1516d94.tar.bz2
gentoo-2-1b5ea6763da5b9159d10ad39b9546d33b1516d94.zip
*** empty log message ***
Diffstat (limited to 'app-text/ghostscript')
-rw-r--r--app-text/ghostscript/ghostscript-6.23-r2.ebuild (renamed from app-text/ghostscript/ghostscript-6.23.ebuild)26
1 files changed, 19 insertions, 7 deletions
diff --git a/app-text/ghostscript/ghostscript-6.23.ebuild b/app-text/ghostscript/ghostscript-6.23-r2.ebuild
index 6f39e4f9bfa6..dc7124a24d96 100644
--- a/app-text/ghostscript/ghostscript-6.23.ebuild
+++ b/app-text/ghostscript/ghostscript-6.23-r2.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-6.23.ebuild,v 1.3 2000/09/15 20:08:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-6.23-r2.ebuild,v 1.1 2000/10/29 20:36:59 achim Exp $
P=ghostscript-6.23
-A="${P}.tar.gz ghostscript-fonts-std-6.0.tar.gz"
+A="${P}.tar.gz ghostscript-fonts-std-6.0.tar.gz print-4.0.0rc1.tar.gz"
A1=jpegsrc.v6b.tar.gz
A2=zlib-1.1.3.tar.gz
-A3=libpng-1.0.6.tar.gz
+A3=libpng-1.0.8.tar.gz
S=${WORKDIR}/gs6.23
DESCRIPTION="Aladin Ghostscript"
SRC_URI="http://download.sourceforge.net/ghostscript/${P}.tar.gz
- http://download.sourceforge.net/gs-fonts/ghostscript-fonts-std-6.0.tar.gz"
+ http://download.sourceforge.net/gs-fonts/ghostscript-fonts-std-6.0.tar.gz
+ http://download.sourceforge.net/gimp-print/print-4.0.0rc1.tar.gz"
src_unpack() {
unpack ${A}
@@ -30,7 +31,13 @@ src_unpack() {
unpack ${A3}
cd ../src
cp ${O}/files/all-arch.mak all-arch.mak
-
+ cd ${WORKDIR}/print-4.0.0rc1/Ghost
+ cp *.c *.h ${S}/src
+ cat contrib.mak.addon >> ${S}/src/contrib.mak
+ cd ${S}/src
+ cp unix-gcc.mak unix-gcc.mak.orig
+ sed -e "s:^DEVICE_DEVS6=:DEVICE_DEVS6=\$\(DD\)stp\.dev :" \
+ unix-gcc.mak.orig > unix-gcc.mak
}
src_compile() {
@@ -41,6 +48,8 @@ src_compile() {
sed -e "s:-O2:${CFLAGS}:" unix-gcc.mak.orig > unix-gcc.mak
cd ..
try make -f src/all-arch.mak linux prefix=/usr
+ cd ${WORKDIR}/print-4.0.0rc1/Ghost
+ try make
}
src_install() {
@@ -51,8 +60,6 @@ src_install() {
cp -a fonts ${D}/usr/share/ghostscript
cd ${S}
- prepman
-
dodir /usr/doc/${PF}
rm -rf ${D}/usr/share/ghostscript/6.23/doc
dodoc doc/README doc/PUBLIC
@@ -61,6 +68,11 @@ src_install() {
insinto /usr/share/emacs/site-lisp
doins doc/gsdoc.el
+ cd ${WORKDIR}/print-4.0.0rc1/Ghost
+ dobin escputil
+ docinto stp
+ dodoc README* COPYING ChangeLog
+ cp -a stp-interface ${D}/usr/doc/${P}/stp
}