summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-12-19 01:02:16 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-12-19 01:02:16 +0000
commitcc6d918d7fed4ad45df8dca74dc2619527b8c395 (patch)
treef0b46dad4a676fb1a9f013f7b553e66a6627a9ac /app-text/ghostview/ghostview-1.5.ebuild
parentfix updatedb (database) location (diff)
downloadgentoo-2-cc6d918d7fed4ad45df8dca74dc2619527b8c395.tar.gz
gentoo-2-cc6d918d7fed4ad45df8dca74dc2619527b8c395.tar.bz2
gentoo-2-cc6d918d7fed4ad45df8dca74dc2619527b8c395.zip
added ghostview 1.5 with AA-patch from incoming
Diffstat (limited to 'app-text/ghostview/ghostview-1.5.ebuild')
-rw-r--r--app-text/ghostview/ghostview-1.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/ghostview/ghostview-1.5.ebuild b/app-text/ghostview/ghostview-1.5.ebuild
new file mode 100644
index 000000000000..07a31927dd94
--- /dev/null
+++ b/app-text/ghostview/ghostview-1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Andreas Voegele <voegelas@users.sourceforge.net>
+# Maintainer: Mikael Hallendal <hallski@gentoo.org>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.9 2001/10/21 16:17:12 agriffis Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A PostScript viewer for X11"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/ghostview/"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+
+RDEPEND="${DEPEND}
+ >=app-text/ghostscript-6.50-r2"
+
+src_unpack() {
+ unpack ${A}
+ # This patch contains all the Debian patches and enables anti-aliasing.
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ xmkmf -a || die
+ cp Makefile Makefile.old
+ sed -e "s,all:: ghostview.\$(MANSUFFIX).html,all:: ,g" Makefile.old > Makefile
+ emake || die
+}
+
+src_install() {
+ dobin ghostview
+ newman ghostview.man ghostview.1
+ insinto /etc/X11/app-defaults
+ newins Ghostview.ad Ghostview
+ dodoc COPYING HISTORY README comments.doc
+}